aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages serveez)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages guile))

(define-public serveez
  (package
    (name "serveez")
    (version "0.3.0")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/serveez/serveez-"
                          version ".tar.lz"))
      (sha256
       (base32
        "0capm8i6fyjvh5rflxkfd07llfaa0kk4i3y836qpld9vzy49q6ky"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--enable-libserveez-install")
       #:phases
       (modify-phases %standard-phases
         (add-before 'patch-source-shebangs 'patch-test-source
           (lambda _
             (substitute*
                 (find-files "test" "^t[0-9]{3}$")
               (("/bin/sh") (which "sh")))
             #t)))))
    (native-inputs
     (list lzip))
    (inputs
     (list guile-2.2))
    (home-page "https://www.gnu.org/software/serveez/")
    (synopsis "Framework for implementing IP-based servers")
    (description
     "GNU Serveez is a server framework providing the routines necessary to
easily implement IP-based servers in your application.  It
demonstrates aspects of network programming in a portable manner,
making it convenient for both simplifying the process of adding a
server to your application or for learning about how network services
work.  Several example servers are provided already, such as an HTTP
server and an IRC server.")
    (license gpl3+)))
colas Goaziou 2021-02-19gnu: nushell: Update to 0.27.1....* gnu/packages/shells.scm (nushell): Update to 0.27.1. [arguments]: Add rust-serial-test to Cargo development inputs. (rust-nu-cli-0.27): (rust-nu-command-0.27): (rust-nu-data-0.27): (rust-nu-engine-0.27): (rust-nu-errors-0.27): (rust-nu-json-0.27): (rust-nu-parser-0.27): (rust-nu-plugin-0.27): (rust-nu-plugin-binaryview-0.27): (rust-nu-plugin-chart-0.27): (rust-nu-plugin-fetch-0.27): (rust-nu-plugin-from-bson-0.27): (rust-nu-plugin-from-sqlite-0.27): (rust-nu-plugin-inc-0.27): (rust-nu-plugin-match-0.27): (rust-nu-plugin-post-0.27): (rust-nu-plugin-ps-0.27): (rust-nu-plugin-s3-0.27): (rust-nu-plugin-selector-0.27): (rust-nu-plugin-start-0.27): (rust-nu-plugin-sys-0.27): (rust-nu-plugin-textview-0.27): (rust-nu-plugin-to-bson-0.27): (rust-nu-plugin-to-sqlite-0.27): (rust-nu-plugin-tree-0.27): (rust-nu-plugin-xpath-0.27): (rust-nu-protocol-0.27): (rust-nu-source-0.27): (rust-nu-stream-0.27): (rust-nu-table-0.27): (rust-nu-test-support-0.27): (rust-nu-value-ext-0.27): Update to 0.27.1. Nicolas Goaziou 2021-02-16gnu: nushell: Update to 0.27.0....* gnu/packages/shells.scm (nushell): Update to 0.27.0. (rust-nu-cli-0.27): (rust-nu-command-0.27): (rust-nu-data-0.27): (rust-nu-engine-0.27): (rust-nu-errors-0.27): (rust-nu-json-0.27): (rust-nu-parser-0.27): (rust-nu-plugin-0.27): (rust-nu-plugin-binaryview-0.27): (rust-nu-plugin-chart-0.27): (rust-nu-plugin-fetch-0.27): (rust-nu-plugin-from-bson-0.27): (rust-nu-plugin-from-sqlite-0.27): (rust-nu-plugin-inc-0.27): (rust-nu-plugin-match-0.27): (rust-nu-plugin-post-0.27): (rust-nu-plugin-s3-0.27): (rust-nu-plugin-sys-0.27): (rust-nu-plugin-textview-0.27): (rust-nu-plugin-to-bson-0.27): (rust-nu-plugin-to-sqlite-0.27): (rust-nu-plugin-tree-0.27): (rust-nu-plugin-xpath-0.27): (rust-nu-protocol-0.27): (rust-nu-source-0.27): (rust-nu-stream-0.27): (rust-nu-test-support-0.27): (rust-nu-value-ext-0.27): New variables. (rust-nu-cli-0.26): (rust-nu-command-0.26): (rust-nu-data-0.26): (rust-nu-engine-0.26): (rust-nu-errors-0.26): (rust-nu-json-0.26): (rust-nu-parser-0.26): (rust-nu-plugin-0.26): (rust-nu-plugin-binaryview-0.26): (rust-nu-plugin-chart-0.26): (rust-nu-plugin-fetch-0.26): (rust-nu-plugin-from-bson-0.26): (rust-nu-plugin-from-sqlite-0.26): (rust-nu-plugin-inc-0.26): (rust-nu-plugin-match-0.26): (rust-nu-plugin-post-0.26): (rust-nu-plugin-s3-0.26): (rust-nu-plugin-sys-0.26): (rust-nu-plugin-textview-0.26): (rust-nu-plugin-to-bson-0.26): (rust-nu-plugin-to-sqlite-0.26): (rust-nu-plugin-tree-0.26): (rust-nu-plugin-xpath-0.26): (rust-nu-protocol-0.26): (rust-nu-source-0.26): (rust-nu-stream-0.26): (rust-nu-test-support-0.26): (rust-nu-value-ext-0.26): Remove variables. Nicolas Goaziou 2021-02-13gnu: Add nushell....* gnu/packages/shells.scm (nushell): New variable. Nicolas Goaziou 2021-02-13gnu: shells.scm: Prefix license identifiers....* gnu/packages/shells.scm (dash): (fish): (fish-foreign-env): (rc): (es): (tcsh): (zsh): (xonsh): (scsh): (linenoise): (s-shell): (oksh): (loksh): (mksh): (oil): (gash): (gash-utils): (rust-nu-cli-0.26): (rust-nu-command-0.26): (rust-nu-data-0.26): (rust-nu-engine-0.26): (rust-nu-errors-0.26): (rust-nu-json-0.26): (rust-nu-parser-0.26): (rust-nu-plugin-0.26): (rust-nu-plugin-binaryview-0.26): (rust-nu-plugin-chart-0.26): (rust-nu-plugin-fetch-0.26): (rust-nu-plugin-from-bson-0.26): (rust-nu-plugin-from-sqlite-0.26): (rust-nu-plugin-inc-0.26): (rust-nu-plugin-match-0.26): (rust-nu-plugin-post-0.26): (rust-nu-plugin-ps-0.26): (rust-nu-plugin-s3-0.26): (rust-nu-plugin-selector-0.26): (rust-nu-plugin-start-0.26): (rust-nu-plugin-sys-0.26): (rust-nu-plugin-textview-0.26): (rust-nu-plugin-to-bson-0.26): (rust-nu-plugin-to-sqlite-0.26): (rust-nu-plugin-tree-0.26): (rust-nu-plugin-xpath-0.26): (rust-nu-protocol-0.26): (rust-nu-source-0.26): (rust-nu-stream-0.26): (rust-nu-table-0.26): (rust-nu-test-support-0.26): (rust-nu-value-ext-0.26): Prefix license identifier. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-binaryview-0.26....* gnu/packages/shells.scm (rust-nu-plugin-binaryview-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-chart-0.26....* gnu/packages/shells.scm (rust-nu-plugin-chart-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-fetch-0.26....* gnu/packages/shells.scm (rust-nu-plugin-fetch-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-from-bson-0.26....* gnu/packages/shells.scm (rust-nu-plugin-from-bson-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-from-sqlite-0.26....* gnu/packages/shells.scm (rust-nu-plugin-from-sqlite-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-inc-0.26....* gnu/packages/shells.scm (rust-nu-plugin-inc-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-match-0.26....* gnu/packages/shells.scm (rust-nu-plugin-match-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-post-0.26....* gnu/packages/shells.scm (rust-nu-plugin-post-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-ps-0.26....* gnu/packages/shells.scm (rust-nu-plugin-ps-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-s3-0.26....* gnu/packages/shells.scm (rust-nu-plugin-s3-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-selector-0.26....* gnu/packages/shells.scm (rust-nu-plugin-selector-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-start-0.26....* gnu/packages/shells.scm (rust-nu-plugin-start-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-sys-0.26....* gnu/packages/shells.scm (rust-nu-plugin-sys-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-textview-0.26....* gnu/packages/shells.scm (rust-nu-plugin-textview-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-to-bson-0.26....* gnu/packages/shells.scm (rust-nu-plugin-to-bson-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-to-sqlite-0.26....* gnu/packages/shells.scm (rust-nu-plugin-to-sqlite-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-tree-0.26....* gnu/packages/shells.scm (rust-nu-plugin-tree-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-xpath-0.26....* gnu/packages/shells.scm (rust-nu-plugin-xpath-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-cli-0.26....* gnu/packages/shells.scm (rust-nu-cli-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-command-0.26....* gnu/packages/shells.scm (rust-nu-command-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-engine-0.26....* gnu/packages/shells.scm (rust-nu-engine-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-data-0.26....* gnu/packages/shells.scm (rust-nu-data-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-json-0.26....* gnu/packages/shells.scm (rust-nu-json-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-stream-0.26....* gnu/packages/shells.scm (rust-nu-stream-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-plugin-0.26....* gnu/packages/shells.scm (rust-nu-plugin-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-parser-0.26....* gnu/packages/shells.scm (rust-nu-parser-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-test-support-0.26....* gnu/packages/shells.scm (rust-nu-test-support-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-value-ext-0.26....* gnu/packages/shells.scm (rust-nu-value-ext-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-table-0.26....* gnu/packages/shells.scm (rust-nu-table-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-protocol-0.26....* gnu/packages/shells.scm (rust-nu-protocol-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-errors-0.26....* gnu/packages/shells.scm (rust-nu-errors-0.26): New variable. Nicolas Goaziou 2021-02-13gnu: Add rust-nu-source-0.26....* gnu/packages/shells.scm (rust-nu-source-0.26): New variable. Nicolas Goaziou 2021-02-07gnu: xonsh: Update to 0.9.25....* gnu/packages/shells.scm (xonsh): Update to 0.9.25. Tobias Geerinckx-Rice 2021-02-07gnu: oil: Update to 0.8.7....* gnu/packages/shells.scm (oil): Update to 0.8.7. Tobias Geerinckx-Rice 2021-01-17gnu: oil: Update to 0.8.6....* gnu/packages/shells.scm (oil): Update to 0.8.6. Tobias Geerinckx-Rice 2021-01-02gnu: dash: Update to 0.5.11.3....* gnu/packages/shells.scm (dash): Update to 0.5.11.3. Tobias Geerinckx-Rice 2020-11-25gnu: oil: Update to 0.8.5....* gnu/packages/shells.scm (oil): Update to 0.8.5. Signed-off-by: Leo Famulari <leo@famulari.name> Ryan Prior via Guix-patches via 2020-11-09gnu: oil: Update to 0.8.4....* gnu/packages/shells.scm (oil): Update to 0.8.4. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Ryan Prior via Guix-patches via 2020-11-05gnu: oil: Update to 0.8.3....* gnu/packages/shells.scm (oil): Update to 0.8.3. Tobias Geerinckx-Rice 2020-10-19gnu: xonsh: Update to 0.9.24....* gnu/packages/shells.scm (xonsh): Update to 0.9.24. Tobias Geerinckx-Rice 2020-10-14gnu: oil: Update to 0.8.2....* gnu/packages/shells.scm (oil): Update to 0.8.2. Tobias Geerinckx-Rice 2020-10-13gnu: xonsh: Update to 0.9.23....* gnu/packages/shells.scm (xonsh): Update to 0.9.23. Tobias Geerinckx-Rice