aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages serveez)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages guile))

(define-public serveez
  (package
    (name "serveez")
    (version "0.3.0")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/serveez/serveez-"
                          version ".tar.lz"))
      (sha256
       (base32
        "0capm8i6fyjvh5rflxkfd07llfaa0kk4i3y836qpld9vzy49q6ky"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--enable-libserveez-install")
       #:phases
       (modify-phases %standard-phases
         (add-before 'patch-source-shebangs 'patch-test-source
           (lambda _
             (substitute*
                 (find-files "test" "^t[0-9]{3}$")
               (("/bin/sh") (which "sh")))
             #t)))))
    (native-inputs
     (list lzip))
    (inputs
     (list guile-2.2))
    (home-page "https://www.gnu.org/software/serveez/")
    (synopsis "Framework for implementing IP-based servers")
    (description
     "GNU Serveez is a server framework providing the routines necessary to
easily implement IP-based servers in your application.  It
demonstrates aspects of network programming in a portable manner,
making it convenient for both simplifying the process of adding a
server to your application or for learning about how network services
work.  Several example servers are provided already, such as an HTTP
server and an IRC server.")
    (license gpl3+)))
td> 2023-09-28gnu: sbcl-slynk: Update to 1.0.43-8-df62aba....* gnu/packages/lisp-xyz.scm (sbcl-slynk): Update to 1.0.43-8-df62aba. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andre A. Gomes 2023-09-23Merge branch 'lisp-team'Guillaume Le Vaillant 2023-09-21gnu: cl-njson: Update to 1.2.1....* gnu/packages/lisp-xyz.scm (sbcl-njson): Update to 1.2.1. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Artyom Bologov 2023-09-18gnu: cl-nkeymaps: Update to 1.1.0....* gnu/packages/lisp-xyz.scm (sbcl-nkeymaps): Update to 1.1.0. [inputs]: Add sbcl-cl-str. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-09-13gnu: cl-bordeaux-threads: Update to 0.9.2....* gnu/packages/lisp-xyz.scm (sbcl-bordeaux-threads): Update to 0.9.2. [inputs]: Add sbcl-global-vars, sbcl-trivial-features and sbcl-trivial-garbage. [arguments]: Add 'silence-deprecation-warning' phase. Update 'adjust-test-sleep' phase. Guillaume Le Vaillant 2023-09-06gnu: cl-virality: Update to 0.3.0-1.cdc19cc....* gnu/packages/lisp-xyz.scm (sbcl-virality): Update to 0.3.0-1.cdc19cc. [arguments]: Update 'delete-examples' phase. Guillaume Le Vaillant 2023-09-04gnu: cl-gobject-introspection: Update to 0.3-3.83beec4....* gnu/packages/lisp-xyz.scm (sbcl-cl-gobject-introspection): Update to 0.3-3.83beec4. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-09-04gnu: cl-cl+ssl: Update to 0.0.0-6.17d5cdd....* gnu/packages/lisp-xyz.scm (sbcl-cl+ssl): Update to 0.0.0-6.17d5cdd. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-09-04gnu: cl-iolib: Update to 0.8.4-0.010b7a6....* gnu/packages/lisp-xyz.scm (sbcl-iolib): Update to 0.8.4.0.010b7a6. [native-inputs]: Add pkg-config and sbcl-fiveam. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-09-02gnu: sbcl-njson: Update to 1.1.1....* gnu/packages/lisp-xyz.scm (sbcl-json): Update to 1.1.1. [description]: Update description. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Artyom Bologov 2023-09-13gnu: cl-nasdf: Update to 0.1.8....* gnu/packages/lisp-xyz.scm (sbcl-nasdf): Update to 0.1.8. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-09-13gnu: cl-njson: Update to 1.2.0....* gnu/packages/lisp-xyz.scm (sbcl-njson): Update to 1.2.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Artyom Bologov 2023-08-22gnu: cl-trivial-clipboard: Update to 0.0.0-6.6ddf8d5....* gnu/packages/lisp-xyz.scm (sbcl-trivial-clipboard): Update to 0.0.0-6.6ddf8d5. [inputs]: Add wl-clipboard. [arguments]: Update 'fix-paths' phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-08-18gnu: Add cl-gtk4....* gnu/packages/lisp-xyz.scm (sbcl-cl-gtk4, cl-gtk4, ecl-cl-gtk4): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> ykonai 2023-08-18gnu: Add cl-glib....* gnu/packages/lisp-xyz.scm (sbcl-cl-glib, cl-glib, ecl-cl-glib): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> ykonai 2023-08-18gnu: Add cl-gobject-introspection-wrapper....* gnu/packages/lisp-xyz.scm (sbcl-cl-gobject-introspection-wrapper, cl-gobject-introspection-wrapper, ecl-cl-gobject-introspection-wrapper): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> ykonai 2023-08-18gnu: cl-gobject-introspection: Update to 0.3-2.c4fef07....* gnu/packages/lisp-xyz.scm (sbcl-cl-gobject-introspection): Update to 0.3-2.c4fef07. [inputs]: Remove labels. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> ykonai 2023-08-18gnu: cl-nasdf: Update to 0.1.7....* gnu/packages/lisp-xyz.scm (sbcl-nasdf): Update to 0.1.7. [arguments]: Remove trailing boolean. Co-authored-by: Artyom Bologov <mail@aartaka.me> Guillaume Le Vaillant 2023-08-10gnu: cl-mime: Fix home page URL....* gnu/packages/lisp-xyz.scm (sbcl-cl-mime)[home-page]: Use the correct URL. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Konrad Hinsen 2023-08-08gnu: cl-nodgui: Remove input labels....* gnu/packages/lisp-xyz.scm (sbcl-nodgui)[inputs]: Remove labels. [arguments]: Use gexp. Guillaume Le Vaillant 2023-08-08gnu: cl-nodgui: Update to 0.4.8.5-2.4a9c2e7....* gnu/packages/lisp-xyz.scm (sbcl-nodgui): Update to 0.4.8.5-2.4a9c2e7. [source, home-page]: Switch from Notabug to Codeberg. [inputs]: Remove sbcl-cl-lex and sbcl-cl-yacc. Add sbcl-esrap and tklib. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> cage 2023-08-08gnu: cl-colors2: Update to 0.5.4-4.7a14107....* gnu/packages/lisp-xyz.scm (sbcl-cl-colors2): Update to 0.5.4-4.7a14107. [source, home-page]: Switch from Notabug to Codeberg. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> cage 2023-08-08gnu: cl-i18n: Update to 0.5.5-3.acb162a....* gnu/packages/lisp-xyz.scm (sbcl-cl-i18n): Update to 0.5.5-3.acb162a. [source, home-page]: Switch from Notabug to Codeberg. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> cage 2023-08-08gnu: cl-tooter: Update to 1.0.0-4.2e1b22f05....* gnu/packages/lisp-xyz.scm (sbcl-tooter): Update to 1.0.0-4.2e1b22f05. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> cage 2023-08-02gnu: Add cl-transmission....* gnu/packages/lisp-xyz.scm (cl-transmission, ecl-transmission, sbcl-transmission): New variables. Pierre Neidhardt 2023-07-25gnu: cl-nasdf: Update to 0.1.6....* gnu/packages/lisp-xyz.scm (sbcl-nasdf): Update to 0.1.6. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-07-24gnu: cl-ironclad: Update to 0.59....* gnu/packages/lisp-xyz.scm (sbcl-ironclad): Update to 0.59. Guillaume Le Vaillant 2023-07-19gnu: cl-usocket: Update to 0.8.6....* gnu/packages/lisp-xyz.scm (sbcl-usocket): Update to 0.8.6. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-07-19gnu: cl-ndebug: Update to 0.2.0....* gnu/packages/lisp-xyz.scm (sbcl-ndebug): Update to 0.2.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-07-19gnu: cl-array-utils: Update to 1.2.0-0.29da8fc....* gnu/packages/lisp-xyz.scm (sbcl-array-utils): Update to 1.2.0-0.29da8fc. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Andre A. Gomes 2023-07-15gnu: cl-nhooks: Update to 1.2.1....* gnu/packages/lisp-xyz.scm (sbcl-nhooks): Update to 1.2.1. [native-inputs]: Remove sbcl-fiveam, add sbcl-lisp-unit2. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> Artyom Bologov 2023-07-10gnu: sbcl-ospm: Update to 0.0.2....* gnu/packages/lisp-xyz.scm (sbcl-ospm): Update to 0.0.2. Pierre Neidhardt 2023-07-10gnu: cl-spinneret: Update to 3.0-6.d4398b5....* gnu/packages/lisp-xyz.scm (sbcl-spinneret): Update to 3.0-6.d4398b5. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Artyom Bologov 2023-07-04gnu: Add cl-postgres+local-time....The local-time extension for cl-postgres has to be put in a separate package to solve a dependency cycle between local-time and postmodern. * gnu/packages/lisp-xyz.scm (sbcl-local-time)[arguments]: Add 'delete-local-time' phase. (sbcl-cl-postgres+local-time): New variable. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> Roman Scherer 2023-06-17gnu: cl-colors2: Update to 0.5.4-3.cc03bad....* gnu/packages/lisp-xyz.scm (sbcl-cl-colors2): Update to 0.5.4-3.cc03bad. [description]: Update with the latest changes. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Artyom Bologov 2023-06-17gnu: cl-nclasses: Update to 0.6.0....* gnu/packages/lisp-xyz.scm (sbcl-nclasses): Update to 0.6.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Artyom Bologov 2023-06-07gnu: sbcl-cl-webkit: Update to 3.5.9....* gnu/packages/lisp-xyz.scm (sbcl-cl-webkit): Update to 3.5.9. Pierre Neidhardt 2023-06-06gnu: sbcl-stmx: Update to 2.0.5-2.f71e742....* gnu/packages/lisp-xyz.scm (sbcl-stmx): Update to 2.0.5-2.f71e742. [arguments]: Add 'fix-build' phase. Guillaume Le Vaillant