aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages serveez)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages guile))

(define-public serveez
  (package
    (name "serveez")
    (version "0.3.0")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/serveez/serveez-"
                          version ".tar.lz"))
      (sha256
       (base32
        "0capm8i6fyjvh5rflxkfd07llfaa0kk4i3y836qpld9vzy49q6ky"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--enable-libserveez-install")
       #:phases
       (modify-phases %standard-phases
         (add-before 'patch-source-shebangs 'patch-test-source
           (lambda _
             (substitute*
                 (find-files "test" "^t[0-9]{3}$")
               (("/bin/sh") (which "sh")))
             #t)))))
    (native-inputs
     (list lzip))
    (inputs
     (list guile-2.2))
    (home-page "https://www.gnu.org/software/serveez/")
    (synopsis "Framework for implementing IP-based servers")
    (description
     "GNU Serveez is a server framework providing the routines necessary to
easily implement IP-based servers in your application.  It
demonstrates aspects of network programming in a portable manner,
making it convenient for both simplifying the process of adding a
server to your application or for learning about how network services
work.  Several example servers are provided already, such as an HTTP
server and an IRC server.")
    (license gpl3+)))
ts]: Add fix-OpenColorIOConfig phase. Change-Id: I317870801f77dc59bcd07b0d11a750bbbb63b327 Zheng Junjie 2024-08-31gnu: itk-snap: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/image-processing.scm (itk-snap)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I700d4819aa240ab8d6dc3722336e8fe91d896d96 Maxime Devos 2024-08-31gnu: metapixel: Rewrite with G-Expressions....* gnu/packages/image-processing.scm (metapixel)[arguments]: Rewrite with G-Expressions. [inputs, native-inputs]: Drop labels. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-31gnu: metapixel: Drop docbook workaround....* gnu/packages/image-processing.scm (metapixel)[arguments]<#:phases>: Drop 'make-local-docbook-xml phase. [native-inputs]: Use docbook-xml-4.2 instead of docbook-xml. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2024-08-29gnu: opencv: Update to 4.10.0...* gnu/packages/image-processing.scm (opencv): Update to 4.10.0. Change-Id: I4de85cdaa744386deb8162a689dca23003c150ef Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Andy Tai 2024-07-07gnu: gmic: Update source hash....Fixes: https://issues.guix.gnu.org/71970 * gnu/packages/image-processing.scm (gmic): Update source hash. Change-Id: Id7ad742086139263d5677339f1c7b91de350a3f2 Zheng Junjie 2024-07-05gnu: gmic: Update to 3.4.0....* gnu/packages/image-processing.scm (gmic): Update to 3.4.0. Change-Id: I2c9335a96bb22625012f35b60620b9b9ad435a64 Vinicius Monego 2024-06-27gnu: vtk: Update to 9.3.0....* gnu/packages/image-processing.scm (vtk): Update to 9.3.0. Change-Id: Id31d41e7dc457d1f17c0e8e824c170942d81698c Signed-off-by: Andreas Enge <andreas@enge.fr> Lars Bilke 2024-05-23gnu: dcmtk: Update to 3.6.8. [security-fixes]...This fixes CVE-2022-43272. * gnu/packages/image-processing.scm (dcmtk): Update to 3.6.8. Change-Id: I4e0203219280a2571267f566cdfc8c2a9ea3fd18 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Nicolas Graves via Guix-patches via 2024-04-22gnu: Add python-pims....* gnu/packages/image-processing.scm (python-pims): New variable. Change-Id: I33e89dd865a38b526a1f766cf321a6c67a170a36 Ricardo Wurmus 2024-04-22gnu: Add python-spatial-image....* gnu/packages/image-processing.scm (python-spatial-image): New variable. Change-Id: I0e2bbfb94499aca71b33703153ad408530b60658 Ricardo Wurmus 2024-04-06gnu: opencolorio: Update to 2.3.2....* gnu/packages/image-processing.scm (opencolorio): Update to 2.3.2. [source]: Remove snippet. [arguments]: Use G-Expressions. <#:configure-flags>: Unset "-DCMAKE-CXX_FLAGS", "-DOCIO_BUILD_STATIC", "-DUSE_EXTERNAL_TINXML", "-DUSE_EXTERNAL_LCMS". Pass "-DCIO_BUILD_GPU_TESTS=false". <#:phases>: Delete the patch-test-suite phase. [native-inputs]: Remove git, pkg-config. Add openimageio, pybind11-2.10, python-wrapper. [inputs]: Remove openexr-2, tinyxml. Add expat, freeglut, glew, imath, libglvnd, minizip-ng, openexr, pystring, yaml-cpp, zlib. [license]: Simplify. * gnu/packages/patches/opencolorio-fix-build-with-gcc11.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: Iafd87762df81d0f5c23089251b4241a57d414dc4 Vinicius Monego 2024-03-27gnu: insight-toolkit: Build and install Python bindings....* gnu/packages/image-processing.scm (insight-toolkit)[outputs]: Add "python" output. [arguments]: Add configure flags to build Python bindings; add phase 'ignore-warnings. [native-inputs]: Add castxml, swig, and which. (insight-toolkit-4)[outputs]: Override. [native-inputs]: Override. Change-Id: I4177d0c0239027290678a43f2ea26cb8e1e74918 Ricardo Wurmus 2024-03-25gnu: opencv: Update to 4.9.0....* gnu/packages/image-processing.scm (opencv): Update to 4.9.0. [source]: Remove non-existent "libtengine" from 3rdParty drectory list to be deleted. Change-Id: I982256730e33b418491ba2b9238c0e532cb9a7a9 Signed-off-by: Christopher Baines <mail@cbaines.net> Andy Tai 2024-03-23gnu: gmic: Update to 3.3.5....* gnu/packages/image-processing.scm (gmic): Update to 3.3.5. Change-Id: I5e5ced3044ff92bbf66bc4dde5506fac1b883f0b Vinicius Monego