aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages scsi)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools))

(define-public sg3-utils
  (package
    (name "sg3-utils")
    (version "1.48")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://sg.danny.cz/sg/p/sg3_utils-"
                                  version ".tar.xz"))
              (sha256
               (base32
                "1ynv6kijzjj8xab3z87nks26qcrpvg46mhlr3s6yah6mj0ba9ffn"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list "--disable-static")))
    (home-page "https://sg.danny.cz/sg/sg3_utils.html")
    (synopsis "SCSI device utilities")
    (description
     "sg3-utils is a collection of utilities for devices that use the Small
Computer System Interface (@dfn{SCSI}) command set.  It includes utilities to
read data from, write data to, control, modify, and query the state of SCSI
devices.

For example, this package provides command-line tools to:
@itemize
@item copy data based on @code{dd} syntax and semantics (called @command{sg_dd},
@command{sgp_dd}, and @command{sgm_dd})
@item check @code{INQUIRY} data and @code{VPD pages} (@command{sg_inq})
@item check mode and log pages (@command{sginfo}, @command{sg_modes}, and
@command{sg_logs})
@item spin up and down disks (@command{sg_start})
@item do self-tests (@code{sg_senddiag})
@item parse sense data (@code{sg_decode_sense})
@item and perform various other functions.
@end itemize

In addition, this package includes a library, called libsgutils, which can be
used in C and C++ programs to interact with SCSI devices.")
    ;; See README: "All utilities and libraries have either a "2 clause" BSD
    ;;   license or are "GPL-2ed". [...] That BSD license was updated from the
    ;;   "3 clause" to the newer "2 clause" version on 20180119. To save space
    ;;   various source code files refer to a file called "BSD_LICENSE" [...]."
    ;; Some files (like sg_compare_and_write.c) retain their 3-clause headers!
    (license (list license:gpl2+ license:bsd-2 license:bsd-3))))

(define-public libiscsi
  (package
    (name "libiscsi")
    (version "1.19.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/sahlberg/libiscsi")
             (commit version)))
       (sha256
        (base32
         "0ajrkkg5awmi8m4b3mha7h07ylg18k252qprvk1sgq0qbyd66zy7"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs (list autoconf automake libtool))
    (synopsis "Client-side library for iSCSI")
    (description "Libiscsi is a client-side library to implement the iSCSI
protocol that can be used to access the resources of an iSCSI target.  It is
fully asynchronous with regards to iSCSI commands and SCSI tasks, but a
synchronous layer is also provided for ease of use for simpler applications.")
    (home-page "https://github.com/sahlberg/libiscsi")
    (license (list
              ;; For the src, examples and test-tool directories, except
              ;; src/ld_iscsi.c.
              license:gpl2+
              ;; For the lib and include directories.
              license:lgpl2.1+))))

(define-public lsscsi
  (package
    (name "lsscsi")
    (version "0.32")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
             (sha256
              (base32
               "0jp458m2b3wckr18qkln69i01152qlwz33zm49103lq8fgx0n6d4"))))
    (build-system gnu-build-system)
    (synopsis "Lists information about SCSI or NVMe devices in Linux")
    (home-page "https://sg.danny.cz/scsi/lsscsi.html")
    (description
     "@command{lsscsi} lists SCSI logical units or SCSI targets.  It can
also list NVMe namespaces or controllers and show the relationship between a
device's primary node name, its SCSI generic (sg) node name and its kernel
name.")
    (license license:gpl2)))
-17 23:43:14 +0100'>2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-10gnu: Add BLAKE3 command line tool.Leo Famulari * gnu/packages/crypto.scm (b3sum): New variable. 2021-11-10gnu: Add BLAKE3 Rust implementation.Leo Famulari * gnu/packages/crypto.scm (rust-blake3-0.3): New variable. 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-29gnu: botan: Omit static library.Tobias Geerinckx-Rice * gnu/packages/crypto.scm (botan)[arguments]: Add a "--disable-static" configure flag. 2021-10-29gnu: botan: Update to 2.18.2.Tobias Geerinckx-Rice * gnu/packages/crypto.scm (botan): Update to 2.18.2. 2021-10-26gnu: asignify: Update to 1.1-1.08af003.Leo Famulari * gnu/packages/crypto.scm (asignify): Update to 1.1-1.08af003. 2021-10-26gnu: Add b2sum.Leo Famulari * gnu/packages/crypto.scm (b2sum): New variable. 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-18gnu: Add python-olm.Lars-Dominik Braun * gnu/packages/crypto.scm (python-olm): New variable. 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-05gnu: libmd: Omit static library.Tobias Geerinckx-Rice * gnu/packages/crypto.scm (libmd)[arguments]: Add "--disable-static" to the #:configure-flags. 2021-10-05gnu: libmd: Update to 1.0.4.Tobias Geerinckx-Rice * gnu/packages/crypto.scm (libmd): Update to 1.0.4. 2021-09-17Merge branch 'master' into core-updates-frozenMarius Bakke Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm 2021-09-16gnu: Add cryfs.Brendan Tildesley * gnu/packages/crypto.scm (cryfs): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-08-12Merge branch 'master' into core-updates-frozenMarius Bakke Conflicts: gnu/packages/algebra.scm gnu/packages/games.scm gnu/packages/golang.scm gnu/packages/kerberos.scm gnu/packages/mail.scm gnu/packages/python.scm gnu/packages/ruby.scm gnu/packages/scheme.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm 2021-07-27gnu: Remove eschalot.Leo Famulari As discussed in <https://bugs.gnu.org/46602>, eschalot does not support a current release of OpenSSL. * gnu/packages/crypto.scm (eschalot): Remove variable. 2021-08-04gnu: Fix broken links to Arch Linux git repositoriesMilkey Mouse * gnu/packages/crypto.scm (libsecp256k1): Update comment patch link. * gnu/packages/engineering.scm (freehdl): Update patch link. * gnu/packages/tex.scm (texlive-bin): Update arch-patch base URL. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2021-07-23gnu: RHash: Update to 1.4.2.Marius Bakke * gnu/packages/crypto.scm (rhash): Update to 1.4.2. 2021-07-23gnu: RHash: Turn arguments into gexp.Marius Bakke * gnu/packages/crypto.scm (rhash)[arguments]: Turn into gexp, and use #$OUTPUT instead of the %OUTPUT variable. 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-15gnu: libolm: Unbundle unused blob.Maxime Devos * gnu/package/crypto.scm: (libolm)[source][snippet]: Delete "gradle-wrapper.jar". It is a bundled compiled (!) version of gradle. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2021-07-08gnu: libolm: Respect "--without-tests".Maxime Devos * gnu/packages/libolm.scm (libolm)[arguments]<#:phases>{check}: Respect #:tests?. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>