aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages scsi)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools))

(define-public sg3-utils
  (package
    (name "sg3-utils")
    (version "1.48")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://sg.danny.cz/sg/p/sg3_utils-"
                                  version ".tar.xz"))
              (sha256
               (base32
                "1ynv6kijzjj8xab3z87nks26qcrpvg46mhlr3s6yah6mj0ba9ffn"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list "--disable-static")))
    (home-page "https://sg.danny.cz/sg/sg3_utils.html")
    (synopsis "SCSI device utilities")
    (description
     "sg3-utils is a collection of utilities for devices that use the Small
Computer System Interface (@dfn{SCSI}) command set.  It includes utilities to
read data from, write data to, control, modify, and query the state of SCSI
devices.

For example, this package provides command-line tools to:
@itemize
@item copy data based on @code{dd} syntax and semantics (called @command{sg_dd},
@command{sgp_dd}, and @command{sgm_dd})
@item check @code{INQUIRY} data and @code{VPD pages} (@command{sg_inq})
@item check mode and log pages (@command{sginfo}, @command{sg_modes}, and
@command{sg_logs})
@item spin up and down disks (@command{sg_start})
@item do self-tests (@code{sg_senddiag})
@item parse sense data (@code{sg_decode_sense})
@item and perform various other functions.
@end itemize

In addition, this package includes a library, called libsgutils, which can be
used in C and C++ programs to interact with SCSI devices.")
    ;; See README: "All utilities and libraries have either a "2 clause" BSD
    ;;   license or are "GPL-2ed". [...] That BSD license was updated from the
    ;;   "3 clause" to the newer "2 clause" version on 20180119. To save space
    ;;   various source code files refer to a file called "BSD_LICENSE" [...]."
    ;; Some files (like sg_compare_and_write.c) retain their 3-clause headers!
    (license (list license:gpl2+ license:bsd-2 license:bsd-3))))

(define-public libiscsi
  (package
    (name "libiscsi")
    (version "1.19.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/sahlberg/libiscsi")
             (commit version)))
       (sha256
        (base32
         "0ajrkkg5awmi8m4b3mha7h07ylg18k252qprvk1sgq0qbyd66zy7"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs (list autoconf automake libtool))
    (synopsis "Client-side library for iSCSI")
    (description "Libiscsi is a client-side library to implement the iSCSI
protocol that can be used to access the resources of an iSCSI target.  It is
fully asynchronous with regards to iSCSI commands and SCSI tasks, but a
synchronous layer is also provided for ease of use for simpler applications.")
    (home-page "https://github.com/sahlberg/libiscsi")
    (license (list
              ;; For the src, examples and test-tool directories, except
              ;; src/ld_iscsi.c.
              license:gpl2+
              ;; For the lib and include directories.
              license:lgpl2.1+))))

(define-public lsscsi
  (package
    (name "lsscsi")
    (version "0.32")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
             (sha256
              (base32
               "0jp458m2b3wckr18qkln69i01152qlwz33zm49103lq8fgx0n6d4"))))
    (build-system gnu-build-system)
    (synopsis "Lists information about SCSI or NVMe devices in Linux")
    (home-page "https://sg.danny.cz/scsi/lsscsi.html")
    (description
     "@command{lsscsi} lists SCSI logical units or SCSI targets.  It can
also list NVMe namespaces or controllers and show the relationship between a
device's primary node name, its SCSI generic (sg) node name and its kernel
name.")
    (license license:gpl2)))
g-avail'>...Andy Patterson 2016-07-25gnu: ecl: Update to 16.1.2....Andy Patterson 2016-07-03Update name for ng0....ng0 2016-05-26gnu: Rename texlive module to tex....Roel Janssen 2016-02-08gnu: add lispf4...Nils Gillmann 2016-02-03gnu: sbcl: Generate and install documentation....Federico Beffa 2016-02-03gnu: sbcl: Convert to the 'modify-phases' syntax....Federico Beffa 2015-11-13gnu: Adjust formatting as recommended by 'guix lint'....宋文武 2015-07-17gnu: clisp: Do not pass --build=<triplet> to configure....Mark H Weaver 2015-04-22gnu: ccl: Add default 'match' cases for unsupported platforms....Mark H Weaver 2015-04-19gnu: ccl: Fix inputs on non-Intel platforms....Mark H Weaver 2015-03-07gnu: sbcl: Use ISO-8859-1 to patch unix tool paths....Mark H Weaver 2015-03-04gnu: Move 'which' to (gnu packages base)....Ludovic Courtès 2015-03-01gnu: ecl: Update to version 15.2.21....Taylan Ulrich Bayırlı/Kammer 2015-02-24gnu: Sync GNU synopses and descriptions....Ludovic Courtès 2015-02-23gnu: Add CCL....Taylan Ulrich Bayırlı/Kammer 2015-02-15gnu: Add SBCL....Taylan Ulrich Bayırlı/Kammer 2015-02-13gnu: Add CLISP....Taylan Ulrich Bayırlı/Kammer 2015-02-12gnu: Add ECL....Taylan Ulrich Bayırlı/Kammer 2014-11-27gnu: gcl: Drop 'strip phase....Andreas Enge 2014-11-25gnu: gcl: Update to 2.6.12....Andreas Enge 2014-11-09gnu: Re-synchronize a couple of synopses with the Womb....Ludovic Courtès 2014-09-27gnu: gcl: Update to 2.6.11....Andreas Enge 2014-09-23Use #:prefix instead of #:renamer with 'symbol-prefix-proc'....Mark H Weaver 2014-09-13gnu: Adjust synopses as recommended by 'guix lint'....Ludovic Courtès 2014-07-05gnu: Add gcl....John Darrington