aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages scsi)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools))

(define-public sg3-utils
  (package
    (name "sg3-utils")
    (version "1.48")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://sg.danny.cz/sg/p/sg3_utils-"
                                  version ".tar.xz"))
              (sha256
               (base32
                "1ynv6kijzjj8xab3z87nks26qcrpvg46mhlr3s6yah6mj0ba9ffn"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list "--disable-static")))
    (home-page "https://sg.danny.cz/sg/sg3_utils.html")
    (synopsis "SCSI device utilities")
    (description
     "sg3-utils is a collection of utilities for devices that use the Small
Computer System Interface (@dfn{SCSI}) command set.  It includes utilities to
read data from, write data to, control, modify, and query the state of SCSI
devices.

For example, this package provides command-line tools to:
@itemize
@item copy data based on @code{dd} syntax and semantics (called @command{sg_dd},
@command{sgp_dd}, and @command{sgm_dd})
@item check @code{INQUIRY} data and @code{VPD pages} (@command{sg_inq})
@item check mode and log pages (@command{sginfo}, @command{sg_modes}, and
@command{sg_logs})
@item spin up and down disks (@command{sg_start})
@item do self-tests (@code{sg_senddiag})
@item parse sense data (@code{sg_decode_sense})
@item and perform various other functions.
@end itemize

In addition, this package includes a library, called libsgutils, which can be
used in C and C++ programs to interact with SCSI devices.")
    ;; See README: "All utilities and libraries have either a "2 clause" BSD
    ;;   license or are "GPL-2ed". [...] That BSD license was updated from the
    ;;   "3 clause" to the newer "2 clause" version on 20180119. To save space
    ;;   various source code files refer to a file called "BSD_LICENSE" [...]."
    ;; Some files (like sg_compare_and_write.c) retain their 3-clause headers!
    (license (list license:gpl2+ license:bsd-2 license:bsd-3))))

(define-public libiscsi
  (package
    (name "libiscsi")
    (version "1.19.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/sahlberg/libiscsi")
             (commit version)))
       (sha256
        (base32
         "0ajrkkg5awmi8m4b3mha7h07ylg18k252qprvk1sgq0qbyd66zy7"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs (list autoconf automake libtool))
    (synopsis "Client-side library for iSCSI")
    (description "Libiscsi is a client-side library to implement the iSCSI
protocol that can be used to access the resources of an iSCSI target.  It is
fully asynchronous with regards to iSCSI commands and SCSI tasks, but a
synchronous layer is also provided for ease of use for simpler applications.")
    (home-page "https://github.com/sahlberg/libiscsi")
    (license (list
              ;; For the src, examples and test-tool directories, except
              ;; src/ld_iscsi.c.
              license:gpl2+
              ;; For the lib and include directories.
              license:lgpl2.1+))))

(define-public lsscsi
  (package
    (name "lsscsi")
    (version "0.32")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
             (sha256
              (base32
               "0jp458m2b3wckr18qkln69i01152qlwz33zm49103lq8fgx0n6d4"))))
    (build-system gnu-build-system)
    (synopsis "Lists information about SCSI or NVMe devices in Linux")
    (home-page "https://sg.danny.cz/scsi/lsscsi.html")
    (description
     "@command{lsscsi} lists SCSI logical units or SCSI targets.  It can
also list NVMe namespaces or controllers and show the relationship between a
device's primary node name, its SCSI generic (sg) node name and its kernel
name.")
    (license license:gpl2)))
e-xyz.scm?id=475c3278df4f9dc1bc708e1092e8c93d0618711a'>gnu: emacsy: Partially unbreak build and switch to Guile 3.0....Previously it would fail to build. Now it fails tests. * gnu/packages/guile-xyz.scm (emacsy)[source]: Adjust 'uri'. Add 'snippet' and 'modules'. [native-inputs]: Remove AUTOCONF and AUTOMAKE. Replace GUILE-2.2 by GUILE-3.0. [inputs]: Replace GUILE-2.2 by GUILE-3.0. Ludovic Courtès 2021-01-03gnu: guile-studio: Update to 0.1.0-1.93622e7....* gnu/packages/guile-xyz.scm (guile-studio): Update to 0.1.0-1.93622e7. [arguments]: Remove ICONS_DIR from make-flags. [inputs]: Add emacs-all-the-icons-dired. Ricardo Wurmus 2021-01-03gnu: guile-gi: Patch all references to libguile-gi....* gnu/packages/guile-xyz.scm (guile-gi)[patch-references-to-extension]: Use find-files to discover all modules. Leo Prikler 2021-01-03gnu: guile-gi: Update to 0.3.1....* gnu/packages/guile-xyz.scm (guile-gi): Update to 0.3.1. Leo Prikler 2021-01-03gnu: Add guile2.0-pg....* gnu/packages/guile-xyz.scm (guile2.0-pg): New variable. Christopher Baines 2021-01-03gnu: guile-picture-language: Update to 0.0.1-3.7e5982a....* gnu/packages/guile-xyz.scm (guile-picture-language): Update to 0.0.1-3.7e5982a. [propagated-inputs]: Add guile-rsvg. [native-inputs]: Remove imagemagick; add librsvg. [license]: Add GPLv3+. Ricardo Wurmus 2021-01-01gnu: guile-studio: Update to 0.0.4-2.e9f2b46....* gnu/packages/guile-xyz.scm (guile-studio): Update to 0.0.4-2.e9f2b46. [inputs]: Add emacs-dired-sidebar. Ricardo Wurmus 2021-01-01gnu: guile-squee: Update to 0-2.c1497a2....* gnu/packages/guile-xyz.scm (guile-squee): Update to 0-2.c1497a2. Mathieu Othacehe 2020-12-31gnu: guile-studio: Update to 0.0.4-1.84d4e8d....* gnu/packages/guile-xyz.scm (guile-studio): Update to 0.0.4-1.84d4e8d. [inputs]: Remove emacs-smart-mode-line; add emacs-f, emacs-memoize, emacs-all-the-icons, emacs-doom-modeline, emacs-modus-themes, and emacs-ivy. Ricardo Wurmus 2020-12-31gnu: guile-picture-language: Update to 0.0.1-2.bf4600b....* gnu/packages/guile-xyz.scm (guile-picture-language): Update to 0.0.1-2.bf4600b. Ricardo Wurmus 2020-12-30gnu: Add guile-shapefile....* gnu/packages/guile-xyz.scm (guile-shapefile): New variable. Ricardo Wurmus 2020-12-27gnu: Add guile-r6rs-protobuf....* gnu/packages/guile-xyz.scm (guile-r6rs-protobuf): New variable. Ricardo Wurmus 2020-12-12gnu: Add guile-eris....* gnu/packages/guile-xyz.scm (guile-eris): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> pukkamustard 2020-12-12gnu: Add guile-sodium....* gnu/packages/guile-xyz.scm (guile-sodium): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> pukkamustard 2020-12-11gnu: guile-simple-zmq: Update to 0.0.0-5.f8b7d81....* gnu/packages/guile-xyz.scm (guile-simple-zmq): Update to 0.0.0-5.f8b7d81. Mathieu Othacehe 2020-12-10gnu: guile-prometheus: Update to 0-5.35dc26c....* gnu/packages/guile-xyz.scm (guile-prometheus): Update to 0-5.35dc26c. Christopher Baines 2020-12-10gnu: guile-prometheus: Update to 0-4.f661edf....* gnu/packages/guile-xyz.scm (guile-prometheus): Update to 0-4.f661edf. Christopher Baines 2020-12-06gnu: guile-lib: Support cross-compilation....* gnu/packages/guile-xyz.scm (guile-lib)[native-inputs]: Add guile-3.0. (guile2.0-lib, guile2.2-lib)[native-inputs]: Explicitly specifiy pkg-config. Christopher Baines 2020-12-06gnu: Add guile-email-latest....* gnu/packages/guile-xyz.scm (guile-email-latest): New variable. Ricardo Wurmus 2020-12-05gnu: guile-prometheus: Update to 0-3.2549c48....* gnu/packages/guile-xyz.scm (guile-prometheus): Update to 0-3.2549c48. Christopher Baines 2020-12-03gnu: guile-semver: Switch to Guile 3.0....* gnu/packages/guile-xyz.scm (guile-semver)[inputs]: Use GUILE-3.0. (guile3.0-semver): Define in terms of 'deprecated-package'. (guile2.2-semver): New variable. Ludovic Courtès 2020-11-29gnu: guile-prometheus: Update to 0-2.12d3d9d....* gnu/packages/guile-xyz.scm (guile-prometheus): Update to 0-2.12d3d9d. Christopher Baines 2020-11-28gnu: guile-jsonld: Update to 1.0.2....* gnu/packages/guile-xyz.scm (guile-jsonld): Update to 1.0.2. Julien Lepiller 2020-11-22gnu: guile-simple-zmq: Update to 0.0.0-4.29a20af....* gnu/packages/guile-xyz.scm (guile-simple-zmq): Update to 0.0.0-4.29a20af. Mathieu Othacehe 2020-11-19gnu: Don't append '.git' to GitHub uris....* gnu/packages/admin.scm (nmrpflash)[source]: Remove '.git' from URI. * gnu/packages/aidc.scm (zxing-cpp), * gnu/packages/assembly.scm (mbuild), * gnu/packages/audio.scm (opensles, wildmidi, tinyalsa), * gnu/packages/browser-extensions.scm (ublock-origin-chromium), * gnu/packages/check.scm (mutest), * gnu/packages/compression.scm (unshield), * gnu/packages/coq.scm (subset), * gnu/packages/dictionaries.scm (translate-shell), * gnu/packages/disk.scm (memkind), * gnu/packages/documentation.scm (latex2html), * gnu/packages/emacs-xyz.scm (emacs-chronometrist, emacs-flycheck-ledger, emacs-counsel-notmuch, emacs-spaceline, emacs-org-generate), * gnu/packages/embedded.scm (ebusd, ebusd-configuration), * gnu/packages/enchant.scm (nuspell), * gnu/packages/fontutils.scm (woff2), * gnu/packages/geo.scm (memphis), * gnu/packages/gimp.scm (mrg), * gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator), * gnu/packages/gnome.scm (parlatype), * gnu/packages/golang.scm (go-github-com-tv42-httpunix, go-github-com-ayufan-golang-kardianos-service), * gnu/packages/graphics.scm (eglexternalplatform, egl-wayland, mmm, directfb, flux), * gnu/packages/gstreamer.scm (openni2, ccextractor, libvisual, graphene), * gnu/packages/guile-xyz.scm (guile-srfi-180, guile-torrent), * gnu/packages/image.scm (openjpeg-data), * gnu/packages/java.scm (javacc), * gnu/packages/language.scm (liblouis, liblouisutdml), * gnu/packages/linux.scm (pamela, ttyebus), * gnu/packages/lxqt.scm (lxqt-connman-applet), * gnu/packages/mail.scm (libetpan), * gnu/packages/man.scm (ronn), * gnu/packages/music.scm (tascam-gtk, artyfx), * gnu/packages/networking.scm (srt, lksctp-tools, nng, nanomsg), * gnu/packages/python-crypto.scm (pure-python-otr), * gnu/packages/qt.scm (qtspell), * gnu/packages/raspberry-pi.scm (raspi-gpio, raspi-open-firmware), * gnu/packages/rdp.scm (freerdp), * gnu/packages/ruby.scm (ruby-prawn-templates, ruby-treetop, ruby-gimme, ruby-standard, ruby-rubocop-ast, ruby-rexml, ruby-range-compressor, ruby-regexp-property-values, ruby-regexp-parser, ruby-rubocop, ruby-pdf-reader, ruby-pdf-inspector, ruby-prawn), * gnu/packages/syncthing.scm (syncthing-gtk), * gnu/packages/video.scm (svt-hevc, mediasdk, libvideogfx, libde265, tslib), * gnu/packages/xml.scm (libxmlb, libxmlplusplus)[source]: Same. Efraim Flashner 2020-11-10gnu: nomad: Update to 0.2.0-alpha-199-g3e7a475....* gnu/packages/guile-xyz.scm (nomad): Update to 0.2.0-alpha-199-g3e7a475. [inputs]: add gsettings-desktop-schemas Signed-off-by: Marius Bakke <marius@gnu.org> Mike Rosset 2020-11-10gnu: g-golf: Update to ef830107b9765bd6a2da848d0cbe45e11374c0b5....* gnu/packages/guile-xyz.scm (g-golf): Update to ef830107b9765bd6a2da848d0cbe45e11374c0b5. Signed-off-by: Marius Bakke <marius@gnu.org> Mike Rosset 2020-11-10gnu: emacsy-minimal: Update to v0.4.1-37-g5f91ee6....* gnu/packages/guile-xyz.scm (emacsy-minimal): Update to v0.4.1-37-g5f91ee6. Signed-off-by: Marius Bakke <marius@gnu.org> Mike Rosset 2020-11-04gnu: haunt: Update home page....* gnu/packages/guile-xyz.scm (haunt)[home-page]: Update. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Matthew Kraai 2020-11-03gnu: Depend on 'gettext-minimal' rather than 'gettext' when appropriate....* gnu/packages/backup.scm (duplicity)[native-inputs]: Use GETTEXT-MINIMAL instead of GNU-GETTEXT. * gnu/packages/mpd.scm (mpdris2)[native-inputs]: Likewise. * gnu/packages/guile-xyz.scm (nomad)[native-inputs]: Likewise. (guile-mkdir-p)[native-inputs]: Likewise. (guile-avahi)[native-inputs]: Remove GNU-GETTEXT, now unneeded. Ludovic Courtès 2020-11-03gnu: guile-avahi: Update to 0.4.0-1.6d43caf....* gnu/packages/guile-xyz.scm (guile-avahi): Update to 0.4.0-1.6d43caf. [arguments]: Add 'fix-guile-avahi-file-name phase with the required modules and imported-modules. Mathieu Othacehe 2020-10-28gnu: Add guile-filesystem....* gnu/packages/guile-xyz.scm (guile-filesystem): New variable. (guile2.0-filesystem guile2.2-filesystem): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Leo Prikler