aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2018, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2021, 2022, 2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages scribus)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages cups)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages hunspell)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages image)
  #:use-module (gnu packages imagemagick)
  #:use-module (gnu packages libreoffice)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pdf)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages xml))

(define-public scribus
  (package
    (name "scribus")
    (version "1.6.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/scribus/scribus/"
                           version "/scribus-" version ".tar.gz"))
       (sha256
        (base32 "066p0a9jp676qid5hf1cilrks70xchpzfck9db79rhqhk84ja355"))))
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f                      ;no test target
       #:configure-flags
       '("-DWANT_GRAPHICSMAGICK=1"
         "-DWANT_CPP17=ON")))
    (inputs
     (list boost
           cairo
           cups
           fontconfig
           freetype
           graphicsmagick
           harfbuzz
           hunspell
           icu4c
           lcms
           libcdr
           libfreehand
           libjpeg-turbo
           libmspub
           libpagemaker
           librevenge
           libtiff
           libvisio
           libxml2
           libzmf
           openssl
           podofo
           poppler
           python                       ;need Python library
           qtbase-5
           qtdeclarative-5
           zlib))
    (native-inputs
     (list pkg-config qttools-5 util-linux))
    (home-page "https://www.scribus.net")
    (synopsis "Desktop publishing and page layout program")
    (description
     "Scribus is a @dfn{desktop publishing} (DTP) application and can
be used for many tasks; from brochure design to newspapers, magazines,
newsletters and posters to technical documentation.  Scribus supports
professional DTP features, such as CMYK color and a color management
system to soft proof images for high quality color printing, flexible
PDF creation options, Encapsulated PostScript import/export and
creation of four color separations, import of EPS/PS and SVG as native
vector graphics, Unicode text including right to left scripts such as
Arabic and Hebrew via FreeType.")
    (license license:gpl2+)))
e to 0.14.7. [native-inputs]: Add python-bech32 and python-cryptography. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Attila Lendvai 2023-10-03gnu: python-trezor: Update to 0.13.7....* gnu/packages/finance.scm (python-trezor): Update to 0.13.7. [propagated-inputs]: Drop python-click-7 kludge, add python-construct-classes instead of python-construct. [native-inputs]: Add python-pillow, python-simple-rlp and python-wheel. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Attila Lendvai 2023-09-28gnu: fulcrum: Update to 1.9.1....* gnu/packages/finance.scm (fulcrum): Use the upstream origin instead of the Flowee's fork of it, updates and expands the synopsis and description. Updates the package to 1.9.1 and build without any bundled libraries with the help of a patch. * gnu/packages/patches/fulcrum-1.9.1-unbundled-libraries.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jean-Pierre De Jesus DIAZ 2023-09-22gnu: python-duniterpy: Update to 1.1.1....* gnu/packages/finance.scm (python-duniterpy): Update to 1.1.1. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Add more tweaks for hard coded version ranges. [native-inputs]: Add PYTHON-POETRY-CORE. Marius Bakke 2023-09-04gnu: p2pool: Update to 3.6.2....* gnu/packages/finance.scm (p2pool): Update to 3.6.2. Guillaume Le Vaillant 2023-09-02gnu: electrum: Update to 4.4.6....* gnu/packages/finance.scm (electrum): Update to 4.4.6. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> fanquake