aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2018, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2021, 2022, 2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages scribus)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages cups)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages hunspell)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages image)
  #:use-module (gnu packages imagemagick)
  #:use-module (gnu packages libreoffice)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pdf)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages xml))

(define-public scribus
  (package
    (name "scribus")
    (version "1.6.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/scribus/scribus/"
                           version "/scribus-" version ".tar.gz"))
       (sha256
        (base32 "066p0a9jp676qid5hf1cilrks70xchpzfck9db79rhqhk84ja355"))))
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f                      ;no test target
       #:configure-flags
       '("-DWANT_GRAPHICSMAGICK=1"
         "-DWANT_CPP17=ON")))
    (inputs
     (list boost
           cairo
           cups
           fontconfig
           freetype
           graphicsmagick
           harfbuzz
           hunspell
           icu4c
           lcms
           libcdr
           libfreehand
           libjpeg-turbo
           libmspub
           libpagemaker
           librevenge
           libtiff
           libvisio
           libxml2
           libzmf
           openssl
           podofo
           poppler
           python                       ;need Python library
           qtbase-5
           qtdeclarative-5
           zlib))
    (native-inputs
     (list pkg-config qttools-5 util-linux))
    (home-page "https://www.scribus.net")
    (synopsis "Desktop publishing and page layout program")
    (description
     "Scribus is a @dfn{desktop publishing} (DTP) application and can
be used for many tasks; from brochure design to newspapers, magazines,
newsletters and posters to technical documentation.  Scribus supports
professional DTP features, such as CMYK color and a color management
system to soft proof images for high quality color printing, flexible
PDF creation options, Encapsulated PostScript import/export and
creation of four color separations, import of EPS/PS and SVG as native
vector graphics, Unicode text including right to left scripts such as
Arabic and Hebrew via FreeType.")
    (license license:gpl2+)))
d Maxime Devos 2024-08-18gnu: knot-resolver: Update to 5.7.4....* gnu/packages/dns.scm (knot-resolver): Update to 5.7.4. Change-Id: I1902c3ced083c5cbb360aa65517cde339b5e0893 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Ashish SHUKLA 2024-08-18gnu: knot: Update to 3.3.8...* gnu/packages/dns.scm (knot): Update to 3.3.8. Change-Id: Ia9c2a07c852af13383dfb1d37ae1350a25bae533 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Ashish SHUKLA 2024-08-17gnu: unbound: Fix cross-compilation....* gnu/packages/dns.scm (unbound)[native-inputs]: Add python-wrapper. Change-Id: I98f5e11dad2d89a4f25fca8e0935134b39e779e3 Zheng Junjie 2024-08-17gnu: unbound: Update to 1.21.0....* gnu/packages/dns.scm (unbound): Update to 1.21.0. Change-Id: Ie398f85371aeaa673034d3c1545f31d2c9305f92 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Ashish SHUKLA 2024-06-24gnu: openresolv: Update to 3.13.2....* gnu/packages/dns.scm (openresolv): Update to 3.13.2. * gnu/packages/patches/openresolv-restartcmd-guix.patch: Adjust. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sergey Trofimov 2024-06-24gnu: isc-bind: Update to 9.19.24....* gnu/packages/dns.scm (isc-bind): Update to 9.19.24. Change-Id: I0fc1128191dbda349ac27a9d1b7bf67b59caac39 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Wilko Meyer 2024-06-02gnu: knot: Remove input labels....* gnu/packages/dns.scm (knot)[inputs]: Remove labels. Change-Id: I03be6db350b939f8a17c8a2e572dda62b16b48af Ludovic Courtès 2024-06-02gnu: knot: Build against libbpf 0.8....Commit 12d2a6e5a6f412d91ba0c34a1c3c080c6c587cc6 introduced a regression whereby ./configure would error out for lack of libxdp. * gnu/packages/dns.scm (knot)[inputs]: Replace LIBBPF with LIBBPF-0.8. Change-Id: Ifeeacc27705d4d617ee0c58672f22d5f9de06389 Ludovic Courtès 2024-03-17gnu: smartdns: Update to 45....* gnu/packages/dns.scm (smartdns): Update to 45. [arguments]<#:make-flags>: Obtain version with ‘package-version’. [native-inputs]: Add which. Change-Id: I1b572753cba53f6e8f8105541c1292e03dec9053 Hilton Chain 2024-02-28gnu: bind: Update to 9.19.21 [security fixes]....The current release fixes CVE-2023-50387 and other security issues. Previous releases fix many other security issues. * gnu/packages/dns.scm (bind): Update to 9.19.21. [source]: Remove 'patches' field. * gnu/packages/patches/bind-re-add-attr-constructor-priority.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I2415de88f16d9c952a1adcee5219980a3a19bb59 John Kehayias 2024-02-28gnu: knot-resolver: Update to 5.7.1 [security fixes]....Fixes CVE-2023-50868 and CVE-2023-50387 as well as other security issues. * gnu/packages/dns.scm (knot-resolver): Update to 5.7.1. Change-Id: I8d3b084d6ff356593651ff4864edc7cffadcf442 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I2b2304aaf96582bca81d3f20a5d5a60c3daff68d John Kehayias 2024-02-28gnu: knot: Update to 3.3.4....* gnu/packages/dns.scm (knot): Update to 3.3.4. Change-Id: I5ea3bdd8060da8c32c404473197e02bcb3018d7b John Kehayias 2024-02-28gnu: unbound: Update to 1.19.1 [security fixes]....Fixes CVE-2023-50387 and CVE-2023-50868 * gnu/packages/dns.scm (unbound): Update to 1.19.1. Change-Id: I25f87ce60c87d1ed9dfbb41983039440fb396191 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: If6bb9b782d775dfacbc6d4c6dedc3e6cfeb2b6b3 John Kehayias 2024-02-28gnu: dnsmasq: Update to 2.90 [security fixes]....Fixes CVE 2023-50387 and CVE 2023-50868. * gnu/packages/dns.scm (dnsmasq): Update to 2.90. Change-Id: Id814dd2a562fe3c90673b98f7e0d6f3571988a90 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I191a62d62f202c65d7063eed0368affc115d82ca John Kehayias 2023-11-19gnu: knot: Update to 3.3.2....* gnu/packages/dns.scm (knot): Update to 3.3.2. Change-Id: Ic4909301027c75d269774fa9c52562933283f46c Tobias Geerinckx-Rice