aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2018, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2021, 2022, 2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages scribus)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages cups)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages ghostscript)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages hunspell)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages image)
  #:use-module (gnu packages imagemagick)
  #:use-module (gnu packages libreoffice)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pdf)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages xml))

(define-public scribus
  (package
    (name "scribus")
    (version "1.6.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/scribus/scribus/"
                           version "/scribus-" version ".tar.gz"))
       (sha256
        (base32 "066p0a9jp676qid5hf1cilrks70xchpzfck9db79rhqhk84ja355"))))
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f                      ;no test target
       #:configure-flags
       '("-DWANT_GRAPHICSMAGICK=1"
         "-DWANT_CPP17=ON")))
    (inputs
     (list boost
           cairo
           cups
           fontconfig
           freetype
           graphicsmagick
           harfbuzz
           hunspell
           icu4c
           lcms
           libcdr
           libfreehand
           libjpeg-turbo
           libmspub
           libpagemaker
           librevenge
           libtiff
           libvisio
           libxml2
           libzmf
           openssl
           podofo
           poppler
           python                       ;need Python library
           qtbase-5
           qtdeclarative-5
           zlib))
    (native-inputs
     (list pkg-config qttools-5 util-linux))
    (home-page "https://www.scribus.net")
    (synopsis "Desktop publishing and page layout program")
    (description
     "Scribus is a @dfn{desktop publishing} (DTP) application and can
be used for many tasks; from brochure design to newspapers, magazines,
newsletters and posters to technical documentation.  Scribus supports
professional DTP features, such as CMYK color and a color management
system to soft proof images for high quality color printing, flexible
PDF creation options, Encapsulated PostScript import/export and
creation of four color separations, import of EPS/PS and SVG as native
vector graphics, Unicode text including right to left scripts such as
Arabic and Hebrew via FreeType.")
    (license license:gpl2+)))
any more. Remove a configure flag which is not recognized by the configure script any more. Andreas Enge 2023-08-17gnu: biber: Update to 2.17....* gnu/packages/texlive.scm (biber): Update to 2.17. Andreas Enge 2023-08-17gnu: texlive: Update to 2022....* gnu/packages/texlive.scm (%texlive-date): Update to 20220321. (texlive-extra-src, texlive-texmf-src, texlivebin): Update source hashes. Andreas Enge 2023-08-17gnu: texlive: Simplify the monolithic build....This removes phases added for the needs of the modular build system. It reverts commit dfdc002c9bf86270941823a96abded0aa5d44088 and subsequent ones, which download scripts from subversion instead of using those from the distribution. It also reverts the changes started in commit 04a0b1e09abce99857e7930336421ca6d15ae630 and removes the GUIX_TEXMF environment variable. * gnu/packages/texlive.scm (%texlive-tag, %texlive-revision): Remove variables. (texlivebin)[inputs]: Remove texlive-scripts. [phases]: Remove 'unpack-texlive-scripts, 'patch-scripts and 'customize-texmf.cnf and the script handling in 'post-install. [native-search-paths]: Remove them. Andreas Enge 2023-08-17gnu: texlive: Reinstate the monolithic texlive package....This goes back essentially to commit ad457d01147b8d6fcb4ee64b2dc2d699caa1d1ee and defines the monolithic texlive packages independently of the modular ones. It also downgrades their version to 2021. Not using dashes in the names of texlivebin and texlivetexmf prevents the profile hook for font mapping from being run during the command "guix shell -D texlive". * gnu/packages/tex.scm (texlive-bin-full): Remove variable. (biber): Remove variable deprecation. (texlive-texm, texlive): Move variables from here... * gnu/packages/texlive.scm (texlivetexm, texlive): ...to this new file. (%texlive-date, %texlive-version, %texlive-tag, %texlive-revision, texlive-extra-src, texlive-texmf-src, texlivebin): New variables. (biber): Add variable again. * gnu/packages/patches/biber-adapt-perl-5.36.patch: Add file again. * gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Register files. Andreas Enge