aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages sawfish)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages crypto)
  #:use-module (gnu packages dbm)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages libffi)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages texinfo)
  #:use-module (gnu packages base)
  #:use-module (gnu packages xorg))

(define-public librep
  (package
    (name "librep")
    (version "0.92.7")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://download.tuxfamily.org/librep/"
                                  "librep_" version ".tar.xz"))
              (sha256
               (base32
                "1bmcjl1x1rdh514q9z3hzyjmjmwwwkziipjpjsl301bwmiwrd8a8"))))
    (build-system gnu-build-system)
    (native-inputs
     (list texinfo pkg-config autoconf automake libtool))
    (inputs
     (list gdbm gmp libffi readline))
    (native-search-paths
     (list (search-path-specification
            (variable "REP_DL_LOAD_PATH")
            (files '("lib/rep")))))
    (home-page "https://sawfish.fandom.com/wiki/Librep")
    (synopsis "Lisp system for sawfish")
    (description
     "Librep is a dialect of Lisp, designed to be used both as an extension
language for applications and as a general purpose programming language.  It
was originally written to be mostly-compatible with Emacs Lisp, but has
subsequently diverged markedly.  Its aim is to combine the best features of
Scheme and Common Lisp and provide an environment that is comfortable for
implementing both small and large scale systems.")
    (license gpl2+)))

(define-public rep-gtk
  (package
    (name "rep-gtk")
    (version "0.90.8.3")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://download.tuxfamily.org/librep/"
                                  name "/" name "_" version ".tar.xz"))
              (sha256
               (base32
                "0hgkkywm8zczir3lqr727bn7ybgg71x9cwj1av8fykkr8pdpard9"))
              (modules '((guix build utils)))
              (snippet
               '(begin
                  (substitute* "Makefile.in"
                    (("installdir=\\$\\(repexecdir\\)")
                     ;; Install libraries for librep to $out/lib/rep.
                     "installdir=$(libdir)/rep"))
                  #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:tests? #f ; no tests
       #:phases
       (modify-phases %standard-phases
         (add-before 'bootstrap 'remove-autogen
           (lambda _
             ;; Remove autogen.sh so that the bootstrap phase can run
             ;; autoreconf.
             (delete-file "autogen.sh")
             #t)))))
    (native-inputs
     (list autoconf automake libtool pkg-config))
    (propagated-inputs
     ;; required by rep-gtk.pc.
     (list gtk+-2 librep))
    (home-page "https://sawfish.fandom.com/wiki/Rep-GTK")
    (synopsis "GTK+ binding for librep")
    (description
     "Rep-GTK is a GTK+ (and GLib, GDK) binding to the librep, and one of the
backend of Sawfish.")
    (license gpl2+)))

(define-public sawfish
  (package
    (name "sawfish")
    (version "1.13.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://download.tuxfamily.org/sawfish/"
                                  name "_" version ".tar.xz"))
              (sha256
               (base32
                "0pdgf9w5vrn3kfqxwggikj4yqg82rpy8ji613zdhidacz9dkqsw1"))
              (modules '((guix build utils)))
              (snippet
               '(begin
                  (substitute* "Makedefs.in"
                    (("/bin/sh") "@SHELL@")
                    (("REP_DL_LOAD_PATH=")
                     ;; To find rep-gtk when building sawfish.
                     "REP_DL_LOAD_PATH=$(REP_DL_LOAD_PATH):"))
                  (substitute* "src/Makefile.in"
                    ;; Install libraries for librep to $out/lib/rep.
                    (("\\$\\(repexecdir\\)") "$(libdir)/rep"))))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:tests? #f ; no tests
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'configure 'patch-exec-rep
            (lambda _
              (substitute* '("lisp/sawfish/cfg/main.jl.in"
                             "scripts/sawfish-about.jl.in"
                             "scripts/sawfish-client.jl"
                             "scripts/sawfish-menu.jl")
                (("exec rep") (string-append "exec " (which "rep"))))))
          (add-after 'install 'wrap-scripts
            ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
            ;; and sawfish.client.
            (lambda* (#:key outputs #:allow-other-keys)
              (define (wrap-script script)
                (let ((out (assoc-ref outputs "out")))
                  (wrap-program (string-append out script)
                    `("REP_DL_LOAD_PATH" =
                      ,(list (getenv "REP_DL_LOAD_PATH")
                             (string-append out "/lib/rep"))))))
              (for-each wrap-script
                        (list "/bin/sawfish-about"
                              "/bin/sawfish-client"
                              "/bin/sawfish-config"
                              "/lib/sawfish/sawfish-menu")))))))
    (native-inputs
     (list gettext-minimal
           texinfo
           pkg-config
           which))
    (inputs
     (list bash-minimal
           gdk-pixbuf-xlib
           gmp
           libsm
           libxcrypt
           libxft
           libxinerama
           libxrandr
           libxtst
           rep-gtk))
    (home-page "https://sawfish.tuxfamily.org")
    (synopsis "Configurable window manager")
    (description
     "Sawfish is an extensible window manager using a Lisp-based scripting
language.  Its policy is very minimal compared to most window managers.  Its aim
is simply to manage windows in the most flexible and attractive manner possible.
All high-level WM functions are implemented in Lisp for future extensibility or
redefinition.")
    (license gpl2+)))
elft-icon-theme): Update to 1.12. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Leo Prikler 2020-05-16gnu: papirus-icon-theme: Update to 20200430....* gnu/packages/gnome-xyz.scm (papirus-icon-theme): Update to 20200430. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Leo Prikler 2020-05-16gnu: matcha-theme: Update to 2020-05-09....* gnu/packages/gnome-xyz.scm (matcha-theme): Update to 2020-05-09. [source]: Update URL. [arguments]: Update build script. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Leo Prikler 2020-05-09gnu: gnome-shell-extension-gsconnect: Update to 33....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect): Update to 33. [inputs]: Remove folks. Alex Griffin 2020-05-06gnu: Add gnome-shell-extension-clipboard-indicator....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-clipboard-indicator): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Jack Hill 2020-04-12gnu: gnome-shell-extension-hide-app-icon: Fix grammar of "allows to hide" to..."hides". * gnu/packages/gnome-xyz (gnome-shell-extension-hide-app-icon): Fix grammar. Vagrant Cascadian 2020-03-29gnu: numix-gtk-theme: Fix installation directory....* gnu/packages/gnome-xyz.scm (numix-gtk-theme)[arguments]: Replace erroneous use of DESTDIR with INSTALL_DIR in #:make-flags. Tobias Geerinckx-Rice 2020-03-29gnu: numix-gtk-theme: Fix name....* gnu/package/gnome-xyz.scm (numix-gtk-theme): New public variable, renamed from…… (numix-theme): …this now-deprecated one. Tobias Geerinckx-Rice 2020-03-29gnu: numix-theme: The ‘check’ phase already respects ‘#:tests?’....* gnu/packages/gnome-xyz.scm (numix-theme)[arguments]: Don't delete the ‘check’ phase. Tobias Geerinckx-Rice 2020-03-22gnu: gnome-shell-extension-paperwm: Update to 36.0....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm): Update to 36.0. Alex Griffin 2020-03-21gnu: Add gnome-shell-extension-topicons-redux....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-topicons-redux): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Ekaitz Zarraga 2020-03-16gnu: gnome-shell-extension-appindicator: Update to 33....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator): Update to 33. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Ekaitz Zarraga 2020-02-28gnu: delft-icon-theme: Update to 1.11....* gnu/packages/gnome-xyz.scm (delft-icon-theme): Update to 1.11. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz> Leo Prikler 2020-02-28gnu: delft-icon-theme: Use the copy-build-system....* gnu/packages/gnome-xyz.scm (delft-icon-theme): Use the copy-build-system. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz> Leo Prikler 2020-02-27gnu: gnome-shell-extension-noannoyance: Fix synopsis and description....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance)[synopsis]: Use imperative form. [description]: Remove spurious comma. Pierre Neidhardt 2020-02-27gnu: gnome-shell-extension-noannoyance: Use the copy-build-system....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance): Use the copy-build-system. Leo Prikler 2020-02-27gnu: gnome-shell-extension-appindicator: Use the copy-build-system....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator): Use the copy-build-system. Leo Prikler 2020-02-27gnu: Add gnome-shell-extension-gsconnect....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect): New variable. Alex Griffin 2020-02-21gnu: gnome-shell-extension-paperwm: Install compiled gschemas....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm)[arguments]: Install compiled gschemas. Signed-off-by: Alex Griffin <a@ajgrf.com> Jack Hill 2020-02-21gnu: gnome-shell-extension-paperwm: Recompile schemas....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm) [source]: Remove gschemas.compiled in a snippet. [arguments]: Add compile-schemas phase. [native-inputs]: Add glib. Signed-off-by: Alex Griffin <a@ajgrf.com> Jack Hill 2020-02-21gnu: Add gnome-shell-extension-paperwm....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm): New variable. Alex Griffin 2020-02-05gnu: Add gnome-shell-extension-appindicator....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2019-12-25Revert "gnu: gnome-shell-extension-dash-to-dock: Update to 67."...This reverts commit 5a30234c210dfb37da832125cdbda6a9a0c585ca, which assumes you're running Gnome 3.34, which is unlikely. Tobias Geerinckx-Rice 2019-12-23gnu: gnome-shell-extension-dash-to-dock: Update to 67....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock): Update to 67. Tobias Geerinckx-Rice 2019-12-23gnu: gnome-shell-extension-dash-to-dock: Depropagate glib:bin....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock): [propagated-inputs]: Move glib:bin from here... [native-inputs]: ... to here. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Leo Prikler 2019-12-23gnu: gnome-shell-extension-hide-app-icon: Fix installation....* gnu/packages/gnome-xyz.scm: (gnome-shell-extension-hide-app-icon): [arguments]: Install in subdirectory. Adjust indentation. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Leo Prikler 2019-12-20gnu: Add gnome-shell-extension-hide-app-icon....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Leo Prikler 2019-12-19gnu: Add gnome-shell-extension-dash-to-panel....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-panel): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2019-12-15gnu: Add papirus-icon-theme....* gnu/packages/gnome-xyz.scm (papirus-icon-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2019-12-11gnu: gnome-shell-extension-dash-to-dock: Update to 66....* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-dock): Update to 66. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Leo Prikler 2019-12-09gnu: delft-icon-theme: Fix broken icons....* gnu/packages/gnome-xyz (delft-icon-theme): Inherit from Adwaita instead of using the (non-existing) GNOME theme. Signed-off-by: Brett Gilio <brettg@posteo.net> Leo Prikler