aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rush)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public rush
  (package
    (name "rush")
    (version "2.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/rush/rush-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1nqjjbamdn4lcysc2hji3i73jjl1ghivb24h12zh79xnka438vr6"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/rush/")
    (synopsis "Restricted user (login) shell")
    (description
     "GNU Rush is a restricted user shell, for systems on which users are to
be provided with only limited functionality or resources.  Administrators set
user rights via a configuration file which can be used to limit, for example,
the commands that can be executed, CPU time, or virtual memory usage.")
    (license gpl3+)))
> 2020-01-10gnu: hplip: Fix scanner model detection....Danny Milosavljevic 2020-01-03Merge branch 'master' into stagingMarius Bakke 2019-12-24gnu: hplip: Update to 3.19.12....Tobias Geerinckx-Rice 2019-12-11gnu: cups-filters: Update to 1.25.13....Marius Bakke 2019-11-15Merge branch 'master' into stagingMarius Bakke 2019-11-08gnu: hplip: Actually wrap binaries....Tobias Geerinckx-Rice 2019-11-05gnu: hplip: Update to 3.19.11....Tobias Geerinckx-Rice 2019-11-03gnu: hplip: Update to 3.19.10....Tobias Geerinckx-Rice 2019-10-13gnu: cups-filters: Update to 1.25.11....Marius Bakke 2019-10-09gnu: CUPS: Update to 2.3.0....Marius Bakke 2019-10-09gnu: cups-filters: Update to 1.25.7....Marius Bakke 2019-09-11gnu: foo2zjs: Update to 20190909....Tobias Geerinckx-Rice 2019-09-01gnu: hplip: Update to 3.19.8....Tobias Geerinckx-Rice 2019-08-30gnu: Add splix....Tobias Geerinckx-Rice 2019-08-23gnu: foomatic-filters: Don't use NAME in source URI....Tobias Geerinckx-Rice 2019-08-23gnu: foo2zjs: Update to 20190517....Tobias Geerinckx-Rice 2019-08-04gnu: cups-filters: Update to 1.25.1....Marius Bakke 2019-06-14gnu: cups-filters: Update to 1.25.0....Marius Bakke 2019-05-24gnu: cups-filters: Update to 1.23.0....Marius Bakke 2019-05-17gnu: foo2zjs: Update source hash....Tobias Geerinckx-Rice 2019-04-23Merge branch 'master' into stagingMarius Bakke 2019-04-22gnu: foo2zjs: Update to 20190413....Tobias Geerinckx-Rice 2019-04-01gnu: cups-filters: Update to 1.22.3....Marius Bakke 2019-03-23gnu: CUPS: Update to 2.2.11....Marius Bakke 2019-03-21Merge branch 'master' into stagingMarius Bakke 2019-03-17gnu: cups-filters: Update to 1.22.2....Marius Bakke 2019-03-15gnu: hplip-minimal: Remove dependency on Python & co....Ludovic Courtès 2019-03-15gnu: hplip: Do not keep reference to GCC....Ludovic Courtès 2019-03-15gnu: hplip: Remove pre-built executable from the source....Ludovic Courtès 2019-03-07gnu: cups-filters: Fix build with newer version of poppler....Ricardo Wurmus