aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rush)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public rush
  (package
    (name "rush")
    (version "2.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/rush/rush-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1nqjjbamdn4lcysc2hji3i73jjl1ghivb24h12zh79xnka438vr6"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/rush/")
    (synopsis "Restricted user (login) shell")
    (description
     "GNU Rush is a restricted user shell, for systems on which users are to
be provided with only limited functionality or resources.  Administrators set
user rights via a configuration file which can be used to limit, for example,
the commands that can be executed, CPU time, or virtual memory usage.")
    (license gpl3+)))
td>gnu: mympd: Update to 10.3.3....* gnu/packages/mpd.scm (mympd): Update to 10.3.3. <arguments>: Honor 'strip phase. <native-inputs>: Add missing pkg-config. <description>: Reword it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-06-04gnu: mpd: Split outputs....The HTML manual accounts for more than 40% of the package size. * gnu/packages/mpd.scm (mpd)[outputs]: Add 'doc' output. [arguments]<#:phases>: Add ‘split-package’. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Bruno Victal 2023-06-04gnu: mpd: Enable tests....With this, ninja will no longer report “no work to do” when inside the `check' phase. * gnu/packages/mpd.scm [arguments]<#:configure-flags>: Add “-Dtest=true”. [native-inputs]: Add googletest and zip. Remove cmake. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Bruno Victal 2023-06-04gnu: mpd: Update to 0.23.13....* gnu/packages/mpd.scm (mpd): Update to 0.23.13. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Leo Famulari 2023-05-19gnu: mympd: Update to 10.3.2....* gnu/packages/mpd.scm (mympd): Update to 10.3.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-04-25gnu: mpdevil: Add missing input....* gnu/packages/mpd.scm (mpdevil)[native-inputs]: Add gettext-minimal. Efraim Flashner 2023-04-23gnu: ncmpc: Update to 0.48....* gnu/packages/mpd.scm (ncmpc): Update 0.48. Leo Famulari 2023-04-21gnu: mpdevil: Update to 1.10.2....* gnu/packages/mpd.scm (mpdevil): Update to 1.10.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> kiasoc5 2023-03-27gnu: mympd: Update to 10.2.6....* gnu/packages/mpd.scm (mympd): Update to 10.2.6. Signed-off-by: Christopher Baines <mail@cbaines.net> Bruno Victal 2023-03-02gnu: mympd: Update to 10.2.4....* gnu/packages/mpd.scm (mympd): Update to 10.2.4. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Bruno Victal 2023-02-23gnu: mpdris2: Remove input labels and add inputs....* gnu/packages/mpd.scm (mpdris2)[arguments]: Use G-expressions. Remove trailing #T from phase. [inputs]: Remove labels. Add BASH-MINIMAL and PYTHON-MUTAGEN. [native-inputs]: Remove labels. [description]: Use complete sentence. Simon Streit 2023-02-12gnu: mympd: Update to 10.2.3....* gnu/packages/mpd.scm (mympd): Update to 10.2.3. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Bruno Victal 2023-02-11gnu: mympd: Update to 10.2.2....* gnu/packages/mpd.scm (mympd): Update to 10.2.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Bruno Victal 2023-02-05gnu: mpd: Update to 0.23.12....* gnu/packages/mpd.scm (mpd): Update to 0.23.12. Signed-off-by: Leo Famulari <leo@famulari.name> Bruno Victal 2023-02-05gnu: mpd: Add missing inputs....Enable more features for MPD. * gnu/packages/mpd.scm (mpd)[inputs]: Add liburing, chromaprint, expat, libgme, libnfs, libopenmpt, libshout, pcre2, soxr, yajl and zziplib. Signed-off-by: Leo Famulari <leo@famulari.name> Bruno Victal 2023-02-03gnu: mympd: Update to 10.2.1....* gnu/packages/mpd.scm (mympd): Update to 10.2.1. Signed-off-by: Christopher Baines <mail@cbaines.net> Bruno Victal 2023-01-29gnu: mpdevil: Update to 1.10.0...* gnu/packages/mpd.scm (mpdevil): Update to 1.10.0. [inputs]: Add python-pycairo. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Simon Streit 2023-01-28gnu: mympd: Update to 10.2.0....* gnu/packages/mpd.scm (mympd): Update to 10.2.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Bruno Victal 2023-01-08gnu: Switch to default pipewire....This is a follow-up of: 590700ce00177a826872c867066eeba6eb7c4641. * gnu/packages/kde-plasma.scm (kwin, plasma-desktop, plasma-workspace)[inputs]: Switch to pipewire. * gnu/packages/mpd.scm (mpd)[inputs]: Ditto. Mathieu Othacehe 2022-12-11gnu: mpd: Update to 0.23.11....* gnu/packages/mpd.scm (mpd): Update to 0.23.11. Tobias Geerinckx-Rice