aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rush)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public rush
  (package
    (name "rush")
    (version "2.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/rush/rush-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1nqjjbamdn4lcysc2hji3i73jjl1ghivb24h12zh79xnka438vr6"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/rush/")
    (synopsis "Restricted user (login) shell")
    (description
     "GNU Rush is a restricted user shell, for systems on which users are to
be provided with only limited functionality or resources.  Administrators set
user rights via a configuration file which can be used to limit, for example,
the commands that can be executed, CPU time, or virtual memory usage.")
    (license gpl3+)))
06-04 13:37:25 -0400'>2019-06-04gnu: MPD: Update to 0.21.9....Leo Famulari 2019-05-24gnu: Move Sphinx and friends to (gnu packages sphinx)....Marius Bakke 2019-04-26gnu: MPD: Update to 0.21.8....Leo Famulari 2019-04-15gnu: ncmpc: Update to 0.34....Tobias Geerinckx-Rice 2019-04-04gnu: MPD: Update to 0.21.7....Leo Famulari 2019-03-18gnu: MPD: Update to 0.21.6....Leo Famulari 2019-03-05gnu: MPD: Update to 0.21.5....Leo Famulari 2019-02-10gnu: MPD: Update to 0.21.4....Leo Famulari 2019-01-20Merge branch 'master' into stagingLudovic Courtès 2019-01-16gnu: Move sqlite to separate module....Ricardo Wurmus 2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus 2018-12-22Merge branch 'master' into stagingMarius Bakke 2018-12-21gnu: ncmpc: Update to 0.33....Eric Bavier 2018-12-13gnu: Fix misplaced commas (unquotes)....Mark H Weaver 2018-12-12gnu: Remove special Boost C++14 variant....Marius Bakke 2018-12-07gnu: Add a C++14 variant of Boost for packages that need it....Leo Famulari 2018-11-01gnu: MPD: Update to 0.20.23....Leo Famulari 2018-11-01gnu: mpd-mpc: Update to 0.31....Leo Famulari 2018-10-21gnu: libmpdclient: Update to 2.16....Leo Famulari 2018-10-07gnu: ncmpc: Update to 0.32....Leo Famulari 2018-09-18gnu: ncmpc: Update to 0.30....Tobias Geerinckx-Rice 2018-09-06gnu: libmpdclient: Update to 2.15....Tobias Geerinckx-Rice 2018-08-24gnu: ncmpc: Update to 0.29....Tobias Geerinckx-Rice 2018-08-18gnu: mpd: Update to 0.20.21....Tobias Geerinckx-Rice 2018-06-27gnu: python-mpd2: Return #t from phases....Tobias Geerinckx-Rice 2018-05-29gnu: mpd: Update to 0.20.20....Leo Famulari 2018-05-12gnu: MPD: Remove unecessary dependency on libmad....Leo Famulari 2018-05-06gnu: mpd-mpc: Update to 0.30....Leo Famulari 2018-04-27gnu: mpd: Update to 0.20.19....Tobias Geerinckx-Rice 2018-04-15gnu: ncmpcpp: Update to 0.8.2....Leo Famulari 2018-03-21gnu: mpd: Update to 0.20.18....Leo Famulari 2018-02-22gnu: mpd-mpc: Update to 0.29....Leo Famulari 2018-02-22gnu: mpd: Update to 0.20.17....Leo Famulari 2018-02-22gnu: libmpdclient: Update to 2.14....Leo Famulari 2018-02-16gnu: Use HTTPS for supported nongnu.org home pages....Tobias Geerinckx-Rice 2018-01-22gnu: mpd: Update to 0.20.15....Leo Famulari 2018-01-13gnu: mpd: Remove (gnu packages gcc) import....Tobias Geerinckx-Rice 2018-01-13gnu: mpd: Use HTTPS for musicpd.org home pages....Tobias Geerinckx-Rice 2018-01-13gnu: mpdscribble: Update home page....Tobias Geerinckx-Rice 2018-01-13gnu: libmpdclient: Update to 2.13....Tobias Geerinckx-Rice