aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rush)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public rush
  (package
    (name "rush")
    (version "2.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/rush/rush-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1nqjjbamdn4lcysc2hji3i73jjl1ghivb24h12zh79xnka438vr6"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/rush/")
    (synopsis "Restricted user (login) shell")
    (description
     "GNU Rush is a restricted user shell, for systems on which users are to
be provided with only limited functionality or resources.  Administrators set
user rights via a configuration file which can be used to limit, for example,
the commands that can be executed, CPU time, or virtual memory usage.")
    (license gpl3+)))
'>* gnu/packages/python-science.scm (python-scikit-fem): New variable. Vinicius Monego 2023-07-15gnu: python-distributed: Update to 2023.7.0....* gnu/packages/python-science.scm (python-distributed): Update to 2023.7.0. Ricardo Wurmus 2023-07-13gnu: Add python-plotnine....* gnu/packages/python-science.scm (python-plotnine): New variable. Ricardo Wurmus 2023-06-29gnu: python-pandas-flavor: Update to 0.5.0....* gnu/packages/python-science.scm (python-pandas-flavor): Update to 0.5.0. [propagated-inputs]: Add python-lazy-loader and python-packaging. [home-page]: Update. Arun Isaac 2023-06-29gnu: python-distributed: Disable timeout test....* gnu/packages/python-science.scm (python-distributed)[arguments]: Disable test_nanny_timeout, because it times out. Ricardo Wurmus 2023-06-25gnu: python-trimesh: Update to 3.22.1....* gnu/packages/python-science.scm (python-trimesh): Update to 3.22.1. [arguments]<#:phases>: Update path in 'fix-build' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-06-25gnu: Add python-pytensor....* gnu/packages/python-science.scm (python-pytensor): New variable. Vinicius Monego 2023-06-25gnu: Add python-xarray-einstats....* gnu/packages/python-science.scm (python-xarray-einstats): New variable. Vinicius Monego 2023-06-25gnu: python-xarray: Update to 2023.6.0....* gnu/packages/python-science.scm (python-xarray): Update to 2023.6.0. [build-system]: Switch to pyproject-build-system. [arguments]: Do not override the check phase. Vinicius Monego 2023-06-25gnu: Add python-einops....* gnu/packages/python-science.scm (python-einops): New variable. Vinicius Monego 2023-06-20gnu: python-pyvista: Update to 0.39.1....* gnu/packages/python-science.scm (python-pyvista): Update to 0.39.1. [propagated-inputs]: Add python-pooch, remove python-appdirs. Signed-off-by: Christopher Baines <mail@cbaines.net> Paul A. Patience 2023-05-11gnu: python-distributed: Update to 2023.4.1....* gnu/packages/python-science.scm (python-distributed): Update to 2023.4.1. [source]: Remove snippet. [arguments]: Update build phase 'versioneer; restore 'sanity-check phase; simplify custom 'check phase; add 'fix-pytest-config phase; use #:test-flags. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-importlib-metadata. Ricardo Wurmus 2023-05-10gnu: python-scikit-optimize: Fix build with newer numpy and sklearn....* gnu/packages/patches/python-scikit-optimize-1148.patch, gnu/packages/patches/python-scikit-optimize-1150.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/python-science.scm (python-scikit-optimize)[source]: Fetch with git and apply patches. Ricardo Wurmus 2023-05-08gnu: python-bottleneck: Honor #:tests? flag....* gnu/packages/python-science.scm (python-bottleneck)[arguments]: Adjust custom 'check phase to honor the #:tests? flag. Efraim Flashner 2023-05-08gnu: python-bottleneck: Update to 1.3.7....* gnu/packages/python-science.scm (python-bottleneck): Update to 1.3.7. Efraim Flashner 2023-04-26gnu: python-distributed: Fix build....* gnu/packages/python-science.scm (python-distributed)[build-system]: Use pyproject-build-system. [arguments]: Hide deprecation warnings from tornado, because they break almost all tests; disable three more tests. Ricardo Wurmus 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-11gnu: python-scipy: Update to 1.10.1....* gnu/packages/python-science.scm (python-scipy): Update to 1.10.1. [build-system]: Use pyproject-build-system. [arguments]: Add #:build-backend argument. Remove loosen-requirements, build and install phases. [native-inputs]: Remove python-pypa-build. Maxim Cournoyer 2023-03-24gnu: python-scikit-allel: Use pyproject-build-system....* gnu/packages/python-science.scm (python-scikit-allel): Move up to create alphabetic order. [build-system]: Use pyproject-build-system. [arguments]: Provide test flags instead of overriding 'check phase; split out build step into new 'build-ext phase. Disable roh_mhmm tests. Ricardo Wurmus 2023-03-24gnu: Add python-scikit-optimize....* gnu/packages/python-science.scm (python-scikit-optimize): New variable. Ricardo Wurmus 2023-03-21gnu: Add python-libneuroml....* gnu/packages/python-science.scm (python-libneuroml): New variable. Lars-Dominik Braun 2023-03-21gnu: Add python-pylems....* gnu/packages/python-science.scm (python-pylems): New variable. Lars-Dominik Braun 2023-01-08gnu: Add python-pydicom....* gnu/packages/python-science.scm (python-pydicom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Antero Mejr 2022-12-05gnu: python-sgp4: Move to astronomy....* gnu/packages/astronomy.scm: (python-sgp4): Move here from python-science.scm. [description]: Expand description, annotate acronyms, add link to CelesTrak. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-12-05gnu: python-sgp4: Update to 2.21....The latest version passes build on aarch64-linux system. * gnu/packages/python-science.scm (python-sgp4): Update to 2.21. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-12-02gnu: python-msgpack-numpy: Update to 0.4.8....* gnu/packages/python-science.scm (python-msgpack-numpy): Update to 0.4.8. Navid Afkhami