aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rush)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public rush
  (package
    (name "rush")
    (version "2.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/rush/rush-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1nqjjbamdn4lcysc2hji3i73jjl1ghivb24h12zh79xnka438vr6"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/rush/")
    (synopsis "Restricted user (login) shell")
    (description
     "GNU Rush is a restricted user shell, for systems on which users are to
be provided with only limited functionality or resources.  Administrators set
user rights via a configuration file which can be used to limit, for example,
the commands that can be executed, CPU time, or virtual memory usage.")
    (license gpl3+)))
. * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Likewise. (scintilla)[native-inputs]: Remove GCC-9. * gnu/packages/build-tools.scm (bear)[native-inputs]: Likewise. * gnu/packages/cpp.scm (magic-enum)[native-inputs]: Likewise. * gnu/packages/games.scm (openttd)[native-inputs]: Likewise. (schiffbruch)[native-inputs]: Remove GCC-11. * gnu/packages/music.scm (liquidsfz, geonkick)[native-inputs]: Remove GCC-9. * gnu/packages/fcitx5.scm (fcitx5, libime, fcitx5-configtool)[native-inputs]: Likewise. * gnu/packages/wine.scm (dxvk32)[native-inputs]: Likewise. * gnu/packages/ftp.scm (libfilezilla)[native-inputs]: Remove GCC-8. * gnu/packages/image.scm (blurhash)[native-inputs]: Likewise. * gnu/packages/jami.scm (libring)[native-inputs]: Likewise. * gnu/packages/pdf.scm (xournalpp)[native-inputs]: Likewise. * gnu/packages/telegram.scm (webrtc-for-telegram-desktop, telegram-desktop)[native-inputs]: Likewise. Marius Bakke 2021-12-13gnu: Further simplify package inputs....This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.) Ludovic Courtès 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-10gnu: fcitx5-configtool: Update to 5.0.8....* gnu/packages/fcitx5.scm (fcitx5-configtool): Update to 5.0.8. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> dan 2021-11-10gnu: fcitx5-qt: Update to 5.0.7....* gnu/packages/fcitx5.scm (fcitx5-qt): Update to 5.0.7. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> dan 2021-11-10gnu: fcitx5-gtk: Update to 5.0.9....* gnu/packages/fcitx5.scm (fcitx5-gtk): Update to 5.0.9. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> dan 2021-11-10gnu: fcitx5: Update to 5.0.10....* gnu/packages/fcitx5.scm (fcitx5): Update to 5.0.10. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> dan 2021-06-14gnu: Rename qtbase to qtbase-5....This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit. Maxim Cournoyer 2021-06-09gnu: fcitx5-chinese-addons: Update to 5.0.6....* gnu/packages/fcitx5.scm (fcitx5-chinese-addons): Update to 5.0.6. Tobias Geerinckx-Rice 2021-06-09gnu: fcitx5-configtool: Update to 5.0.5....* gnu/packages/fcitx5.scm (fcitx5-configtool): Update to 5.0.5. Tobias Geerinckx-Rice 2021-06-09gnu: fcitx5-gtk: Update to 5.0.7....* gnu/packages/fcitx5.scm (fcitx5-gtk): Update to 5.0.7. [inputs]: Add fmt. Tobias Geerinckx-Rice 2021-06-09gnu: fcitx5-qt: Update to 5.0.6....* gnu/packages/fcitx5.scm (fcitx5-qt): Update to 5.0.6. Tobias Geerinckx-Rice 2021-06-09gnu: fcitx5: Update to fcitx5....* gnu/packages/fcitx5.scm (fcitx5): Update to fcitx5. [native-inputs]: Add gcc-9. Tobias Geerinckx-Rice 2021-06-09gnu: fcitx5-lua: Update to 5.0.5....* gnu/packages/fcitx5.scm (fcitx5-lua): Update to 5.0.5. Tobias Geerinckx-Rice 2021-06-09gnu: libime: Fix grammar in descriptions....* gnu/packages/fcitx5.scm (libime)[synopsis, description]: Exchange s. Tobias Geerinckx-Rice 2021-06-09gnu: libime: Update to 1.0.7....* gnu/packages/fcitx5.scm (libime): Update to 1.0.7. Tobias Geerinckx-Rice 2021-04-11gnu: libime: Update to 1.0.6....* gnu/packages/fcitx5.scm (libime): Update to 1.0.6. Tobias Geerinckx-Rice 2021-04-10gnu: libime: Fix typo in description....* gnu/packages/fcitx5.scm (libime)[description]: Fix typo. Tobias Geerinckx-Rice 2021-03-23gnu: fcitx5-qt: Update to 5.0.5....* gnu/packages/fcitx5.scm (fcitx5-qt): Update to 5.0.5. Tobias Geerinckx-Rice 2021-03-23gnu: libime: Update to 1.0.5....* gnu/packages/fcitx5.scm (libime): Update to 1.0.5. Tobias Geerinckx-Rice 2021-03-23gnu: xcb-imdkit: Update to 1.0.3....* gnu/packages/fcitx5.scm (xcb-imdkit): Update to 1.0.3. Tobias Geerinckx-Rice 2021-03-10gnu: fcitx5: Update to 5.0.5....* gnu/packages/fcitx5.scm (fcitx5): Update to 5.0.5. Tobias Geerinckx-Rice 2021-03-09gnu: libime: Update to 1.0.4....* gnu/packages/fcitx5.scm (libime): Update to 1.0.4. Tobias Geerinckx-Rice