aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rush)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages))

(define-public rush
  (package
    (name "rush")
    (version "2.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/rush/rush-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "1nqjjbamdn4lcysc2hji3i73jjl1ghivb24h12zh79xnka438vr6"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/rush/")
    (synopsis "Restricted user (login) shell")
    (description
     "GNU Rush is a restricted user shell, for systems on which users are to
be provided with only limited functionality or resources.  Administrators set
user rights via a configuration file which can be used to limit, for example,
the commands that can be executed, CPU time, or virtual memory usage.")
    (license gpl3+)))
ltip'>* gnu/packages/samba.scm (samba): Update to 4.13.4. Tobias Geerinckx-Rice 2021-02-07gnu: talloc: Update to 2.3.2....* gnu/packages/samba.scm (talloc): Update to 2.3.2. Tobias Geerinckx-Rice 2021-01-11gnu: ppp: Update to 2.4.9....* gnu/packages/samba.scm (ppp): Update to 2.4.9. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vincent Legoll 2021-01-02gnu: cifs-utils: Update to 6.12....* gnu/packages/samba.scm (cifs-utils): Update to 6.12. [arguments]: Remove obsolete 'bootstrap phase replacement. Tobias Geerinckx-Rice 2020-12-22gnu: samba: Update to 4.13.3....* gnu/packages/samba.scm (samba): Update to 4.13.3. Tobias Geerinckx-Rice 2020-11-07gnu: samba: Update to 4.13.2....* gnu/packages/samba.scm (samba): Update to 4.13.2. Tobias Geerinckx-Rice 2020-11-03gnu: samba: Prepare for tests....* gnu/packages/samba.scm (samba)[arguments]: Update comment regarding the test suite failure. [make-flags]: Run the test suite with the '--quick' option, as it is very slow otherwise. [phases]{configure}: Add the '--enable-selftest' argument. [inputs]: Add libtirpc. Maxim Cournoyer 2020-11-03gnu: samba: Unbundle cmocka, heimdal; add gamin....* gnu/packages/samba.scm (samba)[snippet]: Update comment. [phases]{configure}: Remove '--bundled-libraries=com_err' argument. [inputs]: Add cmocka, heimdal, gamin. Remove TODO comment. Maxim Cournoyer 2020-11-03gnu: samba: Set localstatedir to /var....It previously defaulted to a $PREFIX/var, where $PREFIX was the root of the installation directory (under /gnu/store) of Samba. * gnu/packages/samba.scm (samba)[phases]{configure}: Add --localstatedir=/var option. {disable-etc-samba-directory-creation}: Rename to disable-etc,var-samba-directories-setup and prevent creating directories under both sysconfdir and localstatedir. Maxim Cournoyer 2020-11-03gnu: samba: Update to 4.13.1....* gnu/packages/samba.scm (samba): Update to 4.13.1. [native-inputs]: Add libxml2. [phases]{locate-docbook-stylesheets}: Rename to... {setup-docbook-stylesheets}: ...this. Setup offline Samba DTD catalog, and have it used along any pre-existing XML_CATALOG_FILES environment variable in the build script. Maxim Cournoyer 2020-09-22gnu: samba: Fix fcntl hint detection in configure script....The configure script generates a C program to detect support for lifetime hints on files. But this program could crash, potentially leaving a stale unreadable file behind which could cause the patch-generated-file-shebang phase to fail. Reported upstream <https://bugzilla.samba.org/show_bug.cgi?id=14503>. * gnu/packages/patches/patches/samba-fix-fcntl-hint-detection.patch: New file. * gnu/packages/samba.scm (samba)[origin]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch. Pierre Langlois 2020-09-21gnu: samba: Update to 4.12.7 [security fixes]....Fixes CVE-2020-1472 with 4.12.7. Fixes CVE-2020-10730, CVE-2020-10745, CVE-2020-10760 and CVE-2020-14303 with 4.12.4. * gnu/packages/samba.org (samba): Update to 4.12.7. Pierre Langlois 2020-09-04gnu: cifs-utils: Update to 6.11 [fixes CVE-2020-14342]....* gnu/packages/samba.scm (cifs-utils): Update to 6.11. Tobias Geerinckx-Rice