aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rsync)
  #:use-module (gnu packages)
  #:use-module (gnu packages acl)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages digest)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages popt)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system gnu))

(define-public rsync
  (package
   (name "rsync")
   (version "3.3.0")
   (source (origin
            (method url-fetch)
            (uri (string-append "https://rsync.samba.org/ftp/rsync/src/rsync-"
                                version ".tar.gz"))
            (sha256
             (base32
              "146z85qd16446k8hzr9n4fzf0fzjjsg22qralxwdcclcf2kfk6bk"))))
   (build-system gnu-build-system)
   (arguments
    `(#:configure-flags
      ;; The bundled copies are preferred by default.
      (list "--without-included-zlib"
            "--without-included-popt")))
   (native-inputs
    (list perl))
   (inputs
    (list acl
          lz4
          openssl
          popt
          xxhash
          zlib
          `(,zstd "lib")))
   (synopsis "Remote (and local) file copying tool")
   (description
    "Rsync is a fast and versatile file copying tool.  It can copy locally,
to/from another host over any remote shell, or to/from a remote rsync daemon.
Its delta-transfer algorithm reduces the amount of data sent over the network
by sending only the differences between the source files and the existing
files in the destination.")
   (license license:gpl3+)
   (home-page "https://rsync.samba.org/")))

(define-public librsync
  (package
    (name "librsync")
    (version "2.3.2")
       (source (origin
            (method git-fetch)
            (uri (git-reference
                   (url "https://github.com/librsync/librsync")
                   (commit (string-append "v" version))))
            (file-name (git-file-name name version))
            (sha256
             (base32
              "0bn29npmbw26akc6y54661irpdh6qcivcs6q48cgp3llklhhxp0q"))))
   (build-system cmake-build-system)
   (inputs
    (list popt))
   (native-inputs
    (list which perl))
   (home-page "https://librsync.sourceforge.net/")
   (synopsis "Implementation of the rsync remote-delta algorithm")
   (description
    "Librsync is a free software library that implements the rsync
remote-delta algorithm.  This algorithm allows efficient remote updates of a
file, without requiring the old and new versions to both be present at the
sending end.  The library uses a \"streaming\" design similar to that of zlib
with the aim of allowing it to be embedded into many different applications.")
   (license license:lgpl2.1+)))

(define-public librsync-0.9
  (package
    (inherit librsync)
    (version "0.9.7")
        (source (origin
             (method url-fetch)
            (uri (string-append "mirror://sourceforge/librsync/librsync/"
                                version "/librsync-" version ".tar.gz"))
             (sha256
              (base32
              "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
    (build-system gnu-build-system)
    (arguments '(#:configure-flags '("--enable-shared")))
    (inputs '())))
'/guix/commit/gnu/packages/samba.scm?id=bcf66fc2e75151b248265ed12ec8453fe9b0ce47'>gnu: samba: Update to 4.10.0....Rutger Helling 2019-03-14gnu: samba: Update to 4.9.5....Marius Bakke 2019-03-02gnu: ldb: Update to 1.6.2....Marius Bakke 2019-03-02gnu: tevent: Update to 0.9.39....Marius Bakke 2019-03-02gnu: talloc: Update to 2.1.16....Marius Bakke 2019-01-25gnu: ldb: Use INVOKE....Ricardo Wurmus 2019-01-25gnu: tevent: Use INVOKE....Ricardo Wurmus 2019-01-25gnu: talloc/static: Use INVOKE....Ricardo Wurmus 2018-12-27gnu: samba: Update to 4.9.4....Marius Bakke 2018-12-06gnu: ldb: Fix build on 32-bit systems....Marius Bakke 2018-12-04gnu: samba.scm: Sort module imports....Marius Bakke 2018-12-04gnu: ldb: Update to 1.4.3....Marius Bakke 2018-12-04gnu: samba: Update to 4.9.3....Marius Bakke 2018-11-14Merge branch 'master' into core-updatesMarius Bakke 2018-11-11gnu: cifs-utils: Remove autoreconf phase....Ricardo Wurmus 2018-10-22Merge branch 'master' into core-updatesMarius Bakke 2018-10-22gnu: samba: Update to 4.8.6....Marius Bakke 2018-09-03gnu: ppp: Use OpenSSL for cryptography....Marius Bakke 2018-09-03gnu: ppp: Return #t from all phases....Marius Bakke 2018-08-30gnu: samba: Update to 4.8.5....Marius Bakke 2018-08-30gnu: ldb: Update to 1.3.6....Marius Bakke 2018-08-14gnu: samba: Update to 4.8.4 [fixes CVE-2018-{1139,1130,10858,10918,10919}]....Leo Famulari 2018-07-12gnu: ldb: Downgrade to 1.3.3....Marius Bakke 2018-07-12gnu: tevent: Update to 0.9.37....Marius Bakke 2018-07-12gnu: talloc: Update to 2.1.14....Marius Bakke 2018-06-28gnu: samba: Update to 4.8.3....Marius Bakke 2018-06-27gnu: samba: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-27gnu: cifs-utils: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-16gnu: ldb: Fix build on 32-bit systems....Marius Bakke 2018-06-11gnu: ldb: Delete bundled libraries from the source....Marius Bakke 2018-06-11gnu: ldb: Update to 1.4.0....Marius Bakke 2018-05-27Merge branch 'master' into core-updatesMark H Weaver 2018-05-26gnu: samba: Update to 4.8.2....Marius Bakke