aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rsync)
  #:use-module (gnu packages)
  #:use-module (gnu packages acl)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages digest)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages popt)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system gnu))

(define-public rsync
  (package
   (name "rsync")
   (version "3.3.0")
   (source (origin
            (method url-fetch)
            (uri (string-append "https://rsync.samba.org/ftp/rsync/src/rsync-"
                                version ".tar.gz"))
            (sha256
             (base32
              "146z85qd16446k8hzr9n4fzf0fzjjsg22qralxwdcclcf2kfk6bk"))))
   (build-system gnu-build-system)
   (arguments
    `(#:configure-flags
      ;; The bundled copies are preferred by default.
      (list "--without-included-zlib"
            "--without-included-popt")))
   (native-inputs
    (list perl))
   (inputs
    (list acl
          lz4
          openssl
          popt
          xxhash
          zlib
          `(,zstd "lib")))
   (synopsis "Remote (and local) file copying tool")
   (description
    "Rsync is a fast and versatile file copying tool.  It can copy locally,
to/from another host over any remote shell, or to/from a remote rsync daemon.
Its delta-transfer algorithm reduces the amount of data sent over the network
by sending only the differences between the source files and the existing
files in the destination.")
   (license license:gpl3+)
   (home-page "https://rsync.samba.org/")))

(define-public librsync
  (package
    (name "librsync")
    (version "2.3.2")
       (source (origin
            (method git-fetch)
            (uri (git-reference
                   (url "https://github.com/librsync/librsync")
                   (commit (string-append "v" version))))
            (file-name (git-file-name name version))
            (sha256
             (base32
              "0bn29npmbw26akc6y54661irpdh6qcivcs6q48cgp3llklhhxp0q"))))
   (build-system cmake-build-system)
   (inputs
    (list popt))
   (native-inputs
    (list which perl))
   (home-page "https://librsync.sourceforge.net/")
   (synopsis "Implementation of the rsync remote-delta algorithm")
   (description
    "Librsync is a free software library that implements the rsync
remote-delta algorithm.  This algorithm allows efficient remote updates of a
file, without requiring the old and new versions to both be present at the
sending end.  The library uses a \"streaming\" design similar to that of zlib
with the aim of allowing it to be embedded into many different applications.")
   (license license:lgpl2.1+)))

(define-public librsync-0.9
  (package
    (inherit librsync)
    (version "0.9.7")
        (source (origin
             (method url-fetch)
            (uri (string-append "mirror://sourceforge/librsync/librsync/"
                                version "/librsync-" version ".tar.gz"))
             (sha256
              (base32
              "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
    (build-system gnu-build-system)
    (arguments '(#:configure-flags '("--enable-shared")))
    (inputs '())))
...* gnu/packages/vim.scm (xxd)[inputs]: New field, don't inherit from vim. Efraim Flashner 2018-06-02gnu: vim: Update to 8.1.0026....* gnu/packages/vim.scm (vim): Update to 8.1.0026. [arguments]: Update substitute list on custom 'patch-config-files phase. [inputs]: Remove inetutils. Efraim Flashner 2018-06-02gnu: xxd: Return true from all phases....* gnu/packages/vim.scm (xxd)[arguments]: Return '#t' from custom 'chdir phase. Efraim Flashner 2018-03-20Correct name and Email for ng0....* .mailmap: Correct name and Email for ng0. * Makefile.am, doc/guix.texi, etc/completion/fish/guix.fish gnu/packages/accessibility.scm, gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/autotools.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/cinnamon.scm, gnu/packages/compression.scm, gnu/packages/crypto.scm, gnu/packages/databases.scm, gnu/packages/django.scm, gnu/packages/dns.scm, gnu/packages/emacs.scm, gnu/packages/enlightenment.scm, gnu/packages/fonts.scm, gnu/packages/fontutils.scm, gnu/packages/forth.scm, gnu/packages/fvwm.scm, gnu/packages/games.scm, gnu/packages/gl.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/gtk.scm, gnu/packages/guile-wm.scm, gnu/packages/guile.scm, gnu/packages/haskell-check.scm, gnu/packages/haskell-crypto.scm, gnu/packages/haskell.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/irc.scm, gnu/packages/language.scm, gnu/packages/libcanberra.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lolcode.scm, gnu/packages/lxde.scm, gnu/packages/lxqt.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/mate.scm, gnu/packages/maths.scm, gnu/packages/mc.scm, gnu/packages/messaging.scm, gnu/packages/music.scm, gnu/packages/ncurses.scm, gnu/packages/networking.scm, gnu/packages/nickle.scm, gnu/packages/openbox.scm, gnu/packages/pdf.scm, gnu/packages/perl-check.scm, gnu/packages/perl.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/ssh.scm, gnu/packages/suckless.scm, gnu/packages/tbb.scm, gnu/packages/telephony.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/web.scm, gnu/packages/wm.scm, gnu/packages/xdisorg.scm, gnu/packages/xfce.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/services/certbot.scm, gnu/services/desktop.scm, gnu/services/version-control.scm, gnu/services/web.scm, guix/import/hackage.scm, guix/licenses.scm: Likewise. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> ng0 2018-02-11gnu: vifm: Update to 0.9.1....* gnu/packages/vim.scm (vifm): Update to 0.9.1. Efraim Flashner 2018-01-24gnu: vifm: Update inputs....* gnu/packages/vim.scm (vifm)[native-inputs]: Move perl ... [inputs]: ... to here. [home-page]: Use https. Efraim Flashner 2018-01-18gnu: vim: Update to 8.0.1428....* gnu/packages/vim.scm (vim): Update to 8.0.1428. [arguments]: Add ‘patch-failing-test’ phase. Tobias Geerinckx-Rice 2017-11-27gnu: Add vim-fugitive....* gnu/packages/vim.scm (vim-fugitive): New variable. Efraim Flashner 2017-11-19Update email address for ng0.ng0 2017-11-17gnu: vim: Update to 8.0.1300....* gnu/packages/vim.scm (vim): Update to 8.0.1300. Leo Famulari 2017-11-07gnu: vim: Update to 8.0.1274 [fixes CVE-2017-1000382]....* gnu/packages/vim.scm (vim): Update to 8.0.1274. Marius Bakke 2017-10-22gnu: vim: Update to 8.0.1207....* gnu/packages/vim.scm (vim): Update to 8.0.1207. Marius Bakke 2017-09-22gnu: Add xxd....* gnu/packages/vim.scm (xxd): New variable. Ricardo Wurmus 2017-09-21gnu: vim: Update to 8.0.1130....* gnu/packages/vim.scm (vim): Update to 8.0.1130. Marius Bakke 2017-08-20gnu: vifm: Update to 0.9....* gnu/packages/vim.scm (vifm): Update to 0.9. [source]: Add alternate uri. [arguments]: Remove build timestamp. Add phase to install vim plugins into vim plugin directory. Patch more shebangs. Efraim Flashner 2017-07-29gnu: vim: Update to 8.0.0808....* gnu/packages/vim.scm (vim): Update to 8.0.0808. [arguments]: Remove obsolete 'make-bit-reproducable' phase. (vim-full): Update to 8.0.0808. [arguments]: Remove 'drop-failing-tests' phase. Marius Bakke 2017-07-21gnu: vim: Update to 8.0.0727 [fixes CVE-2017-11109]....* gnu/packages/vim.scm (vim): Update to 8.0.0727. (vim-full)[source]: Add field and hold back at version 8.0.0600. Leo Famulari 2017-05-21gnu: vim: Update to 8.0.0600....* gnu/packages/vim.scm (vim, vim-full): Update to 8.0.0600. Marius Bakke 2017-05-21gnu: vim-full: Disable failing test....* gnu/packages/vim.scm (vim-full)[arguments]<#:phases>: Add substitution. Marius Bakke 2017-05-10gnu: Add neovim-syntastic....* gnu/packages/vim.scm (neovim-syntastic): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> ng0 2017-05-10gnu: Add vim-syntastic....* gnu/packages/vim.scm (vim-syntastic): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> ng0 2017-05-04gnu: neovim: Update to 0.2.0....* gnu/packages/vim.scm (neovim): Update to 0.2.0. Ricardo Wurmus 2017-04-15gnu: vim: Update to 8.0.0566....* gnu/packages/vim.scm (vim): Update to 8.0.0566. Signed-off-by: Kei Kebreau <kei@openmailbox.org> ng0 2017-03-20gnu: vim: Update to 8.0.0494....* gnu/packages/patches/vim-CVE-2017-5953.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/vim.scm (vim, vim-full): Update to 8.0.0494. [source]: Remove patch. (vim-full)[arguments]: Add two phases to drop tests and start xorg. [native-inputs]: Add XORG-SERVER. Marius Bakke