aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rrdtool)
  #:use-module (guix git-download)
  #:use-module (gnu packages)
  #:use-module (gnu packages algebra)
  #:use-module (gnu packages base)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages xml)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages))

(define-public rrdtool
  (package
    (name "rrdtool")
    (version "1.8.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/oetiker/rrdtool-1.x")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "04dhygsp34dykrnbbcqni5f7hih0hzqbnj6d2sl439lqbx9k3q3b"))))
    (build-system gnu-build-system)
    (inputs
     (list cairo
           freetype
           glib
           libxml2
           pango
           python))
    (native-inputs
     (list groff
           pkg-config
           ;; For tests.
           bc
           perl                         ; will also build Perl bindings
           tzdata-for-tests))
    (arguments
     (list
      #:disallowed-references (list (gexp-input tzdata-for-tests))
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'check 'prepare-test-environment
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "TZDIR"
                      (search-input-directory inputs "share/zoneinfo"))))
          (add-after 'install 'remove-native-input-references
            (lambda _
              (let ((examples (string-append #$output
                                             "/share/rrdtool/examples")))
                ;; Drop shebangs from examples to avoid depending on native-input
                ;; perl.  It's clear from context and extension how to run them.
                (substitute* (find-files examples "\\.pl$")
                  (("^#!.*") ""))))))))
    (home-page "https://oss.oetiker.ch/rrdtool/")
    (synopsis "Time-series data storage and display system")
    (description
     "The Round Robin Database Tool (RRDtool) is a system to store and display
time-series data (e.g. network bandwidth, machine-room temperature, server
load average).  It stores the data in Round Robin Databases (RRDs), a very
compact way that will not expand over time.  RRDtool processes the extracted
data to enforce a certain data density, allowing for useful graphical
representation of data values.")
    (license license:gpl2+))) ; with license exception that allows combining
                              ; with many other licenses.
rvices/version-control.scm, gnu/services/web.scm, guix/import/hackage.scm, guix/licenses.scm: Likewise. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> nikita 2020-02-03Merge branch 'staging' into core-updatesMarius Bakke 2020-02-03gnu: python-lz4: Remove bundled copy of lz4....* gnu/packages/python-compression.scm (python-lz4)[source](modules, snippet): New fields. [native-inputs]: Add PKG-CONFIG. [inputs]: Add LZ4. Marius Bakke 2020-01-24gnu: python2-pytest: Update to 4.6.9....* gnu/packages/check.scm (python2-pytest): Update to 4.6.9. (python2-pytest-bootstrap)[propagated-inputs]: Add PYTHON2-IMPORTLIB-METADATA-BOOTSTRAP, PYTHON2-PACKAGING-BOOTSTRAP, and PYTHON2-WCWIDTH. Replace PYTHON2-PLUGGY with PYTHON2-PLUGGY-BOOTSTRAP. * gnu/packages/python-compression.scm (python2-zipp-bootstrap): New public variable. * gnu/packages/python-xyz.scm (python2-importlib-resources-bootstrap): New public variable. (python-importlib-metadata)[native-inputs]: Change from PYTHON-PACKAGING to PYTHON-PACKAGING-BOOTSTRAP. [properties]: New field. (python2-importlib-metadata-bootstrap, python2-contextlib2-bootstrap, python2-pluggy-bootstrap): New public variables. (python-packaging)[arguments]: Allow overriding #:tests?. (python2-packaging-bootstrap): New public variable. Marius Bakke 2020-01-16gnu: python-zipp: Remove redundant inputs....The Python 3 variant do not need these. * gnu/packages/python-compression.scm (python-zipp)[native-inputs]: Remove PYTHON-CONTEXTLIB2, PYTHON-PATHLIB2, and PYTHON-UNITTEST2. [properties]: New field. (python2-zipp)[native-inputs]: Add PYTHON2-CONTEXTLIB2, PYTHON2-PATHLIB2, and PYTHON2-UNITTEST2. Marius Bakke 2020-01-15gnu: Add python2-zipp....* gnu/packages/python-compression.scm (python2-zipp): New public variable. Marius Bakke 2020-01-15gnu: python-zipp: Update to 1.0.0....* gnu/packages/python-compression.scm (python-zipp): Update to 1.0.0. [propagated-inputs]: Remove PYTHON-RST.LINKER. Add PYTHON-MORE-ITERTOOLS. Move PYTHON-CONTEXTLIB2 and PYTHON-PATHLIB2 ... [native-inputs]: ... here. Remove PYTHON-SPHINX. Marius Bakke 2020-01-03gnu: python-zstandard: Fix indentation....* gnu/packages/python-compression.scm (python-zstandard): Fix indentation. Nicolas Goaziou 2020-01-03gnu: Add missing copyright header.Nicolas Goaziou 2020-01-03gnu: Add python-zstandard....* gnu/packages/python-compression.scm (python-zstandard): New variable. Nicolas Goaziou