aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rrdtool)
  #:use-module (guix git-download)
  #:use-module (gnu packages)
  #:use-module (gnu packages algebra)
  #:use-module (gnu packages base)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages xml)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages))

(define-public rrdtool
  (package
    (name "rrdtool")
    (version "1.8.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/oetiker/rrdtool-1.x")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "04dhygsp34dykrnbbcqni5f7hih0hzqbnj6d2sl439lqbx9k3q3b"))))
    (build-system gnu-build-system)
    (inputs
     (list cairo
           freetype
           glib
           libxml2
           pango
           python))
    (native-inputs
     (list groff
           pkg-config
           ;; For tests.
           bc
           perl                         ; will also build Perl bindings
           tzdata-for-tests))
    (arguments
     (list
      #:disallowed-references (list (gexp-input tzdata-for-tests))
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'check 'prepare-test-environment
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "TZDIR"
                      (search-input-directory inputs "share/zoneinfo"))))
          (add-after 'install 'remove-native-input-references
            (lambda _
              (let ((examples (string-append #$output
                                             "/share/rrdtool/examples")))
                ;; Drop shebangs from examples to avoid depending on native-input
                ;; perl.  It's clear from context and extension how to run them.
                (substitute* (find-files examples "\\.pl$")
                  (("^#!.*") ""))))))))
    (home-page "https://oss.oetiker.ch/rrdtool/")
    (synopsis "Time-series data storage and display system")
    (description
     "The Round Robin Database Tool (RRDtool) is a system to store and display
time-series data (e.g. network bandwidth, machine-room temperature, server
load average).  It stores the data in Round Robin Databases (RRDs), a very
compact way that will not expand over time.  RRDtool processes the extracted
data to enforce a certain data density, allowing for useful graphical
representation of data values.")
    (license license:gpl2+))) ; with license exception that allows combining
                              ; with many other licenses.
a href='/guix/commit/gnu/packages/fonts.scm?id=405220916ae8ab4ec8f34adee9b9e09407071fe6'>gnu: font-jetbrains-mono: Update to 2.221....Tobias Geerinckx-Rice 2021-01-02gnu: font-liberation: Update to 2.1.2....Tobias Geerinckx-Rice 2021-01-02gnu: font-gnu-unifont: Update to 13.0.05....Tobias Geerinckx-Rice 2020-12-17Revert "gnu: font-google-roboto: Update to 2.138."...Leo Famulari 2020-12-17gnu: font-fira-code: Update to 5.2....Nicolas Goaziou 2020-12-17gnu: font-google-roboto: Update to 2.138....Nicolas Goaziou 2020-12-17gnu: Add font-iosevka-curly....Nicolas Goaziou 2020-12-17gnu: Add font-iosevka-curly-slab....Nicolas Goaziou 2020-12-17gnu: Iosevka fonts: Update to 4.0.3....Nicolas Goaziou 2020-11-25gnu: font-gnu-unifont: Always download source over HTTPS....Tobias Geerinckx-Rice 2020-11-25gnu: font-gnu-unifont: Update to 13.0.04....Tobias Geerinckx-Rice 2020-11-15gnu: font-jetbrains-mono: Update to 2.210....Tobias Geerinckx-Rice 2020-11-05gnu: Add font-juliamono....nixo 2020-10-31gnu: Add font-openmoji...nixo 2020-10-04gnu: font-jetbrains-mono: Simplify licence installation....Tobias Geerinckx-Rice 2020-10-04gnu: font-jetbrains-mono: Update to 2.002....Tobias Geerinckx-Rice 2020-10-04gnu: font-comic-neue: Update to 2.51....Tobias Geerinckx-Rice 2020-09-25gnu: font-adobe-source-serif-pro: Update to 3.001R....Jens Mølgaard 2020-09-25gnu: font-adobe-source-sans-pro: Update to 3.028R....Jens Mølgaard 2020-09-06gnu: Update Iosevka fonts from 3.2.2 to 3.4.7...simendsjo 2020-08-19gnu: font-fantasque-sans: Fix build....Danny Milosavljevic 2020-07-23gnu: Add font-catamaran....Arun Isaac 2020-07-21gnu: font-jetbrains-mono: Update to 2.001....Michael Rohleder 2020-07-14gnu: font-gnu-freefont: Update to 13.0.03....Efraim Flashner 2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès 2020-07-09gnu: Add font-libertinus....Tim Van den Langenbergh 2020-07-02gnu: Update Iosevka fonts from 3.1.1 to 3.2.2....simendsjo 2020-06-21gnu: Add font-mplus-testflight....Julien Lepiller 2020-06-21gnu: Add font-fontna-yasashisa-antique....Julien Lepiller 2020-06-18gnu: Add Iosevka quasi-proportioal fonts....Simen Endsjø 2020-06-18gnu: Update Iosevka fonts from 2.3.3 to 3.1.1....Simen Endsjø 2020-06-17gnu: font-sarasa-gothic: Update to 0.12.7...Zhu Zihao