aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages regex)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils))

(define-public re2
   (package
     (name "re2")
     (version "2022-12-01")
     (home-page "https://github.com/google/re2")
     (source (origin
               (method git-fetch)
               (uri (git-reference (url home-page) (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
                 "0g627a5ppyarhf2ph4gyzj89pwbkwfjfajgljzkmjafjmdyxfqs6"))))
     (build-system gnu-build-system)
     (arguments
      (list #:test-target "test"
            ;; There is no configure step, but the Makefile respects a prefix.
            #:make-flags #~(list (string-append "prefix=" #$output)
                                 (string-append "CXX=" #$(cxx-for-target)))
            #:phases
            #~(modify-phases %standard-phases
                (delete 'configure)
                (add-after 'install 'delete-static-library
                  (lambda _
                    ;; No make target for shared-only; delete the static version.
                    (delete-file (string-append #$output "/lib/libre2.a")))))))
     (synopsis "Fast, safe, thread-friendly regular expression engine")
     (description "RE2 is a fast, safe, thread-friendly alternative to
backtracking regular expression engines like those used in PCRE, Perl and
Python.  It is a C++ library.")
     (license license:bsd-3)))

(define-public tre
  (package
    (name "tre")
    (version "0.8.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://laurikari.net/tre/"
                                  name "-" version ".tar.bz2"))
              (sha256
               (base32
                "0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-before 'check 'install-locales
           (lambda _
             ;; The tests require the availability of the
             ;; 'en_US.ISO-8859-1' locale.
             (setenv "LOCPATH" (getcwd))
             (invoke "localedef" "--no-archive"
                     "--prefix" (getcwd) "-i" "en_US"
                     "-f" "ISO-8859-1" "./en_US.ISO-8859-1"))))))
    (synopsis "Approximate regex matching library and agrep utility")
    (description "Superset of the POSIX regex API, enabling approximate
matching.  Also ships a version of the agrep utility which behaves similar to
grep but features inexact matching.")
    (home-page "https://laurikari.net/tre")
    (license license:bsd-2)))
ibuting.texi?id=bb9a99e6571c492d30f95c5b51ead6861d1dc098'>doc: Adjust branching and rebuilding strategy to match reality....Marius Bakke 2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner 2020-05-25doc: Fix typos....zimoun 2020-05-22maint: Add "make check-channel-news"....Ludovic Courtès 2020-05-12doc: Specify the branch name in the title of a patch....Brice Waegeneire 2020-05-04doc: Recommend against SHA1 OpenPGP signatures....Ludovic Courtès 2020-05-04doc: Document committer authorization....Ludovic Courtès 2020-03-13doc: Update guidance about Python 2 package variants....Leo Famulari 2020-03-10doc: Use HTTPS for external links....Vitaliy Shatrov 2020-03-09doc: Use an https link for Contributor Covenant....Jakub Kądziołka 2020-02-22etc: Add copyright....Oleg Pykhalov 2020-02-18doc: Document packaging guidelines for Rust crates....Efraim Flashner 2020-01-19Use HTTPS for www.emacswiki.org....Tobias Geerinckx-Rice 2020-01-09doc: Add a cooptation policy for commit access....Ludovic Courtès 2020-01-09doc: Encourage patch review....Ludovic Courtès 2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual....Ludovic Courtès 2020-01-09doc: Add "Tracking Bugs and Patches" section....Ludovic Courtès 2019-12-27doc: Mention "make authenticate"....Ludovic Courtès 2019-12-13doc: Link to "Building from Git" instead of quoting command to build Guix....Pierre Neidhardt 2019-12-08doc: Mention how to simulate a `guix pull' before submitting patches....Pierre Neidhardt 2019-12-08doc: Mention how to rebuild guix before submitting patches....Pierre Neidhardt 2019-11-09doc: Mention value /var to localstatedir option....zimoun 2019-09-07doc: Use @lisp instead of @example for Scheme snippets....Ludovic Courtès 2019-07-17doc: Reorder and clarify contributing instructions....Florian Pelz 2019-07-15doc: note how to install git send-email...Arne Babenhauserheide 2019-06-29doc: Remove references to hydra.gnu.org....Tobias Geerinckx-Rice 2019-05-20doc: use pure environment when building from git...Giovanni Biscuolo 2019-03-24doc: Remove instances of powerpc-linux being a supported Guix architecture....Efraim Flashner 2019-02-04doc: Document how to enable qemu binfmt service and how to use it....Danny Milosavljevic 2019-02-04doc: Show how to install Emacs, Guile, and Geiser....Ludovic Courtès 2019-01-22doc: Move "Packaging Guidelines" under "Contributing"....Ludovic Courtès 2018-12-15doc: Replace @command by @code for packages...Pierre Neidhardt 2018-12-15doc: Merge "discourage use of texlive" with existing paragraph on "guix size"...Pierre Neidhardt 2018-12-14doc: Discourage the use of texlive as input...Pierre Neidhardt 2018-12-04Remove most references to hydra.gnu.org....Ludovic Courtès 2018-11-16doc: Mention that ./pre-inst-env is generated....Ludovic Courtès 2018-10-10doc: Add recommendations for good origin URLs....Pierre Neidhardt