aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rednotebook)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system python)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages python)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages webkit)
  #:use-module (gnu packages python-xyz))

(define-public rednotebook
  (package
    (name "rednotebook")
    (version "2.22")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/jendrikseipp/rednotebook")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "11n970ad0j57vlll5j30ngkrfyil23v1b29ickbnblcldvjbgwa5"))))
    (build-system python-build-system)
    (arguments
     ;; Tests fail to find the "_" function.
     ;; It should be defined in rednotebook/info.py if '_' is not a member of
     ;; 'builtins'. It is either not defined or not exported during the check
     ;; phase. The program does not have this problem after it is installed.
     ;; TODO: Fix tests.
     `(#:tests? #f
       #:imported-modules ((guix build glib-or-gtk-build-system)
                           ,@%python-build-system-modules)
       #:modules ((ice-9 match)
                  (guix build python-build-system)
                  ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
                  (guix build utils))
       #:phases
       (modify-phases %standard-phases
         ;; Make sure rednotebook can find the typelibs and webkitgtk shared
         ;; libraries.
         (add-before 'wrap 'wrap-with-library-paths
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out"))
                   (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
                   (webkitgtk-path (string-append
                                    (assoc-ref inputs "webkitgtk-for-gtk3")
                                    "/lib")))
               (wrap-program (string-append out "/bin/rednotebook")
                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
                 `("LD_LIBRARY_PATH" ":" prefix (,webkitgtk-path)))))))))
    (inputs
     (list bash-minimal
           gtk+
           gtksourceview-3
           python-pyyaml
           python-pygobject
           webkitgtk-for-gtk3))
    ;; TODO: package the following for python3 (if possible), add them as
    ;; dependencies, and remove them from rednotebook source:
    ;; pygtkspellcheck, elib.intl, msgfmt, txt2tags
    ;; TODO: package and add pyenchant for python3 and add it as a dependency.
    (home-page "https://www.rednotebook.app")
    (synopsis "Daily journal with calendar, templates and keyword searching")
    (description
     "RedNotebook is a modern desktop journal.  It lets you format, tag and
search your entries.  You can also add pictures, links and customizable
templates, spell check your notes, and export to plain text, HTML, Latex or
PDF.")
    (license (list license:gpl2+     ; rednotebook, txt2tags
                   license:lgpl3+    ; elib.intl
                   license:gpl3+)))) ; pygtkspellcheck
ass='msg-avail'>...* gnu/packages/llvm.scm (libcxx)[arguments]: New field. Marius Bakke 2020-03-15gnu: clang: Switch to 'C_INCLUDE_PATH' & co....* gnu/packages/llvm.scm (clang-from-llvm)[native-search-paths]: Remove "CPATH", and add "C_INCLUDE_PATH" and "CPLUS_INCLUDE_PATH". Marius Bakke 2020-03-05gnu: clang-runtime: Fix build with glibc 2.31....* gnu/packages/patches/clang-runtime-3.8-libsanitizer-mode-field.patch, gnu/packages/patches/clang-runtime-3.9-libsanitizer-mode-field.patch, gnu/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (clang-runtime, clang-runtime-8, clang-runtime-7, clang-runtime-6, clang-runtime-3.9.1, clang-runtime-3.8, clang-runtime-3.7): Add the respective patches. Marius Bakke 2020-03-05gnu: clang-runtime: Adjust for CPLUS_INCLUDE_PATH changes....* gnu/packages/llvm.scm (clang-runtime-from-llvm)[arguments]: Add #:modules and #:phases. Marius Bakke 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-26gnu: clang: Move version conditionals out of the builder....* gnu/packages/llvm.scm (clang-from-llvm)[arguments]: Rewrite phase 'set-glibc-file-names' to use VERSION>=? from (guix utils) and splice in the relevant build code, instead of doing the comparison at build time. Marius Bakke 2020-02-26gnu: clang: Fix C++ search path handling on non-x86_64....* gnu/packages/llvm.scm (clang-from-llvm)[arguments]: Add phase 'add-missing-triplets'. Marius Bakke 2020-02-25gnu: clang-runtime-3.5: Fix build....* gnu/packages/llvm.scm (clang-runtime-3.5) [inputs]: Add libtirpc. [arguments]: Add phase to find rpc headers. Ricardo Wurmus 2020-02-24gnu: LLVM: Promote LLVM 9 to the default 'llvm' package....* gnu/packages/llvm.scm (llvm-8): Rename to ... (llvm): ... this. Update to 9.0.1. [license]: Change to ASL2.0. (clang-runtime-from-llvm)[license]: Inherit from LLVM. (clang-from-llvm)[license]: Conditionally choose license based on version. (llvm-9, clang-runtime-8, clang-8, clang-toolchain-8): New public variables. (llvm-7): Inherit from LLVM-8 (for the license change). (llvm-6): Inherit from LLVM-7. (llvm-3.9.1): Inherit from LLVM-6. (llvm-3.8): Inherit from LLVM-3.9.1. (llvm-3.7): Inherit from LLVM-3.8. (llvm-3.6): Inherit from LLVM-3.7. (llvm-3.5): Inherit from LLVM-3.6. (libcxx, libclc, libomp): Update to 9.0.1. Marius Bakke 2020-02-24gnu: clang: Use the correct CLANG-RUNTIME for versions 6 and 7....* gnu/packages/llvm.scm (clang-7): Use CLANG-RUNTIME-7. (clang-6): Use CLANG-RUNTIME-6. Marius Bakke 2020-02-24gnu: Reorganize llvm.scm....* gnu/packages/llvm.scm (libcxx, libclc, libomp, libcxx-6): Move package definitions below the various LLVM/Clang variants. Marius Bakke 2020-02-24gnu: clang@9: Update to 9.0.1....* gnu/packages/llvm.scm (llvm-9): Update to 9.0.1. clang-runtime-9, clang-9): Update hashes. Marius Bakke 2020-02-24gnu: llvm: Add helper procedure for constructing download URLs.......in preparation for LLVM 9.0.1 which is no longer hosted on llvm.org. * gnu/packages/llvm.scm (llvm-download-uri): New procedure. (llvm-8, clang-runtime-from-llvm, clang-from-llvm, libcxx, libomp, llvm-9, llvm-7, llvm-6, libcxx-6, llvm-3.9.1, llvm-3.8, llvm-3.7, llvm-3.6, llvm-3.5)[source](uri): Use it. Marius Bakke 2020-02-24gnu: clang@9: Fix search path handling....* gnu/packages/patches/clang-9.0-libc-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (clang-9): Add #:patches. Marius Bakke 2020-02-03gnu: llvm@3: Do not inherit 'install-opt-viewer' phase....This is a follow-up to commit 50b61ec22306181c419a3bd4c35b3c001c604994. * gnu/packages/llvm.scm (llvm-3.9.1)[outputs, arguments]: New fields. (llvm-3.8, llvm-3.7, llvm-3.6, llvm-3.5): Inherit from LLVM-3.9.1. Marius Bakke 2019-12-31Merge remote-tracking branch 'master' into core-updates.Mathieu Othacehe 2019-12-23gnu: python-llvmlite: Update to 0.30.0....* gnu/packages/llvm.scm (python-llvmlite): Update to 0.30.0. [arguments]: Disable tests until dynamic loading of libm.so is fixed. Brett Gilio 2019-12-14gnu: llvm: split scripts to a separate output....This reduces the closure size by almost 80 MiB. * gnu/packages/llvm.scm (llvm-8): Add "opt-viewer" output. Julien Lepiller