aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
guix/commit/gnu/packages/disk.scm?id=73fe4552aa4958d4ea0d9ea0ef0326e112b22a92'>gnu: gptfdisk: Update description....Tobias Geerinckx-Rice 2017-07-25gnu: fdisk: Update to 2.0.0a1....Tobias Geerinckx-Rice 2017-07-25gnu: sdparm: Update to 1.10....Tobias Geerinckx-Rice 2017-05-09gnu: Add f3....Hartmut Goebel 2017-02-24gnu: gparted: Update to 0.28.1....Tobias Geerinckx-Rice 2017-02-15gnu: gptfdisk: Install the documentation....Leo Famulari 2017-02-15gnu: gparted: Update to 0.28.0....Tobias Geerinckx-Rice 2017-02-06gnu: dosfstools: Update to 4.1....Marius Bakke 2017-02-06gnu: ddrescue: Update to 1.22....Marius Bakke 2016-12-17gnu: Add fatfsck-static....Marius Bakke 2016-10-23Merge branch 'master' into core-updatesMark H Weaver 2016-10-19gnu: gparted: Update to 0.27.0....Tobias Geerinckx-Rice 2016-09-30Merge branch 'master' into core-updatesLudovic Courtès 2016-09-28gnu: Add and use gettext-minimal....Alex Kost 2016-09-16doc: "filesystem" -> "file system"...John Darrington 2016-08-21gnu: Add gparted....Roel Janssen 2016-08-21gnu: disk: Use license: prefix....Roel Janssen 2016-07-15Update e-mail address for Tobias Geerinckx-Rice....Andreas Enge 2016-07-13gnu: Add gptfdisk....Jan Nieuwenhuizen 2016-05-31gnu: dosfstools: Update to 4.0....Efraim Flashner