aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
cm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-03-22gnu: OpenSSH: Update to 9.3p1 [security fixes]....The release announcement contains more information about the security vulnerabilities fixed in this update: https://www.openssh.com/txt/release-9.3 * gnu/packages/ssh.scm (openssh): Update to 9.3p1. Leo Famulari 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-27gnu: libssh: Fix compilation on GNU/Hurd....* gnu/packages/ssh.scm (libssh)[source]: Add snippet. Ludovic Courtès 2023-02-26gnu: libssh: Update to 0.10.4....* gnu/packages/ssh.scm (libssh): Update to 0.10.4. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vagrant Cascadian 2023-02-23gnu: Add x11-ssh-askpass....* gnu/packages/ssh.scm (x11-ssh-askpass): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Simon Streit 2023-02-20gnu: sshpass: Update to 1.10....* gnu/packages/ssh.scm (sshpass): Update to 1.10. Nicolas Goaziou 2023-02-04gnu: openssh: Update to 9.2p1 [security fixes]....Here is more information about the security issues fixed in this release: https://www.openssh.com/txt/release-9.2 * gnu/packages/ssh.scm (openssh): Update to 9.2p1. Signed-off-by: Leo Famulari <leo@famulari.name> Jack Hill 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2023-01-30gnu: guile-ssh: Update to 0.16.3....Fixes <https://issues.guix.gnu.org/58290>. Reported by Aleksandr Vityazev <avityazev@posteo.org>, and Andrew Tropin <andrew@trop.in>. * gnu/packages/ssh.scm (guile-ssh): Update to 0.16.3. Ludovic Courtès 2023-01-08gnu: guile-ssh: Update to 0.16.2....* gnu/packages/ssh.scm (guile-ssh): Update to 0.16.2. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Artyom V. Poptsov 2022-12-21gnu: guile-ssh: Update to 0.16.0....* gnu/packages/ssh.scm (guile-ssh): Update to 0.16.0. Vagrant Cascadian 2022-11-17gnu: mosh: Update to 1.4.0....* gnu/packages/ssh.scm (mosh): Update to 1.4.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hilton Chain 2022-11-13gnu: dropbear: Update to 2022.83....* gnu/packages/ssh.scm (dropbear): Update to 2022.83. [arguments]: Remove obsolete part of 'enable-x11-forwarding phase. Tobias Geerinckx-Rice 2022-10-24gnu: Various typo fixes....* gnu/packages/emacs-xyz.scm (emacs-popup-kill-ring)[description]: Fix very sneaky "This packages" variant. Thanks to nckhexen! * gnu/packages/bioinformatics.scm (r-icellnet)[description]: Fix use of "allows to". * gnu/packages/check.scm (python-pytest-freezegun)[description]: Ditto. * gnu/packages/linux.scm (tp-smapi-module)[description]: Ditto. * gnu/packages/mail.scm (procmail): Ditto. * gnu/packages/maths.scm (maxima): Ditto. * gnu/packages/samba.scm (wsdd)[description]: Ditto. * gnu/packages/ssh.scm (openssh): Ditto. Vagrant Cascadian 2022-10-16gnu: openssh: Update to 9.1p1....* gnu/packages/ssh.scm (openssh): Update to 9.1p1. Tobias Geerinckx-Rice 2022-06-26gnu: libssh2: Omit static library....* gnu/packages/ssh.scm (libssh2)[arguments]: Add "--disable-static" in #:configure-flags. Marius Bakke 2022-06-26gnu: libssh2: Update to 1.10.0....* gnu/packages/ssh.scm (libssh2): Update to 1.10.0. [source](patches): Remove. * gnu/packages/patches/libssh2-CVE-2019-17498.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Marius Bakke 2022-06-16gnu: dropbear: Build with X11 forwarding support....* gnu/packages/ssh.scm (dropbear)[phases] {enable-x11-forwarding}: New phase. Maxim Cournoyer 2022-06-16gnu: dropbear: Update to 2022.82....* gnu/packages/ssh.scm (dropbear): Update to 2022.82. [source]: Delete origin snippet's trailing #t. [arguments]: Use gexps. [tests?]: Update comment. Maxim Cournoyer 2022-06-13gnu: python-asyncssh: Update to 2.11.0....* gnu/packages/ssh.scm (python-asyncssh)[version]: Update to 2.11.0. [propagated-inputs]: Add python-typing-extensions. [native-inputs]: Add python-fido2, python-aiofiles, netcat and python-pytest. [arguments]: Disable netcat autodetection. Replace 'check with call to pytest. Lars-Dominik Braun 2022-05-22gnu: hss: Use G-expressions....* gnu/packages/ssh.scm (hss)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2022-05-22gnu: hss: Update to 1.9....* gnu/packages/ssh.scm (hss): Update to 1.9. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice