aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
0 +0100'>2024-07-25gnu: scc: Update to 3.3.5....* gnu/packages/code.scm (scc): Update to 3.3.5. Change-Id: I17536f3de68bd124c07f1e1908607d248db75492 Sharlatan Hellseher 2024-07-03gnu: global: Update to 6.6.13....* gnu/packages/code.scm (global): Update to 6.6.13. Change-Id: I4a00f0853b9ad9dcd216f4a7e33a23df3c1caa13 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Andy Tai 2024-06-24gnu: astyle: Update to 3.5....* gnu/packages/code.scm (astyle): Update to 3.5. [source]: Change source archive file name to match the upstream. [arguments]: Remove "modules". Add "patch-makefile" phase to set the C++ compiler to version c++17 as it is required for the build. Simplify "install-more" file. Change-Id: I8777710d723d22320c288c331645f8d61d5e640e Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Artyom V. Poptsov 2024-04-07gnu: Remove withershins....This was only ever needed for powertabeditor. * gnu/packages/code.scm (withershins): Remove variable. Change-Id: I1c286073d1415cd2261ad58017855fedb7701b05 Ricardo Wurmus 2024-04-07gnu: automatic-component-toolkit: Swap to go-build-system....* gnu/packages/code.scm (automatic-component-toolkit): [build-system]: Swap to go-build-system to make the package more maintainable and build predictable. [arguments] <#:phases>: Swap to default 'build and 'install phases, revert 'configure phase. Add 'pretend-cmd-act phase to satisfy go-build-system. [native-inputs]: Remove go. Change-Id: Iba7bd4c87bdbbb91381f81a77c7811cb9f1f4943 Sharlatan Hellseher 2024-04-06gnu: packages: code: Add golang module back....Fix CI as seen in <https://ci.guix.gnu.org/eval/1229755>. * gnu/packages/code.scm: Add golang module back, required for automatic-component-toolkit. Change-Id: I5e099f769e7edf5735e2119e65fd37619fe4760e Sharlatan Hellseher 2024-04-06gnu: Add scc...* gnu/packages/code.scm (scc): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I90653554a6f0640718892622f76c0c1be138687c Fries 2024-03-21gnu: universal-ctags: Update to 6.1.20240317.0....* gnu/packages/code.scm (universal-ctags): Update to 6.1.20240317.0. Change-Id: I035bc73702fbe9951820e176f09bde16bd9049c6 Efraim Flashner 2024-03-21gnu: global: Update to 6.6.12....* gnu/packages/code.scm (global): Update to 6.6.12. Change-Id: If073f74f55199bfbc9f29b95e9e3db3a6cf00548 Efraim Flashner 2024-02-22gnu: universal-ctags: Update to 6.1.20240218.0....* gnu/packages/code.scm (universal-ctags): Update to 6.1.20240218.0. Change-Id: I3d4b19d0ba002d809cb5e659899965d3f62e8e1a Efraim Flashner