aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
0200'>2024-03-12gnu: ruby-stackprof: Update to 0.2.26....Efraim Flashner 2024-03-12gnu: ruby-stackprof: Skip test known to fail....Efraim Flashner 2024-03-12gnu: ruby-x25519: Fix build on non x86_64....Zheng Junjie 2024-02-25Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-02-24gnu: Add ruby-fog-libvirt....Hartmut Goebel 2024-02-24gnu: Add ruby-fog-xml....Hartmut Goebel 2024-02-24gnu: Add ruby-fog-json....Hartmut Goebel 2024-02-24gnu: Add ruby-fog-core....Hartmut Goebel 2024-02-24gnu: Add ruby-libvirt....Hartmut Goebel 2024-02-24gnu: ruby-childprocess: Update to 4.1.0....Hartmut Goebel 2024-02-24gnu: Add ruby-hashicorp-checkpoint....Hartmut Goebel 2024-02-24gnu: Add ruby-vagrant-cloud....Hartmut Goebel 2024-02-24gnu: Add ruby-grpc....Hartmut Goebel 2024-02-24gnu: Add ruby-googleapis-common-protos-types....Hartmut Goebel 2024-02-24gnu: Add ruby-google-protobuf....Hartmut Goebel 2024-02-24gnu: Add ruby-time....Hartmut Goebel 2024-02-24gnu: Add ruby-serverspec....Hartmut Goebel 2024-02-24gnu: Add ruby-specinfra....Hartmut Goebel 2024-02-24gnu: Add ruby-sfl....Hartmut Goebel 2024-02-24gnu: Add ruby-rgl....Hartmut Goebel 2024-02-24gnu: Add ruby-stream....Hartmut Goebel 2024-02-24gnu: Add ruby-stringio....Hartmut Goebel 2024-02-24gnu: Add ruby-pairing-heap....Hartmut Goebel 2024-02-24gnu: Add ruby-net-telnet....Hartmut Goebel 2024-02-24gnu: Add ruby-net-sftp....Hartmut Goebel 2024-02-24gnu: Add ruby-fake-ftp....Hartmut Goebel 2024-02-24gnu: Add ruby-net-ftp....Hartmut Goebel 2024-02-24gnu: Add ruby-ipaddr....Hartmut Goebel 2024-02-24gnu: Add ruby-excon....Hartmut Goebel 2024-02-24gnu: Add ruby-test-unit-ruby-core....Hartmut Goebel 2024-02-13Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-02-12gnu: ruby-3.2: Update to 3.2.3....Remco van 't Veer 2023-11-19Merge branch 'master' into gnome-team...Liliana Marie Prikler 2023-09-07Merge branch 'master' into gnome-teamLiliana Marie Prikler 2023-11-12gnu: ruby: Fix cross-compilation....Zheng Junjie 2023-08-29gnu: bundler: Update to 2.4.18....TakeV