aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
: Update to 1.1.0. Change-Id: Iafa533051e69423bffdb9e9c4f7db4bda3c39964 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Rodion Goritskov 2024-07-03gnu: Add go-github-com-nwaples-rardecode-v2.2023-12-28gnu: sssd: Update to 2.9.3....* gnu/packages/sssd.scm (sssd): Update to 2.9.3. Change-Id: I43c155ff69e7f0dbb96173056683855871eca749 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Timotej Lazar it/gnu/packages/golang-compression.scm?id=71949ab204cbc5a693aa38c4d5bf9b240341d450'>gnu: Add go-github-com-dsnet-compress....* gnu/packages/golang-compression.scm (go-github-com-dsnet-compress): New variable. Change-Id: I232f2d8cc6bb5eb4c850f233b2e2788d0f2fb35b Sharlatan Hellseher 2024-06-28gnu: go-github-com-nwaples-rardecode-v2: Rename variable....* gnu/packages/golang-compression.scm (go-github-com-nwaples-rardecode-v2): Rename as seen in go.mod to go-github-com-nwaples-rardecode. Change-Id: Id492ee6c4e5aebdbec9487b6990e2c5fa5dfe62c Sharlatan Hellseher 2024-04-04gnu: Add go-github-com-pierrec-lz4....* gnu/packages/golang-compression.scm (go-github-com-pierrec-lz4, go-github-com-pierrec-lz4-v4, go-lz4c): New variables. Change-Id: Ie337a1cbfbc5af2dfd258999a4edb508bd552e03 Sharlatan Hellseher 2024-03-16gnu: go-github-com-ulikunitz-xz: Refresh package style....* gnu/packages/golang-compression.scm (go-github-com-ulikunitz-xz) [source]: Remove trailing ".git" from URL. [description]: Add more info based on project's README. Change-Id: I8590ea9099c45a7b636281c95f4fde5952de9410 Sharlatan Hellseher 2024-03-16gnu: go-github-com-ulikunitz-xz: Update to 0.5.11....* gnu/packages/golang-compression.scm (go-github-com-ulikunitz-xz): Update to 0.5.11. [source]: Use 'git-file-name'. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Troy Figiel 2024-03-16gnu: Add go-github-com-klauspost-pgzip....* gnu/packages/golang-compression.scm (go-github-com-klauspost-pgzip): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Troy Figiel 2024-03-06gnu: Add go-github-com-nwaples-rardecode-v2....* gnu/packages/golang-compression.scm (go-github-com-nwaples-rardecode-v2): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Troy Figiel 2024-03-06gnu: go-github.com-ulikunitz-xz: Adjust name....* gnu/packages/golang-compression.scm (go-github.com-ulikunitz-xz): Rename variable to go-github-com-ulikunitz-xz to follow golang naming style. * gnu/packages/admin.scm (fiano) [inputs]: Remove go-github.com-ulikunitz-xz. Add go-github-com-ulikunitz-xz. * gnu/packages/bioinformatics.scm (go-github-com-biogo-hts-cram) [propagated-inputs]: Remove go-github.com-ulikunitz-xz. Add go-github-com-ulikunitz-xz. Change-Id: Id2f2556666c4f9a08e0203f5ca7eb8352c492051 Sharlatan Hellseher 2024-03-06gnu: Add go-github-com-hhrutter-lzw....* gnu/packages/golang-compression.scm (go-github-com-hhrutter-lzw): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Troy Figiel 2024-02-13gnu: go-github.com-ulikunitz-xz: Move to golang-compression....* gnu/packages/golang.scm (go-github.com-ulikunitz-xz): Move from here ... * gnu/packages/golang-compression.scm: ... to here. * gnu/packages/admin.scm: Add (gnu packages golang-compression) module. * gnu/packages/bioinformatics.scm: As above. Change-Id: I1901e67ac4336efd356085332572b3f09de90f7a Sharlatan Hellseher 2024-02-13gnu: go-github-com-andybalholm-brotli: Move to golang-compression....* gnu/packages/golang.scm (go-github-com-andybalholm-brotli): Move from here ... * gnu/packages/golang-compression.scm: ... to here. Change-Id: I820b0211b1fe4d90643e82fc32a99d8e8b6a9b0f Sharlatan Hellseher 2024-02-13gnu: go-github-com-klauspost-compress: Move to golang-compression....* gnu/packages/golang.scm (go-github-com-klauspost-compress): Move from here ... * gnu/packages/golang-compression.scm: ... to here. * gnu/packages/golang-compression.scm: Add (gnu packages golang-compression) module. * gnu/packages/golang-crypto.scm: As above. * gnu/packages/golang-web.scm: As above. * gnu/packages/uucp.scm: As above. Change-Id: Ia99f1e6aae7f75940fc150eb02862c0b3e9f3325 Sharlatan Hellseher 2024-02-13gnu: go-github-com-golang-snappy: Mmove to golang-compression....* gnu/packages/syncthing.scm (go-github-com-golang-snappy): Move from here ... * gnu/packages/golang-compression.scm: ... to here. * gnu/packages/golang.scm: Add (gnu packages golang-compression) module. * gnu/packages/high-availability.scm: As above. * gnu/packages/ipfs.scm: As above. * gnu/packages/syncthing.scm: As above. Change-Id: I936c82c127e1aa25dde20693bee70e5a871249fe Sharlatan Hellseher 2024-02-13gnu: Add (gnu packages golang-compression) module....* gnu/packages/golang-compression.scm: New file. * gnu/local.mk: Add to gnu/packages/golang-compression.scm scope. Change-Id: I1c68a3f6f9b3d6a316cba560b7fc81e707376417 Sharlatan Hellseher