aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
g-tooltip'>* gnu/packages/wm.scm (waybar): Update to 0.9.7. Tobias Geerinckx-Rice 2021-04-11gnu: xnotify: Update to 0.8.1....* gnu/packages/wm.scm (xnotify): Update to 0.8.1. Oleg Pykhalov 2021-04-11gnu: xclickroot: Update to 1.3....* gnu/packages/wm.scm (xclickroot): Update to 1.3. Oleg Pykhalov 2021-04-10gnu: Add wlogout....* gnu/packages/wm.scm (wlogout): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> la snesne 2021-04-01gnu: waybar: Update to 0.9.5....* gnu/packages/wm.scm (waybar): Update to 0.9.5. [inputs]: Replace fmt-6 with fmt, spdlog-1.7 with spdlog. * gnu/packages/logging.scm (spdlog-1.7): Remove variable. * gnu/packages/pretty-print.scm (fmt-6): Same. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> pricly_yellow 2021-03-30gnu: hikari: Update to 2.2.3....* gnu/packages/wm.scm (hikari): Update to 2.2.3. Tobias Geerinckx-Rice 2021-03-26gnu: hikari: Improve package....* gnu/packages/wm.scm (hikari)[inputs]: Sort alphabetically. [synopsis]: Shorten a bit. [description]: Use full sentences. Nicolas Goaziou 2021-03-26gnu: Add hikari....* gnu/packages/wm.scm (hikari): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> qblade 2021-03-17gnu: Add libucl....* gnu/packages/wm.scm (libucl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> qblade 2021-03-13gnu: cagebreak: Update to 1.6.0....* gnu/packages/wm.scm (cagebreak): Update to 1.6.0. Nicolas Goaziou 2021-03-12gnu: Add sbcl-stumpwm-disk....* gnu/packages/wm.scm: (sbcl-stumpwm-disk): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-03-12gnu: stumpwm-contrib: Update to 0.0.1-3.a7dc1c....* gnu/packages/wm.scm (stumpwm-contrib): Update to 0.0.1-3.a7dc1c. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-03-06gnu: polybar: Update to 3.5.5....* gnu/packages/wm.scm (polybar): Update to 3.5.5. Tobias Geerinckx-Rice 2021-03-02gnu: dwl: Update to 0.2....* gnu/packages/wm.scm (dwl): Update to 0.2. [arguments]: Remove the install phase. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Z572 2021-03-01gnu: i3-wm: Use asciidoc-py3....* gnu/packages/wm.scm (i3-wm)[inputs]: Remove asciidoc. [native-inputs]: Add asciidoc-py3. Björn Höfling 2021-02-21gnu: herbstluftwm: Update to 0.9.2....* gnu/packages/wm.scm (herbstluftwm): Update to 0.9.2. [inputs]: Add libxft. [native-inputs]: Add python. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Boris A. Dekshteyn 2021-02-12gnu: dwl: Fix command name in description....* gnu/packages/wm.scm (dwl)[description]: Fix typo. 宋文武 2021-02-12gnu: Add dwl....* gnu/packages/wm.scm (dwl): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Zheng Junjie