aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2021 Sergei Trofimovich <slyich@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages re2c)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages python)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public re2c
  (package
    (name "re2c")
    (version "2.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/skvadrik/" name
                                 "/releases/download/" version "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
               "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g"))))
    (build-system gnu-build-system)
    (home-page "https://re2c.org/")
    (native-inputs
     (list python))             ; for the test driver
    (synopsis "Lexer generator for C/C++")
    (description
     "@code{re2c} generates minimalistic hard-coded state machine (as opposed
to full-featured table-based lexers).  Flexible API allows generated code
to be wired into virtually any environment.  Instead of exposing traditional
@code{yylex()} style API, re2c exposes its internals.  Be sure to take a look
at examples, they cover a lot of real-world cases and shed some light on dark
corners of re2c API.")
    (license public-domain)))
scm?id=a13c1bf4ca0b15fa53235c2bd6aa53e4a75c7d0f'>Merge branch 'master' into core-updatesLudovic Courtès 2018-05-31system: 'read-boot-parameters' provides a more meaningful warning....Ludovic Courtès 2018-05-28Merge branch 'master' into core-updatesMark H Weaver 2018-05-28file-systems: Remove 'title' field and add <file-system-label>....Ludovic Courtès 2018-05-21Merge branch 'master' into core-updatesMark H Weaver 2018-05-19file-systems: Do not export <file-system>....Ludovic Courtès 2018-04-12Merge branch 'master' into core-updatesMark H Weaver 2018-04-11system: Provide a fall-back PATH for non-login shells started with su(1)....Leo Famulari 2018-03-29Merge branch 'master' into core-updatesMarius Bakke 2018-03-20gnu: util-linux: Fix CVE-2018-7738 without grafting....Leo Famulari 2018-03-07services: file-systems: Include 'user-file-systems' service....Ludovic Courtès 2018-03-02system: Add 'initrd-modules' field....Ludovic Courtès 2018-01-23Merge branch 'master' into core-updatesMark H Weaver 2018-01-21services: Missing services are automatically instantiated....Ludovic Courtès 2018-01-11Merge branch 'master' into core-updatesLeo Famulari 2018-01-09system: Export operating-system-user-kernel-arguments....Danny Milosavljevic 2017-12-31Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2017-12-22services: 'user-processes-service-type' can now be extended....Ludovic Courtès 2017-12-05Merge branch 'master' into core-updatesMarius Bakke 2017-11-20Add semicolon in commands that set GUIX_PROFILE....Ludovic Courtès 2017-11-19Merge branch 'master' into core-updatesMarius Bakke 2017-11-13services: guix: Remove dependency on 'lsof'....Ludovic Courtès 2017-11-09system: Do not set 'TZ'....Ludovic Courtès 2017-11-02gnu: rfkill: Mark as superseded by util-linux....Efraim Flashner 2017-10-10system: operating-system-etc-service: Set XCURSOR_PATH....Thomas Danckaert 2017-10-07system: Really filter out Linux device names for the store....Ludovic Courtès 2017-09-21system: <boot-parameters> does not use "/dev" device names....Ludovic Courtès 2017-09-20gnu: system: Fix computation of boot parameters for LUKS devices....Andy Wingo 2017-09-19system: Create "/etc/hostname"....Thomas Danckaert 2017-09-18system: Define 'DICPATH' in /etc/profile....Ludovic Courtès 2017-09-12system: Add gexp compiler for <operating-system>....Ludovic Courtès 2017-09-11system: Fix typo in 'read-boot-parameters'....Ludovic Courtès 2017-09-11system: Serialize the UUID type in the "parameters" file....Ludovic Courtès 2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès 2017-08-01Merge branch 'master' into core-updatesMarius Bakke 2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic 2017-07-23Merge branch 'master' into core-updatesLeo Famulari 2017-07-23gnu: Add support for aarch64's compiled kernel....Efraim Flashner 2017-07-23Merge branch 'master' into core-updatesLeo Famulari 2017-07-18system: Add 'newuidmap' and 'newgidmap' to %SETUID-PROGRAMS....宋文武 2017-07-17locale: Demonadify the locale creation API....Ludovic Courtès 2017-06-30system: Avoid collision between GMP variants in the global profile....Ludovic Courtès 2017-06-30Merge branch 'master' into core-updatesLudovic Courtès