aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rcm)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages perl))

(define-public rcm
  (package
    (name "rcm")
    (version "1.3.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
                                  version ".tar.gz"))
              (sha256
               (base32 "0bdyksrd9i3lkmr9kq6dwa0l4g2403vnma5s4j9h8spi4rziwx14"))))
    (build-system gnu-build-system)
    (arguments '(#:phases
                 (modify-phases %standard-phases
                   (add-after 'patch-source-shebangs 'patch-tests
                     (lambda _
                       (substitute* '("test/rcrc-tilde.t"
                                      "test/rcdn-hooks-run-in-order.t"
                                      "test/rcup-hooks-run-in-order.t")
                         (("/bin/sh") (which "sh")))
                       (substitute* "test/rcup-hooks.t"
                         (("/usr/bin/env") (which "env"))))))
                  #:parallel-tests? #f))
    (native-inputs (list perl python-cram))
    (synopsis "Management suite for dotfiles")
    (description "The rcm suite of tools is for managing dotfiles directories.  This is
a directory containing all the @code{.*rc} files in your home directory
(@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
names in history, such as “rc files” because they typically end in rc
or “dotfiles” because they begin with a period.  This suite is useful
for committing your rc files to a central repository to share, but it also
scales to a more complex situation such as multiple source directories
shared between computers with some host-specific or task-specific files.")
    (license bsd-3)
    (home-page "https://github.com/thoughtbot/rcm")))
g-avail'>...宋文武 2023-06-08gnu: xfce4-panel: Update to 4.18.4....宋文武 2023-06-08gnu: libxfce4ui: Update to 4.18.4....宋文武 2023-05-17gnu: xfce: Use "Greybird" and "elementary-xfce-dark" as default theme....宋文武 2023-05-14gnu: mousepad: Update to 0.6.1....宋文武 2023-05-14gnu: ristretto: Update to 0.13.1....宋文武 2023-05-01gnu: catfish: Fix build....宋文武 2023-05-01gnu: xfce4-netload-plugin: Update to 1.4.1....宋文武 2023-05-01gnu: xfce4-mpc-plugin: Update to 0.5.3....宋文武 2023-05-01gnu: thunar: Update to 4.18.6....宋文武 2023-05-01gnu: xfce4-weather-plugin: Update to 0.11.1....宋文武 2023-05-01gnu: xfce4-timer-plugin: Update to 1.7.2....宋文武 2023-05-01gnu: xfce4-time-out-plugin: Update to 1.1.3....宋文武 2023-05-01gnu: xfce4-mount-plugin: Update to 1.1.6....宋文武 2023-05-01gnu: xfce4-mailwatch-plugin: Update to 1.3.1....宋文武 2023-05-01gnu: xfce4-fsguard-plugin: Update to 1.1.3....宋文武 2023-05-01gnu: xfce4-calculator-plugin: Update to 0.7.2....宋文武 2023-05-01gnu: xfce4-dict: Update to 0.8.5....宋文武 2023-05-01gnu: xfce4-whiskermenu-plugin: Update to 2.7.3....宋文武 2023-05-01gnu: xfce4-battery-plugin: Update to 1.1.5....宋文武 2023-05-01gnu: tumbler: Update to 4.18.1....宋文武 2023-05-01gnu: xfconf: Update to 4.18.1....宋文武