aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages rcm)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages perl))

(define-public rcm
  (package
    (name "rcm")
    (version "1.3.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
                                  version ".tar.gz"))
              (sha256
               (base32 "0bdyksrd9i3lkmr9kq6dwa0l4g2403vnma5s4j9h8spi4rziwx14"))))
    (build-system gnu-build-system)
    (arguments '(#:phases
                 (modify-phases %standard-phases
                   (add-after 'patch-source-shebangs 'patch-tests
                     (lambda _
                       (substitute* '("test/rcrc-tilde.t"
                                      "test/rcdn-hooks-run-in-order.t"
                                      "test/rcup-hooks-run-in-order.t")
                         (("/bin/sh") (which "sh")))
                       (substitute* "test/rcup-hooks.t"
                         (("/usr/bin/env") (which "env"))))))
                  #:parallel-tests? #f))
    (native-inputs (list perl python-cram))
    (synopsis "Management suite for dotfiles")
    (description "The rcm suite of tools is for managing dotfiles directories.  This is
a directory containing all the @code{.*rc} files in your home directory
(@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
names in history, such as “rc files” because they typically end in rc
or “dotfiles” because they begin with a period.  This suite is useful
for committing your rc files to a central repository to share, but it also
scales to a more complex situation such as multiple source directories
shared between computers with some host-specific or task-specific files.")
    (license bsd-3)
    (home-page "https://github.com/thoughtbot/rcm")))
Alexey Abramov 2023-12-29gnu: Add x-resize....Maxim Cournoyer 2023-12-07gnu: xeyes: Update to 1.3.0....Greg Hogan 2023-11-26Merge branch 'master' into mesa-updates...John Kehayias 2023-11-25gnu: xscreensaver: Update to 6.08....kiasoc5 2023-11-25gnu: kbdd: Fix cross-compilation....Zheng Junjie 2023-11-21Merge branch 'master' into mesa-updates...John Kehayias 2023-11-19gnu: wl-clipboard: Fix shell completion directories....Efraim Flashner 2023-11-09gnu: Add libxkbcommon-1.5....John Kehayias 2023-11-07gnu: libdrm: Restore building libdrm_intel by default....John Kehayias 2023-11-05gnu: libxkbcommon: Update to 1.6.0....Zheng Junjie 2023-11-05gnu: libdrm: Update to 2.4.117....John Kehayias 2023-11-05gnu: pixman: Update to 0.42.2....Hilton Chain 2023-10-21gnu: mtdev: Fix cross-compiling to aarch64-linux....Efraim Flashner 2023-10-20gnu: fuzzel: Update to 1.9.2....jgart 2023-10-15gnu: libxkbcommon: Fix cross-compiling....Efraim Flashner 2023-09-24gnu: xsel: Document clipboard functionality....Rostislav Svoboda 2023-09-27gnu: wvkbd: Update to 0.14.1....Tobias Kortkamp 2023-09-25gnu: bemenu: Update to 0.6.16....Timotej Lazar 2023-09-19gnu: wl-clipboard: Update to 2.2.1....Efraim Flashner 2023-07-23gnu: rxvt-unicode: Fix the cursor position when opening new windows in 9.31....Leo Famulari 2023-08-26gnu: xsecurelock: Update to 1.8.0....kiasoc5 2023-08-26gnu: ydotool: Update to 1.0.4....kiasoc5 2023-08-26gnu: xlockmore: Update to 5.72....kiasoc5 2023-08-26gnu: autorandr: Update to 1.14....kiasoc5 2023-08-17gnu: Add xtrlock....Mehmet Tekman 2023-08-15gnu: Move stalonetray to (gnu packages xdisorg)....kiasoc5 2023-08-15gnu: nwg-launchers: Build with librsvg-for-system....Efraim Flashner 2023-08-15gnu: fuzzel: Build with librsvg-for-system....Efraim Flashner 2023-08-15gnu: tint2: Build with librsvg-for-system....Efraim Flashner 2023-08-15gnu: rofi: Remove pre-generated files....Efraim Flashner 2023-08-15gnu: rofi: Build with librsvg-for-system....Efraim Flashner 2023-08-13gnu: rofi-wayland: Update to 1.7.5+wayland2....Hilton Chain 2023-08-13gnu: wl-clipboard: Update to 2.2.0....Hilton Chain 2023-08-12gnu: Add ulauncher....Sergio Pastor Pérez