aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ratpoison)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (gnu packages)
  #:use-module (gnu packages xorg)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages fontutils))

(define-public ratpoison
  (package
    (name "ratpoison")
    (version "1.4.9")
    (source
     (origin (method url-fetch)
             (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
                                 version ".tar.xz"))
             (sha256
              (base32
               "1wfir1gvh5h7izgvx2kd1pr2k7wlncd33zq7qi9s9k2y0aza93yr"))
             (patches (search-patches "ratpoison-shell.patch"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:modules `((ice-9 format)
                  ,@%default-gnu-modules)
      ;; Specify the absolute location of xterm, as the user experience sucks
      ;; when no terminal is available (can't consult help with 'C-t ?', for
      ;; example).
      #:configure-flags
      #~(list (string-append "--with-xterm="
                             (search-input-file %build-inputs "bin/xterm")))
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'install-xsession
            (lambda _
              ;; Add a .desktop file to xsessions.
              (let ((xsessions (string-append #$output "/share/xsessions")))
                (mkdir-p xsessions)
                (call-with-output-file (string-append xsessions
                                                      "/ratpoison.desktop")
                  (lambda (port)
                    (format port
                            "[Desktop Entry]~@
                            Name=ratpoison~@
                            Comment=Tiling window manager: say goodbye to the rodent!~@
                            Exec=~a/bin/ratpoison~@
                            TryExec=~@*~a/bin/ratpoison~@
                            Type=Application~%"
                            #$output)))))))))
    (inputs
     (list fontconfig
           freetype
           libxft
           libxi
           libxrandr
           libxpm
           libxt
           libxtst
           libx11
           readline
           xorgproto
           xterm))
    (native-inputs
     (list perl
           pkg-config))
    (home-page "https://www.nongnu.org/ratpoison/")
    (synopsis "Simple mouse-free tiling window manager")
    (description
     "Ratpoison is a simple window manager with no fat library
dependencies, no fancy graphics, no window decorations, and no
rodent dependence.  It is largely modelled after GNU Screen which
has done wonders in the virtual terminal market.

The screen can be split into non-overlapping frames.  All windows
are kept maximized inside their frames to take full advantage of
your precious screen real estate.

All interaction with the window manager is done through keystrokes.
Ratpoison has a prefix map to minimize the key clobbering that
cripples Emacs and other quality pieces of software.")
    (license gpl2+)))
f='/guix/commit/gnu/packages/gnupg.scm?id=affeb3def70023a277b66f44d6d0ec9663f8dd54'>gnu: jetring: Update to 0.30....* gnu/packages/gnupg.scm (jetring): Update to 0.30. Tobias Geerinckx-Rice 2021-02-08gnu: gnupg: Update to 2.2.27....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.27. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Vincent Legoll 2021-02-01gnu: pinentry-rofi: Update to 2.0.3....* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.3. [arguments]: Add make installcheck phase to verify the installed artifact. [native-inputs]: Add autoconf-archive. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Fredrik Salomonsson 2021-01-28gnu: pinentry-rofi: Update to 2.0.2....* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.2. [arguments]: Simplify the package definition. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Fredrik Salomonsson 2021-01-27gnu: guile-gcrypt: Refer to the right libgcrypt when cross-compiling....Fixes a regression introduced in 5e163ba00969e7ba05897840a1199b967252b4ae where (gcrypt package-config) would end up referring to the native libgcrypt.so instead of the target one. * gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: Reintroduce 'add-libgrypt-config' phase. [native-inputs]: Remove LIBGCRYPT. Ludovic Courtès 2021-01-27gnu: pinentry-efl: Tweak description....* gnu/packages/gnupg.scm (pinentry-efl)[description]: Use @acronym. Tobias Geerinckx-Rice 2021-01-27gnu: pinentry-tty: Update to 1.1.1....* gnu/packages/gnupg.scm (pinentry-tty): Update to 1.1.1. (pinentry-efl)[source]: Remove patch. * gnu/packages/patches/pinentry-efl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Tobias Geerinckx-Rice 2021-01-26gnu: guile-gcrypt: Build sequentially and reproducibly....* gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: New field. Ludovic Courtès 2021-01-26gnu: guile-gcrypt: Add libgcrypt to 'native-inputs'....* gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: Remove. [native-inputs]: Add LIBGCRYPT. Ludovic Courtès 2021-01-13gnu: Add pinentry-rofi....* gnu/packages/gnupg.scm (pinentry-rofi): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fredrik Salomonsson 2021-01-12gnu: gpgme: Update to 1.15.1....* gnu/packages/gnupg.scm (gpgme): Update to 1.15.1. Tobias Geerinckx-Rice 2020-11-30gnu: signing-party: Update to 2.11....* gnu/packages/gnupg.scm (signing-party): Update to 2.11. Tobias Geerinckx-Rice 2020-11-26Merge branch 'master' into stagingMarius Bakke 2020-11-25gnu: gnupg: Update to 2.2.25....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.25. Marius Bakke 2020-11-25gnu: libksba: Update to 1.5.0....* gnu/packages/gnupg.scm (libksba): Update to 1.5.0. Marius Bakke 2020-11-25gnu: Remove gnupg-2....This package was marked as superseded by gnupg in December 2017. * gnu/packages/gnupg.scm (gnupg-2): Remove variable. Efraim Flashner 2020-11-19Merge branch 'master' into stagingMarius Bakke 2020-11-18gnu: gpgme: Update to 1.15.0....* gnu/packages/gnupg.scm (gpgme): Update to 1.15.0. Miguel Ángel Arruga Vivas 2020-11-17gnu: gnupg: Update to 2.2.24....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.24. Miguel Ángel Arruga Vivas 2020-11-17gnu: libksba: Update to 1.4.0....* gnu/packages/gnupg.scm (libksba): Update to 1.4.0. Miguel Ángel Arruga Vivas 2020-11-17gnu: libassuan: Update to 2.5.4....* gnu/packages/gnupg.scm (libassuan): Update to 2.5.4. Miguel Ángel Arruga Vivas 2020-11-08gnu: libgpg-error: Fix cross-compiling to mips64el-linux....* gnu/packages/gnupg.scm (libgpg-error)[arguments]: When cross compiling create a symlink for mips64el. Efraim Flashner