;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014, 2015 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages zip) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #
aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Simon South <simon@simonsouth.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ragel)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages base))

(define-public ragel
  (package
    (name "ragel")
    (version "6.10")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.colm.net/files/ragel/ragel-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gvcsl62gh6sg73nwaxav4a5ja23zcnyxncdcdnqa2yjcpdnw5az"))))
    (build-system gnu-build-system)
    (arguments
     (if (target-aarch64?)
         '(#:phases
           (modify-phases %standard-phases
             (add-after 'unpack 'apply-char-signedness-fix
               ;; Apply a backported fix for aarch64-linux, where the C/C++
               ;; "char" type is unsigned by default.
               ;;
               ;; The patch is applied in this custom phase and not via the
               ;; "origin" object above to avoid rebuilding a large number of
               ;; packages on other platforms.
               (lambda _
                 (let ((patch
                        (search-input-file %build-inputs "/bin/patch"))
                       (char-signedness-patch
                        (assoc-ref %build-inputs "char-signedness-patch")))
                   (invoke patch "-p1" "-i" char-signedness-patch))))))
         '()))
    (native-inputs
     (if (target-aarch64?)
         `(("char-signedness-patch"
            ,(search-patch "ragel-char-signedness.patch"))
           ("patch" ,patch))
         '()))
    (home-page "https://www.colm.net/open-source/ragel/")
    (synopsis "State machine compiler")
    (description
     "Ragel compiles executable finite state machines from regular languages.
Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby.  Ragel state machines
can not only recognize byte sequences as regular expression machines do, but
can also execute code at arbitrary points in the recognition of a regular
language.  Code embedding is done using inline operators that do not disrupt
the regular language syntax.")
    ;; GPLv2 (or later) with exception for generated code.
    (license license:gpl2+)))

bution.")))) (define-public zziplib (package (name "zziplib") (version "0.13.62") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/zziplib/zziplib13/" version "/zziplib-" version ".tar.bz2")) (sha256 (base32 "0nsjqxw017hiyp524p9316283jlf5piixc1091gkimhz38zh7f51")))) (build-system gnu-build-system) (inputs `(("zlib" ,zlib))) (native-inputs `(("perl" ,perl) ; for the documentation ("pkg-config" ,pkg-config) ("python" ,python-2) ; for the documentation; Python 3 not supported, ; http://forums.gentoo.org/viewtopic-t-863161-start-0.html ("zip" ,zip))) ; to create test files (arguments `(#:parallel-tests? #f)) ; since test files are created on the fly (home-page "http://zziplib.sourceforge.net/") (synopsis "Library for accessing zip files") (description "ZZipLib is a library based on zlib for accessing zip files.") (license license:lgpl2.0+))) (define-public perl-zip (package (name "perl-zip") (version "1.59") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/Archive-Zip-" version ".tar.gz")) (sha256 (base32 "0m31qlppg65vh32pwxkwjby02q70abx49d2yk6vfd4585fqb27cx")))) (build-system perl-build-system) (synopsis "Provides an interface to ZIP archive files") (description "The Archive::Zip module allows a Perl program to create, manipulate, read, and write Zip archive files.") (home-page "http://search.cpan.org/~adamk/Archive-Zip-1.30/") (license (package-license perl))))