aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Simon South <simon@simonsouth.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ragel)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages base))

(define-public ragel
  (package
    (name "ragel")
    (version "6.10")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.colm.net/files/ragel/ragel-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gvcsl62gh6sg73nwaxav4a5ja23zcnyxncdcdnqa2yjcpdnw5az"))))
    (build-system gnu-build-system)
    (arguments
     (if (target-aarch64?)
         '(#:phases
           (modify-phases %standard-phases
             (add-after 'unpack 'apply-char-signedness-fix
               ;; Apply a backported fix for aarch64-linux, where the C/C++
               ;; "char" type is unsigned by default.
               ;;
               ;; The patch is applied in this custom phase and not via the
               ;; "origin" object above to avoid rebuilding a large number of
               ;; packages on other platforms.
               (lambda _
                 (let ((patch
                        (search-input-file %build-inputs "/bin/patch"))
                       (char-signedness-patch
                        (assoc-ref %build-inputs "char-signedness-patch")))
                   (invoke patch "-p1" "-i" char-signedness-patch))))))
         '()))
    (native-inputs
     (if (target-aarch64?)
         `(("char-signedness-patch"
            ,(search-patch "ragel-char-signedness.patch"))
           ("patch" ,patch))
         '()))
    (home-page "https://www.colm.net/open-source/ragel/")
    (synopsis "State machine compiler")
    (description
     "Ragel compiles executable finite state machines from regular languages.
Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby.  Ragel state machines
can not only recognize byte sequences as regular expression machines do, but
can also execute code at arbitrary points in the recognition of a regular
language.  Code embedding is done using inline operators that do not disrupt
the regular language syntax.")
    ;; GPLv2 (or later) with exception for generated code.
    (license license:gpl2+)))

Andy Tai 2023-07-22gnu: pluma: Update to 1.26.1....* gnu/packages/mate.scm (pluma): Update to 1.26.1. [inputs]: Replace gtksourceview-3 with gtksourceview-4. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: engrampa: Update to 1.26.1....* gnu/packages/mate.scm (engrampa): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: eom: Update to 1.26.1....* gnu/packages/mate.scm (eom): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-utils: Update to 1.26.1....* gnu/packages/mate.scm (mate-utils): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-menus: Update to 1.26.1....* gnu/packages/mate.scm (mate-menus): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-screensaver: Update to 1.26.2....* gnu/packages/mate.scm (mate-screensaver): Update to 1.26.2. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-netbook: Update to 1.26.0....* gnu/packages/mate.scm (mate-netbook): Update to 1.26.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-backgrounds: Update to 1.26.0....* gnu/packages/mate.scm (mate-backgrounds): update to 1.26.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-calc: Update to 1.26.0....* gnu/packages/mate.scm (mate-calc): Update to 1.26.0. [inputs]: Add mpc and mpfr. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-user-guide: Update to 1.26.1....* gnu/packages/mate.scm (mate-user-guide): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-control-center: Update to 1.26.1....* gnu/packages/mate.scm (mate-control-center): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: caja-extensions: Update to 1.26.1....* gnu/packages/mate.scm (caja-extensions): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: marco: Update to 1.26.2....* gnu/packages/mate.scm (marco): Update to 1.26.2. [inputs]: Add libxres. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: caja: Update to 1.26.1....* gnu/packages/mate.scm (caja): update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-panel: Update to 1.26.3....* gnu/packages/mate.scm (mate-panel): Update to 1.26.3. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-media: Update to 1.26.1....* gnu/packages/mate.scm (mate-media): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-applets: Update to 1.26.1....* gnu/packages/mate.scm (mate-applets): Update to 1.26.1. [inputs]: Add libnl. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: libmatekbd: Update to 1.26.1....* gnu/packages/mate.scm (libmatekbd): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: libmatemixer: Update to 1.26.0....* gnu/packages/mate.scm (libmatemixer): Update to 1.26.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-settings-daemon: Update to 1.26.1....* gnu/packages/mate.scm (mate-settings-daemon): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-session-manager: Update to 1.26.1....* gnu/packages/mate.scm (mate-session-manager): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-terminal: Update to 1.26.1....* gnu/packages/mate.scm (mate-terminal): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: libmateweather: Update to 1.26.1....* gnu/packages/mate.scm (libmateweather): Update to 1.26.1. [source]: Add libmateweather-use-TZDIR.patch. [inputs]: Replace tzdata with tzdata-for-tests. [arguments]: Set TZDIR, ignore test failure for 'check-timezones.sh'. * gnu/packages/patches/libmateweather-use-TZDIR.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Co-authored-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai 2023-07-22gnu: mate-desktop: Update to 1.26.1....* gnu/packages/mate.scm (mate-desktop): Update to 1.26.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Andy Tai