aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Simon South <simon@simonsouth.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ragel)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages base))

(define-public ragel
  (package
    (name "ragel")
    (version "6.10")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.colm.net/files/ragel/ragel-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gvcsl62gh6sg73nwaxav4a5ja23zcnyxncdcdnqa2yjcpdnw5az"))))
    (build-system gnu-build-system)
    (arguments
     (if (target-aarch64?)
         '(#:phases
           (modify-phases %standard-phases
             (add-after 'unpack 'apply-char-signedness-fix
               ;; Apply a backported fix for aarch64-linux, where the C/C++
               ;; "char" type is unsigned by default.
               ;;
               ;; The patch is applied in this custom phase and not via the
               ;; "origin" object above to avoid rebuilding a large number of
               ;; packages on other platforms.
               (lambda _
                 (let ((patch
                        (search-input-file %build-inputs "/bin/patch"))
                       (char-signedness-patch
                        (assoc-ref %build-inputs "char-signedness-patch")))
                   (invoke patch "-p1" "-i" char-signedness-patch))))))
         '()))
    (native-inputs
     (if (target-aarch64?)
         `(("char-signedness-patch"
            ,(search-patch "ragel-char-signedness.patch"))
           ("patch" ,patch))
         '()))
    (home-page "https://www.colm.net/open-source/ragel/")
    (synopsis "State machine compiler")
    (description
     "Ragel compiles executable finite state machines from regular languages.
Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby.  Ragel state machines
can not only recognize byte sequences as regular expression machines do, but
can also execute code at arbitrary points in the recognition of a regular
language.  Code embedding is done using inline operators that do not disrupt
the regular language syntax.")
    ;; GPLv2 (or later) with exception for generated code.
    (license license:gpl2+)))

45'>gnu: gimp: Update to 2.10.2....Tobias Geerinckx-Rice 2018-06-21gnu: gegl: Update to 0.4.2....Tobias Geerinckx-Rice 2018-06-21gnu: babl: Update to 0.1.50....Tobias Geerinckx-Rice 2018-05-29gnu: mypaint-brushes: Fetch source from git....Ricardo Wurmus 2018-05-29gnu: mypaint-brushes: Fix build....Ricardo Wurmus 2018-05-23gnu: gimp-fourier: Fix build....Ricardo Wurmus 2018-04-30gnu: gimp: Update to 2.10.0....Leo Famulari 2018-04-30gnu: babl: Update to 0.1.46....Leo Famulari 2018-04-30gnu: gegl: Update to 0.4....Leo Famulari 2018-04-30gnu: Add mypaint-brushes....Leo Famulari 2018-04-30gnu: Add libmypaint....Leo Famulari 2018-03-17gnu: Fix common unquote typos....Tobias Geerinckx-Rice 2018-01-21gnu: babl: Update to 0.1.40....Tobias Geerinckx-Rice 2018-01-21gnu: babl: Parameterise source URI....Tobias Geerinckx-Rice 2018-01-21gnu: babl: Edit description....Tobias Geerinckx-Rice 2017-12-31gnu: gimp: Fix CVE-2017-{17784,17785,17786,17787,17789}....Leo Famulari 2017-12-20gnu: babl: Update to 0.1.38....Leo Famulari 2017-08-27gnu: babl: Update to 0.1.30....Marius Bakke 2017-08-08gnu: babl: Update to 0.1.28....Efraim Flashner 2017-08-08gnu: gegl: Use 'modify-phases' syntax....Efraim Flashner 2017-08-08gnu: gegl: Fix building on aarch64....Efraim Flashner 2017-05-12gnu: gimp: Update to 2.8.22 [fixes CVE-2007-3126]....Leo Famulari 2017-01-23gnu: gegl: Don't replace 'sh' reference with 'bash'....Leo Famulari 2017-01-13gnu: Removed unused module import from (gnu packages gimp)....Leo Famulari 2017-01-03gnu: gimp: Enable PDF support...Maxim Cournoyer