aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pv)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public pv
  (package
    (name "pv")
    (version "1.7.24")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
                           version ".tar.gz"))
       (sha256
        (base32 "0pmnazlbx8haf5drflf171xca0v5bw8mmspax9k01mf815c3rx1v"))))
    (build-system gnu-build-system)
    (home-page "https://www.ivarch.com/programs/pv.shtml")
    (synopsis "Pipeline progress indicator")
    (description
     "@acronym{pv, Pipe Viewer} is a terminal tool for monitoring the progress
of data through a pipeline.  It can be inserted into any normal pipeline
between two processes.  It gives a visual indication of how quickly data is
passing through, how much has been transferred and how near to completion it is
(with a progress bar), how long it has taken, and an estimate of the remaining
time before completion.")
    (license artistic2.0)))
il'>...* gnu/packages/emacs.scm (emacs-next-pgtk): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Andrew Tropin 2020-11-11gnu: emacs.scm: Remove unused module import....* gnu/packages/emacs.scm: Don't import (gnu packages imagemagick). Marius Bakke 2020-11-03Revert "gnu: emacs: Make strip-double-wrap more robust."...This reverts commit b107a19ffb6a6abb7bde3436f3fa359071bd1f5c. It causes too many rebuilds related to emacs-minimal, and fails with "No code for module (guix build glib-or-gtk-build-system)". Nicolas Goaziou 2020-11-03gnu: emacs: Make strip-double-wrap more robust....* gnu/packages/emacs.scm (emacs) [strip-double-wrap]: Use regex to find emacs executable. This works even when the version is changed by package transformations (e.g., version=git.master). Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Morgan Smith 2020-10-01gnu: emacs-next: Fix load path and version....Fixes <http://issues.guix.info/43277>. * gnu/packages/emacs.scm (emacs)[strip-double-wrap]: Modify to work with emacs-next. (emacs-next)[version]: Use git-version to produce the version string. [arguments]: Remove field. [native-search-paths]: Add field. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Morgan Smith 2020-09-02gnu: Add emacs-next....* gnu/packages/emacs.scm (emacs-next): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Morgan Smith 2020-08-31gnu: emacs: Strip double wrap....* gnu/packages/emacs.scm (emacs)[#:phases]: Add 'strip-double-wrap. (emacs-minimal emacs-xwidgets emacs-no-x) (emacs-no-x-toolkit guile-emacs)[#:phases]: Delete 'strip-double-wrap. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Leo Prikler 2020-08-29Revert "gnu: emacs: Strip double wrap."...This reverts commit 0ec6b8afd7e7a6c288fbf48c5779f2e0bdaffb55 that prevents the load of Emacs packages. Mathieu Othacehe 2020-08-29gnu: emacs: Strip double wrap....* gnu/packages/emacs.scm (emacs)[#:phases]: Add 'strip-double-wrap. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Leo Prikler 2020-08-28gnu: emacs: Update to 27.1....* gnu/packages/emacs.scm (emacs): Update to 27.1. [source]: In snippet, use 'find-files' to find 'eshell/esh-groups.el' if it exists, but gracefully handle its absence. [arguments]: Add "--with-cairo" to configure-flags. Add 'restore-emacs-pdmp' and 'make-compressed-files-writable' phases. Explicitly return #t from 'install-site-start' phase. [inputs]: Add cairo, pango, harfbuzz, jansson, and gmp. Remove imagemagick. (emacs-next): Remove variable. (emacs-minimal, emacs-xwidgets): Use 'package/inherit'. [arguments]: Remove 'restore-emacs-pdmp' phase. (emacs-no-x): Use 'package/inherit'. [arguments]: Remove "--with-cairo" from configure-flags. Remove 'restore-emacs-pdmp' phase. [inputs]: Remove cairo, pango, and harfbuzz. (emacs-no-x-toolkit): Use 'package/inherit'. [arguments]: Remove 'restore-emacs-pdmp' phase. Remove superfluous quasiquote+unquote-splicing pair. (emacs-wide-int): Use 'package/inherit'. (guile-emacs): Use 'package/inherit'. [arguments]: Remove "--with-cairo" from configure-flags. Remove 'restore-emacs-pdmp' phase. * gnu/packages/patches/emacs-ignore-empty-xim-styles.patch, gnu/packages/patches/emacs-source-date-epoch.patch: Adapt to apply cleanly to emacs-27.1. * gnu/packages/patches/emacs-exec-path.patch: Replace with the previous contents of 'emacs27-exec-path.patch', but remove the superfluous comment about it being "like emacs-exec-path.patch, but for Emacs 27". * gnu/packages/patches/emacs27-exec-path.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove 'emacs27-exec-path.patch'. Mark H Weaver 2020-08-03gnu: emacs: Ignore empty XIM styles....As of libx11 version 1.6.10, xim may be NULL, which causes a segmentation fault in the execution of ARRAYELTS. As a cautionary measure, we short-circuit this logic. * gnu/packages/patches/emacs-ignore-empty-xim-styles.patch: New file. * gnu/packages/emacs.scm (emacs emacs-next)[patches]: Use it. * gnu/local.mk: Register it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Leo Prikler