aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pv)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public pv
  (package
    (name "pv")
    (version "1.7.24")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
                           version ".tar.gz"))
       (sha256
        (base32 "0pmnazlbx8haf5drflf171xca0v5bw8mmspax9k01mf815c3rx1v"))))
    (build-system gnu-build-system)
    (home-page "https://www.ivarch.com/programs/pv.shtml")
    (synopsis "Pipeline progress indicator")
    (description
     "@acronym{pv, Pipe Viewer} is a terminal tool for monitoring the progress
of data through a pipeline.  It can be inserted into any normal pipeline
between two processes.  It gives a visual indication of how quickly data is
passing through, how much has been transferred and how near to completion it is
(with a progress bar), how long it has taken, and an estimate of the remaining
time before completion.")
    (license artistic2.0)))
/guix/commit/gnu/packages/pdf.scm?id=6c1c5fecd6a1af29de8deff3ab35cfc5865e8cb7'>gnu: mupdf: Prepare for cross-compilation....Tobias Geerinckx-Rice 2020-11-24gnu: mupdf: Update to 1.18.0....Tobias Geerinckx-Rice 2020-11-24gnu: mupdf: Remove more bundled software....Tobias Geerinckx-Rice 2020-11-24gnu: poppler-data: Update to 0.4.10....Tobias Geerinckx-Rice 2020-11-17gnu: pdfpc: Update to 4.4.1....Tobias Geerinckx-Rice 2020-11-11gnu: fbida: Remove unused input....Marius Bakke 2020-10-23gnu: xournalpp: Update to 1.0.19....Nicolas Goaziou 2020-10-20gnu: poppler: Always use the same 'cairo-sans-poppler' variant....Ludovic Courtès 2020-10-15gnu: zathura: Update to 0.4.7....Michael Rohleder 2020-09-07gnu: xournalpp: Fix path to addr2line binary....Lars-Dominik Braun 2020-08-05gnu: stapler: Update to 1.0.0....Kei Kebreau 2020-07-29gnu: paps: Update description....Tobias Geerinckx-Rice 2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès 2020-05-29Merge branch 'master' into stagingMarius Bakke 2020-05-26gnu: qpdf: Update to 10.0.1....Marius Bakke 2020-05-26gnu: mupdf: Don't use NAME in source URI....Tobias Geerinckx-Rice 2020-05-13mailmap: Update entries for Nikita....nikita 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-25gnu: python-reportlib: Update to 3.5.42....Efraim Flashner 2020-04-25gnu: python-reportlib: Add missing libraries....Efraim Flashner 2020-04-24gnu: pdfpc: Upgrade to 4.4.0...Jack Hill 2020-04-19Merge branch 'master' into core-updatesMarius Bakke 2020-04-16gnu: xournalpp: Remove outdated comments....Nicolas Goaziou 2020-04-16gnu: xournalpp: Update to 1.0.18....Nicolas Goaziou