aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pv)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public pv
  (package
    (name "pv")
    (version "1.7.24")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
                           version ".tar.gz"))
       (sha256
        (base32 "0pmnazlbx8haf5drflf171xca0v5bw8mmspax9k01mf815c3rx1v"))))
    (build-system gnu-build-system)
    (home-page "https://www.ivarch.com/programs/pv.shtml")
    (synopsis "Pipeline progress indicator")
    (description
     "@acronym{pv, Pipe Viewer} is a terminal tool for monitoring the progress
of data through a pipeline.  It can be inserted into any normal pipeline
between two processes.  It gives a visual indication of how quickly data is
passing through, how much has been transferred and how near to completion it is
(with a progress bar), how long it has taken, and an estimate of the remaining
time before completion.")
    (license artistic2.0)))
a>...Alex Kost 2015-06-07Thank Thomas.Ludovic Courtès 2015-05-01Thank Joshua.Ludovic Courtès 2015-04-14Thank Pjotr.Ludovic Courtès 2015-02-24Thank Daniel.Ludovic Courtès 2015-02-07Thank Andrei.Ludovic Courtès 2015-01-28Thank Amirouche.Ludovic Courtès 2014-12-09Thank rekado.Ludovic Courtès 2014-11-28Add (guix elf)....Ludovic Courtès 2014-11-17Thank Bruno.Ludovic Courtès 2014-11-13doc: Improve acknowledgments....Ludovic Courtès 2014-11-11Thank Sylvain.Ludovic Courtès 2014-11-10Thank Philip Woods.Ludovic Courtès 2014-11-08Thank Felipe.Ludovic Courtès 2014-08-31Thank Frederico.Ludovic Courtès 2014-08-23Thank Brandon.Ludovic Courtès 2014-08-15Update AUTHORS and THANKS.Ludovic Courtès 2014-07-22Thank Adam.Ludovic Courtès 2014-07-18Thank Marek.Ludovic Courtès 2014-07-16Update 'THANKS'....John Darrington 2014-07-05Thank Taylan and Alex.Ludovic Courtès 2014-06-17Thank Benno.Ludovic Courtès 2014-06-09Thank Carlos.Ludovic Courtès 2014-01-03Thank Niels.Ludovic Courtès 2013-12-30Thank Kete.Ludovic Courtès 2013-10-14Thank Jeffrin and David.Ludovic Courtès 2013-10-06Update 'AUTHORS'....Ludovic Courtès 2013-09-21Thank Cyrill.Ludovic Courtès 2013-09-12Thank Matthias and Yutaka.Ludovic Courtès 2013-08-24gnu: Add pspp....Andreas Enge 2013-08-24gnu: Add libextractor....Andreas Enge 2013-07-15Thank the translators.Ludovic Courtès 2013-07-04Import (guix hash) in build-aux/download.scm....Ludovic Courtès