aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pv)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public pv
  (package
    (name "pv")
    (version "1.7.24")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
                           version ".tar.gz"))
       (sha256
        (base32 "0pmnazlbx8haf5drflf171xca0v5bw8mmspax9k01mf815c3rx1v"))))
    (build-system gnu-build-system)
    (home-page "https://www.ivarch.com/programs/pv.shtml")
    (synopsis "Pipeline progress indicator")
    (description
     "@acronym{pv, Pipe Viewer} is a terminal tool for monitoring the progress
of data through a pipeline.  It can be inserted into any normal pipeline
between two processes.  It gives a visual indication of how quickly data is
passing through, how much has been transferred and how near to completion it is
(with a progress bar), how long it has taken, and an estimate of the remaining
time before completion.")
    (license artistic2.0)))
ass='msg-tooltip'>* gnu/packages/pretty-print.scm (highlight): Update to 3.60. Tobias Geerinckx-Rice 2020-11-15gnu: highlight: Update to 3.59....* gnu/packages/pretty-print.scm (highlight): Update to 3.59. Tobias Geerinckx-Rice 2020-11-11gnu: a2ps: Remove unused input....* gnu/packages/pretty-print.scm (a2ps)[inputs]: Remove IMAGEMAGICK. Marius Bakke 2020-10-09gnu: source-highlight: Allow cross-compilation....* gnu/packages/pretty-print.scm (source-highlight)[arguments]: Add 'skip-doc-directory' when (%current-target-system) is true. Ludovic Courtès 2020-09-15gnu: waybar: Fix build....Reported by bdju. * gnu/packages/pretty-print.scm (fmt-6): New variable. * gnu/packages/wm.scm (waybar)[inputs]: Replace fmt with fmt-6. Efraim Flashner 2020-09-13gnu: fmt: Update to 7.0.3....From 820d39a55a5673fffac70c919b8cc3b28d94f6e7 Mon Sep 17 00:00:00 2001 From: Greg Hogan <code@greghogan.com> Date: Fri, 11 Sep 2020 10:53:20 +0000 Subject: [PATCH] gnu: fmt: Update to 7.0.3. * gnu/packages/pretty-print.scm (fmt): Update to 7.0.3. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2020-09-11gnu: highlight: Update to 3.58....* gnu/packages/pretty-print.scm (highlight): Update to 3.58. Tobias Geerinckx-Rice 2020-06-30gnu: Sort package modules alphabetically in (gnu packages pretty-print)....* gnu/packages/pretty-print.scm: Sort package module imports alphabetically. Efraim Flashner