aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages purescript)
  #:use-module (gnu packages)
  #:use-module (gnu packages haskell-xyz)
  #:use-module (gnu packages haskell-check)
  #:use-module (gnu packages haskell-crypto)
  #:use-module (gnu packages haskell-web)
  #:use-module ((gnu packages python) #:select (python))
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix packages)
  #:use-module (guix build-system haskell)
  #:use-module ((guix licenses) #:prefix license:))

(define-public purescript
  (package
    (name "purescript")
    (version "0.15.10")
    (source
     (origin
       (method url-fetch)
       (uri (hackage-uri "purescript" version))
       (sha256
        (base32 "08pashk8pm4yjsaq2g94sqa2yd3rfq9fwpxa9qccvjv6in9zybf1"))))
    (build-system haskell-build-system)
    (properties '((upstream-name . "purescript")))
    (inputs (list ghc-aeson
                  ghc-aeson-better-errors
                  ghc-ansi-terminal
                  ghc-blaze-html
                  ghc-bower-json
                  ghc-boxes
                  ghc-cborg
                  ghc-serialise
                  ghc-cheapskate
                  ghc-clock
                  ghc-cryptonite
                  ghc-data-ordlist
                  ghc-dlist
                  ghc-edit-distance
                  ghc-file-embed
                  ghc-glob
                  ghc-language-javascript
                  ghc-lens
                  ghc-lifted-async
                  ghc-lifted-base
                  ghc-memory
                  ghc-monad-control
                  ghc-monad-logger
                  ghc-monoidal-containers
                  ghc-parallel
                  ghc-pattern-arrows
                  ghc-protolude
                  ghc-regex-tdfa
                  ghc-safe
                  ghc-scientific
                  ghc-semigroups
                  ghc-semialign
                  ghc-sourcemap
                  ghc-stringsearch
                  ghc-these
                  ghc-transformers-base
                  ghc-utf8-string
                  ghc-vector
                  ghc-witherable
                  ghc-ansi-wl-pprint
                  ghc-network
                  ghc-optparse-applicative
                  ghc-gitrev))
    (native-inputs (list ghc-generic-random
                         ghc-hspec
                         ghc-hunit
                         ghc-newtype
                         ghc-quickcheck
                         ghc-regex-base
                         ghc-split
                         ghc-typed-process
                         ghc-happy))
    (arguments
     (list
      ;; Tests require npm
      #:tests? #f
       #:configure-flags
       #~(list "--flags=release")
       #:haddock? #f
       #:phases
       #~(modify-phases %standard-phases
         (add-before 'configure 'update-constraints
           (lambda _
             (substitute* "purescript.cabal"
               (("\\b(language-javascript|process)\\s+[^,]+" all dep)
                dep)
               (("happy:happy ==1.20.0") "happy:happy"))))
         (add-after 'register 'remove-libraries
           (lambda _
             (delete-file-recursively
               (string-append #$output "/lib")))))))
    (home-page "https://www.purescript.org/")
    (synopsis "Haskell inspired programming language compiling to JavaScript")
    (description
     "Purescript is a small strongly, statically typed programming language with
expressive types, inspired by Haskell and compiling to JavaScript.")
    (license license:bsd-3)))

he <m.othacehe@gmail.com> Tanguy Le Carrour 2019-10-25gnu: profanity: Update to 0.7.1....* gnu/packages/messaging.scm (profanity): Update to 0.7.1, [uri]: update source URL to the one provided on the website. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Tanguy Le Carrour 2019-10-17gnu: telegram-purple: Update to 1.4.2....* gnu/packages/messaging.scm (telegram-purple): Update to 1.4.2. Tobias Geerinckx-Rice 2019-10-15gnu: quaternion: Wrap with extra inputs....* gnu/packages/messaging.scm (quaternion)[inputs]: Add qtquickcontrols2. [arguments]: Use WRAP-QT-PROGRAM. Tobias Geerinckx-Rice 2019-10-06gnu: quaternion: Update to 0.0.9.4c....* gnu/packages/messaging.scm (quaternion): Update to 0.0.9.4c. Tobias Geerinckx-Rice 2019-10-06gnu: libqmatrixclient: Update to 0.5.2....* gnu/packages/messaging.scm (libqmatrixclient): Update to 0.5.2. Tobias Geerinckx-Rice 2019-09-29gnu: znc: Update to 1.7.5....* gnu/packages/messaging.scm (znc): Update to 1.7.5. Tobias Geerinckx-Rice 2019-09-23gnu: utox: Update to 0.17.1....* gnu/packages/messaging.scm (utox): Update to 0.17.1. Rutger Helling 2019-07-17gnu: telegram-purple: Update to 1.4.1....* gnu/packages/messaging.scm (telegram-purple): Update to 1.4.1. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jonathan Brielmaier 2019-06-25gnu: znc: Enable internationalisation....* gnu/packages/messaging.scm (znc)[arguments]: Want i18n. [native-inputs]: Add the required boost and gettext-minimal packages. Tobias Geerinckx-Rice 2019-06-25gnu: znc: Build with CMake....* gnu/packages/messaging.scm (znc)[build-system]: Use the CMAKE-BUILD-SYSTEM. [arguments]: Adjust #:configure-flags and where the googletest sources are unpacked. Tobias Geerinckx-Rice 2019-06-25gnu: znc: Don't refer to native-inputs....* gnu/packages/messaging.scm (znc)[native-inputs]: Move run-time perl & python… [inputs]: …here, in alphabetical order. Tobias Geerinckx-Rice 2019-06-24gnu: znc: Switch back to Guix's googletest package....* gnu/packages/messaging.scm (znc)[native-inputs]: Use the packaged googletest's sources. Tobias Geerinckx-Rice 2019-06-23gnu: znc: Update to 1.7.4....* gnu/packages/messaging.scm (znc): Update to 1.7.4. Tobias Geerinckx-Rice 2019-05-26gnu: pidgin: Use HTTPS home page....* gnu/packages/messaging.scm (pidgin)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2019-05-26gnu: pidgin: Add network-manager support....* gnu/packages/messaging.scm (pidgin)[inputs]: Add network-manager. [arguments]: Undisable it in #:configure-flags. Tobias Geerinckx-Rice 2019-05-26gnu: pidgin: Update to 2.13.0....* gnu/packages/messaging.scm (pidgin): Update to 2.13.0. Tobias Geerinckx-Rice 2019-05-26gnu: pidgin: Don't use NAME in source URI....* gnu/packages/messaging.scm (pidgin)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-05-24gnu: gajim-omemo: Update to 2.6.29....* gnu/packages/messaging.scm (gajim-omemo): Update to 2.6.29. Rutger Helling 2019-05-13gnu: gajim: Fix error when GAJIM_PLUGIN_PATH is not set....Fixes <https://bug.gnu.org/35606> * gnu/packages/messaging.scm (gajim)[arguments]: Handle case when GAJIM_PLUGIN_PATH is unset in add-plugins-dir phase. Ricardo Wurmus 2019-04-27gnu: gajim: Update to 1.1.3....* gnu/packages/messaging.scm (gajim): Update to 1.1.3. Clément Lassieur 2019-04-27gnu: python-nbxmpp: Update to 0.6.10....* gnu/packages/messaging.scm (python-nbxmpp): Update to 0.6.10. Clément Lassieur 2019-04-15gnu: toxic: Update to 0.8.3....* gnu/packages/messaging.scm (toxic): Update to 0.8.3. Tobias Geerinckx-Rice 2019-04-15gnu: toxic: Don't use unstable tarball....* gnu/packages/messaging.scm (toxic)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-04-11gnu: hangups: Update to 0.4.9....* gnu/packages/messaging.scm (hangups): Update to 0.4.9. [native-inputs]: Add python-httpretty and python-pytest. Tobias Geerinckx-Rice 2019-03-31gnu: znc: Update to 1.7.3....* gnu/packages/messaging.scm (znc): Update to 1.7.3. Tobias Geerinckx-Rice 2019-03-18gnu: bitlbee-discord: Update to 0.4.2....* gnu/packages/messaging.scm (bitlbee-discord): Update to 0.4.2. Tobias Geerinckx-Rice 2019-03-18gnu: bitlbee-discord: Don't use unstable tarball....* gnu/packages/messaging.scm (bitlbee-discord)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-03-18gnu: ngircd: Update to 25....* gnu/packages/messaging.scm (ngircd): Update to 25. Tobias Geerinckx-Rice 2019-03-18Correct name and email address for ng0....* .mailmap, Makefile.am, doc/guix.de.texi, doc/guix.fr.texi, doc/guix.texi, etc/completion/fish/guix.fish, gnu/packages/accessibility.scm, gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/autotools.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/cinnamon.scm, gnu/packages/compression.scm, gnu/packages/crypto.scm, gnu/packages/databases.scm, gnu/packages/django.scm, gnu/packages/dns.scm, gnu/packages/elixir.scm, gnu/packages/emacs-xyz.scm, gnu/packages/emacs.scm, gnu/packages/enlightenment.scm, gnu/packages/erlang.scm, gnu/packages/fonts.scm, gnu/packages/fontutils.scm, gnu/packages/forth.scm, gnu/packages/fvwm.scm, gnu/packages/games.scm, gnu/packages/gl.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/gtk.scm, gnu/packages/guile-wm.scm,gnu/packages/guile-xyz.scm, gnu/packages/haskell-check.scm, gnu/packages/haskell-crypto.scm, gnu/packages/haskell.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/irc.scm, gnu/packages/language.scm, gnu/packages/libcanberra.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lolcode.scm, gnu/packages/lxde.scm, gnu/packages/lxqt.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/mate.scm, gnu/packages/maths.scm, gnu/packages/mc.scm, gnu/packages/messaging.scm, gnu/packages/music.scm, gnu/packages/ncurses.scm, gnu/packages/networking.scm, gnu/packages/nickle.scm, gnu/packages/openbox.scm, gnu/packages/pdf.scm, gnu/packages/perl-check.scm, gnu/packages/perl.scm, gnu/packages/python-compression.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/ssh.scm, gnu/packages/suckless.scm, gnu/packages/tbb.scm, gnu/packages/telephony.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/web.scm, gnu/packages/wm.scm, gnu/packages/xdisorg.scm, gnu/packages/xfce.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/services/certbot.scm, gnu/services/desktop.scm, gnu/services/version-control.scm, gnu/services/web.scm, guix/import/hackage.scm, guix/licenses.scm: Correct name and email address for ng0. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> ng0 2019-03-17gnu: gajim-omemo: Update to 2.6.28....* gnu/packages/messaging.scm (gajim-omemo): Update to 2.6.28. Rutger Helling