aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pure)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages llvm)
  #:use-module (gnu packages multiprecision))

(define-public pure
  (package
    (name "pure")
    (version "0.68")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://github.com/agraef/pure-lang/releases/"
                           "download/pure-" version "/"
                           "pure-" version ".tar.gz"))
       (sha256
        (base32
         "0px6x5ivcdbbp2pz5n1r1cwg1syadklhjw8piqhl63n91i4r7iyb"))))
    (build-system gnu-build-system)
    (arguments
     `(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
                                         (assoc-ref %outputs "out")
                                         "/lib"))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-llvm-lookup
           (lambda _
             (substitute* "configure"
               (("-lLLVM-[$][{]llvm_version[}]")
                "`$LLVMCONF --libs`"))
             #t)))))
    (inputs
     (list gmp llvm-3.5 mpfr))
    (home-page "https://agraef.github.io/pure-lang/")
    (synopsis "Programming Language")
    (description "@code{pure} is a programming language based on term
rewriting.  It offers equational definitions with pattern matching,
full symbolic rewriting capabilities, dynamic typing, eager and lazy
evaluation, lexical closures, built-in list and matrix support and
a C interface.")
    (license license:gpl3+)))
d934bb31339ad1c9aaa201ec837cb743'>gnu: inkscape: Add inkscape-1.0....* gnu/packages/inkscape.scm (inkscape-1.0): New variable. * gnu/packages/gtk.scm (at-spi2-atk): Add a TODO comment. Maxim Cournoyer 2020-02-10gnu: inkscape: Remove obsolete workaround....* gnu/packages/inkscape.scm (inkscape)[arguments]: Remove phase "dont-use-system-includes". Marius Bakke 2020-01-14gnu: poppler: Update to 0.84.0....* gnu/packages/pdf.scm (poppler): Update to 0.84.0. * gnu/packages/inkscape.scm (inkscape)[arguments]: Add phase 'adjust-for-new-poppler'. Marius Bakke 2019-06-15gnu: poppler: Update to 0.77.0....* gnu/packages/patches/inkscape-poppler-0.76.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/inkscape.scm (inkscape)[source](patches): New field. * gnu/packages/patches/texlive-bin-luatex-poppler-compat.patch: Add two new hunks. * gnu/packages/pdf.scm (poppler): Update to 0.77.0. * gnu/packages/tex.scm (texlive-bin)[source]: Update Arch patches. [arguments]: Adjust accordingly. * gnu/packages/scribus.scm (scribus)[source](patches): Add two new origins. Marius Bakke 2019-02-09gnu: inkscape: Fix FTBFS with GCC >= 6....* gnu/packages/inkscape.scm (inkscape)[arguments]: Add phase 'dont-use-system-includes. Marius Bakke 2019-01-18gnu: Inkscape: Update to 0.92.4....* gnu/packages/inkscape.scm (inkscape): Update to 0.92.4. [source]: Remove obsolete patches. Leo Famulari 2018-08-10gnu: inkscape: Add poppler compatibility patch....* gnu/packages/inkscape.scm (inkscape)[source]: Add second poppler compatibility patch. Ricardo Wurmus 2018-06-29gnu: inkscape: Fix build with poppler....* gnu/packages/inkscape.scm (inkscape)[source]: Add upstream patch to fix incompatibility with latest version of poppler. Ricardo Wurmus 2018-05-15gnu: inkscape: Disable "icon-theme.cache" generation....* gnu/packages/inkscape.scm (inkscape)[arguments]<#:make-flags>: Delete. <#:phases>[patch-icon-cache-generator]: Add phase. Danny Milosavljevic 2018-03-17gnu: inkscape: Build with potrace support....From Inkscape 0.92, potrace is required for the Paintbucket and Trace Bitmap tools. * gnu/packages/inkscape.scm (inkscape)[inputs]: Add potrace. Arun Isaac 2018-03-14gnu: inkscape: Update to 0.92.3....* gnu/packages/inkscape.scm (inkscape): Update to 0.92.3. [source]: Remove patch. Tobias Geerinckx-Rice 2018-03-04gnu: inkscape: Disable duplicate icon cache generation....* gnu/packages/inkscape.scm (inkscape): Disable duplicate icon cache generation. Danny Milosavljevic 2018-01-11gnu: inkscape: Use HTTPS for home page....* gnu/packages/inkscape.scm (inkscape)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2018-01-11gnu: inkscape: Update to 0.92.2....* gnu/packages/inkscape.scm (inkscape): Update to 0.92.2. Tobias Geerinckx-Rice 2017-10-05gnu: inkscape: Fix FTBFS with Poppler >= 0.58....* gnu/packages/inkscape.scm (inkscape)[source]: Add upstream patch. Marius Bakke 2017-02-17gnu: inkscape: Update to 0.92.1....* gnu/packages/inkscape.scm (inkscape): Update to 0.92.1. Leo Famulari