aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pure)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages llvm)
  #:use-module (gnu packages multiprecision))

(define-public pure
  (package
    (name "pure")
    (version "0.68")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://github.com/agraef/pure-lang/releases/"
                           "download/pure-" version "/"
                           "pure-" version ".tar.gz"))
       (sha256
        (base32
         "0px6x5ivcdbbp2pz5n1r1cwg1syadklhjw8piqhl63n91i4r7iyb"))))
    (build-system gnu-build-system)
    (arguments
     `(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
                                         (assoc-ref %outputs "out")
                                         "/lib"))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-llvm-lookup
           (lambda _
             (substitute* "configure"
               (("-lLLVM-[$][{]llvm_version[}]")
                "`$LLVMCONF --libs`"))
             #t)))))
    (inputs
     (list gmp llvm-3.5 mpfr))
    (home-page "https://agraef.github.io/pure-lang/")
    (synopsis "Pure programming Language")
    (description "@code{pure} is a programming language based on term
rewriting.  It offers equational definitions with pattern matching,
full symbolic rewriting capabilities, dynamic typing, eager and lazy
evaluation, lexical closures, built-in list and matrix support and
a C interface.")
    (license license:gpl3+)))
2021-01-10gnu: Updated liferea to 1.13.4....* gnu/packages/syndiction.scm (liferea): Updated to 1.13.4. [source]: Switched to git-download. [native-inputs]: Added autotools, automake, libtool. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> raingloom 2021-01-03gnu: newsboat: Update to 2.22....* gnu/packages/syndication.scm (newsboat): Update to 2.22. [arguments]: Remove rust-gettext-sys-0.19, rust-lazy-static-1, rust-nom-5, rust-xdg-2.2 from cargo-inputs. Add rust-cxx-0.5, rust-cxx-build-0.5, rust-nom-6. Efraim Flashner 2020-10-18gnu: newsboat-2.13: Build with json-c-0.13....* gnu/packages/syndication.scm (newsboat-2.13)[inputs]: Replace json-c with json-c@.013. Efraim Flashner 2020-10-13gnu: newsboat: Update to 2.21....* gnu/packages/syndication.scm (newsboat): Update to 2.21. [source]: Remove snippet. [inputs]: Replace json-c-0.13 with json-c. [arguments]: In cargo-inputs replace rust-gettext-rs-0.4 with 0.5, rust-rand-0.6 with 0.7. Remove rust-dirs-2.0, rust-libz-1, rust-percent-encoding-2, rust-smallvec-0.6. Add rust-lazy-static-1. Add new phase to patch the source slightly. Efraim Flashner 2020-10-12gnu: rust-percent-encoding-2.1: Remove minor version from variable name....* gnu/packages/crates-io.scm (rust-percent-encoding-2.1): Rename to rust-percent-encoding-2. Arun Isaac 2020-10-12gnu: rust-url-2.1: Remove minor version from variable name....* gnu/packages/crates-io.scm (rust-url-2.1): Rename to rust-url-2. Arun Isaac 2020-09-30gnu: newsboat: Fix inputs....This is a follow-up to 51b46fa28cd31cf1cc973ef6ccd05fbef3c4b39d. * gnu/packages/syndication.scm (newsboat)[arguments]: Replace rust-once-cell-1.2 with rust-once-cell-1. Efraim Flashner 2020-09-08gnu: liferea: Update to 1.12.9....* gnu/packages/syndication.scm (liferea): Update to 1.12.9. Fix indentation. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vinicius Monego 2020-08-31gnu: rust-libz-sys-1.0: Rename rust-libz-sys-1....* gnu/packages/crates-io.scm (rust-libz-sys-1.0): Rename rust-libz-sys-1. (rust-curl-sys-0.4, rust-flate2-1.0, rust-freetype-sys-0.9, rust-libgit2-sys-0.10, rust-libgit2-sys-0.7, rust-libssh2-sys-0.2) [arguments]: Adjust accordingly. * gnu/packages/syndication.scm (newsboat)[arguments]: Same. Efraim Flashner