aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pumpio)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages aspell)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages web))

(define-public pumpa
  (package
    (name "pumpa")
    (version "0.9.3")
    (source (origin
              (method git-fetch) ; no source tarballs
              (uri (git-reference
                    (url "https://source.pumpa.branchable.com/")
                    (commit (string-append "v" version))))
              (sha256
               (base32
                "14072vis539zjgryjr5a77j2cprxii5znyg3p01qbb11lijk9nj7"))
              (file-name (string-append name "-" version "-checkout"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (substitute* "src/util.cpp"
               (("buffio\\.h") "tidybuffio.h"))
             ;; Fix dependency tests.
             (substitute* "pumpa.pro"
               (("/usr/include/tidy\\.h")
                (search-input-file inputs "/include/tidy.h"))
               (("/usr/include/aspell.h")
                (search-input-file inputs "/include/aspell.h")))
             ;; Run qmake with proper installation prefix.
             (let ((prefix (string-append "PREFIX="
                                          (assoc-ref outputs "out"))))
               (invoke "qmake" prefix))
             #t)))))
    (inputs
     (list aspell qtbase-5 tidy-html))
    (synopsis "Qt-based pump.io client")
    (description "Pumpa is a simple pump.io client written in C++ and Qt.")
    (home-page "https://pumpa.branchable.com/")
    (license gpl3+)))
-wasysym, texlive-fonts-stmryrd with texlive-stmryrd. Efraim Flashner 2021-09-13gnu: Add docbook2x....* gnu/packages/docbook.scm (docbook2x): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andrew Whatson 2021-09-13gnu: Prefix licenses in docbook module....This prevents conflicts between expat package and expat license. * gnu/packages/docbook.scm (docbook-xml-5): Prefix license variable. (docbook-xsl): Likewise. (docbook-dsssl): Likewise. (docbook-dsssl-doc): Likewise. (docbook-sgml): Likewise. (iso-8879-entities): Likewise. (dblatex): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andrew Whatson 2021-06-06gnu: dblatex: Remove unused TeX inputs....* gnu/packages/docbook.scm (dblatex)[inputs]: Remove TEXLIVE-LATEX-EEPIC, TEXLIVE-LATEX-ESO-PIC, TEXLIVE-LATEX-OBERDIEK, TEXLIVE-LATEX-URL, and TEXLIVE-FONTS-EC from updmap.cfg. Marius Bakke 2021-06-06gnu: dblatex: Update to 0.3.12....* gnu/packages/docbook.scm (dblatex): Update to 0.3.12. [source](uri): Adjust file name. [inputs]: Add TEXLIVE-LATEX-BOOKMARK and TEXLIVE-LATEX-REFCOUNT. [arguments]: Remove #:python. Marius Bakke 2021-06-06gnu: TeX Live: Update to 2020.0....* guix/build-system/texlive.scm (%texlive-tag): Set to 2020.0. (%texlive-revision): Set to 54632. * gnu/packages/tex.scm (texlive-extra-src, texlive-texmf-src, texlive-bin, texlive-texmf, texlive): Update to 20200406. (texlive-bin)[source](patches): Remove. [arguments]: Adjust poppler compatibility phase for new upstream patches. * gnu/packages/tex.scm (hyph-utf8-scripts, texlive-docstrip, texlive-unicode-data texlive-hyphen-base, texlive-dvips, texlive-metafont-base, texlive-fontinst, texlive-fontname, texlive-tex-plain, texlive-hyphen-bulgarian, texlive-hyphen-chinese, texlive-hyphen-hungarian, texlive-hyphen-latin, texlive-hyphen-sanskrit, texlive-hyphen-spanish, texlive-hyph-utf8, texlive-kpathsea, texlive-latexconfig, texlive-latex-base, texlive-union, texlive-latex-filecontents, texlive-latex-fancyvrb, texlive-graphics-def, texlive-latex-graphics, texlive-latex-oberdiek, texlive-latex-tools, texlive-latex-l3kernel, texlive-latex-l3packages, texlive-latex-fontspec, texlive-latex-amsmath, texlive-latex-babel, texlive-latex-draftwatermark, texlive-etoolbox, texlive-latex-geometry, texlive-latex-polyglossia, texlive-latex-supertabular, texlive-tex-texinfo, texlive-latex-appendix, texlive-latex-colortbl, texlive-latex-listings, texlive-inconsolata, texlive-latex-enumitem, texlive-latex-multirow, texlive-latex-overpic, texlive-latex-parskip, texlive-latex-pdfpages, texlive-libertine, texlive-latex-titlesec, texlive-metapost, texlive-latex-acmart, texlive-latex-wasysym, texlive-latex-preview, texlive-latex-acronym, texlive-pdftex, texlive-latex-media9, texlive-latex-ocgx2, texlive-latex-ms, texlive-generic-ulem, texlive-latex-pgf, texlive-latex-koma-script, texlive-generic-listofitems, texlive-bibtex, texlive-context-base, texlive-beamer, texlive-pstricks, texlive-marginnote, texlive-iftex, texlive-tools, texlive-siunitx, texlive-booktabs, texlive-csquotes, texlive-biblatex, texlive-microtype, texlive-caption, texlive-ydoc, texlive-courier, texlive-hyperref, texlive-fontspec, texlive-l3build, texlive-luaotfload, texlive-babel, texlive-tipa, texlive-jknappen, texlive-wasy, texlive-context, texlive-cabin, texlive-fourier, texlive-mweights, texlive-newtx, texlive-xcharter, texlive-tcolorbox): Update hashes. (texlive-hyphen-bulgarian): Don't include removed files. (texlive-hyphen-hungarian, texlive-hyphen-sanskrit): Adjust for directory rename. (texlive-hyphen-chinese, texlive-hyphen-latin): Add more files. (texlive-hyphen-macedonian): New public variable. (texlive-metafont-base)[source]: Switch to SVN-MULTI-FETCH. [arguments]: Adjust for extra source files. (texlive-latex-base)[arguments]: Disable more formats. [propagated-inputs]: Add TEXLIVE-HYPHEN-MACEDONIAN. (texlive-fontinst): Don't include "scripts/texlive/fontinst.sh". (texlive-generic-iftex): New public variable. (texlive-iftex, texlive-generic-ifxetex): Deprecate in favor of TEXLIVE-GENERIC-IFTEX. (texlive-latex-oberdiek)[propagated-inputs]: Change from TEXLIVE-GENERIC-IFXETEX to TEXLIVE-GENERIC-IFTEX. (texlive-latex-xkeyval)[native-inputs]: Likewise. (texlive-default-updmap.cfg): Remove variable. * gnu/packages/patches/texlive-bin-poppler-0.83.patch, gnu/packages/patches/texlive-bin-poppler-0.86.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Marius Bakke 2021-06-05gnu: dblatex: Use patched texlive-amsfonts....* gnu/packages/docbook.scm (dblatex)[inputs]: Use texlive-amsfonts/patched. Ricardo Wurmus 2021-04-16Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: gnu/local.mk gnu/packages/boost.scm gnu/packages/chez.scm gnu/packages/compression.scm gnu/packages/crates-io.scm gnu/packages/docbook.scm gnu/packages/engineering.scm gnu/packages/gcc.scm gnu/packages/gl.scm gnu/packages/gtk.scm gnu/packages/nettle.scm gnu/packages/python-check.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/rust.scm gnu/packages/sqlite.scm guix/build-system/node.scm Efraim Flashner 2021-03-30gnu: docbook-xsl: Move 'use-modules' form to the top level....* gnu/packages/docbook.scm (docbook-xsl)[arguments]: Move 'use-modules' to the top level. Ludovic Courtès 2021-03-27gnu: dblatex: Add 'dblatex/stable' variant....* gnu/packages/docbook.scm (dblatex/stable): New variable. Mark H Weaver 2021-03-24Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2021-03-06gnu: Fix input typoes....* gnu/packages/crates-io.scm (rust-nettle-sys-2)[inputs]: Move ‘,’ to its operand. * gnu/packages/docbook.scm (docbook-dsssl)[native-inputs]: Likewise. (docbook-dsssl-doc)[native-inputs]: Likewise. * gnu/packages/emacs-xyz.scm (emacs-helm-slack)[propagated-inputs]: Likewise. * gnu/packages/kde-multimedia.scm (audiocd-kio)[inputs]: Likewise. * gnu/packages/kde-pim.scm (akonadi-mime, kalarmcal, kcalendarsupport) (keventviews, kmailtransport, kpimtextedit)[inputs]: Likewise. * gnu/packages/mpd.scm (cantata)[inputs]: Likewise. * gnu/packages/raspberry-pi.scm (bcm2835): Likewise. * gnu/packages/samba.scm (samba)[native-inputs]: Likewise. * gnu/packages/xdisorg.scm (dex)[inputs]: Likewise. Tobias Geerinckx-Rice 2021-01-29gnu: Replace all uses of texlive-union by texlive-updmap.cfg....* doc/build.scm (pdf-manual) Replace texlive-union by texlive-updmap.cfg. * gnu/packages/algebra.scm (pari-gp): Likewise. * gnu/packages/bioinformatics.scm (discrover, velvet): Likewise. * gnu/packages/chez.scm (chez-scheme, chez-web, chez-sockets): Likewise. * gnu/packages/docbook.scm (dblatex): Likewise. * gnu/packages/emacs-xyz.scm (emacs-auctex): Likewise. * gnu/packages/engineering.scm (fastcap): Likewise. * gnu/packages/guile-xyz.scm (emacsy, guile-cv): Likewise. * gnu/packages/lisp.scm (sbcl): Likewise. * gnu/packages/maths.scm (octave, hypre): Likewise. * gnu/packages/music.scm (lilypond): Likewise. * gnu/packages/plotutils.scm (asymptote): Likewise. * gnu/packages/python-xyz.scm (python-numpy-documentation) (python-matplotlib-documentation, python-ipython-documentation) (python-pypandoc): Likewise. * gnu/packages/radio.scm (gnuradio, libosmo-dsp): Likewise. * gnu/packages/scheme.scm (mit-scheme): Likewise. * gnu/packages/statistics.scm (r-with-tests): Likewise. * gnu/packages/tex.scm (simple-texlive-package) (texlive-xmltex, texlive-tiny, texlive-jadetex, teximpatient, lyx): Likewise. Maxim Cournoyer 2021-01-14gnu: Add docbook-sgml-3.1....* gnu/packages/docbook.scm (docbook-sgml-3.1): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-dsssl....* gnu/packages/docbook.scm (docbook-dsssl): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-sgml....* gnu/packages/docbook.scm (docbook-sgml): New variable. Maxim Cournoyer 2021-01-14gnu: Add iso-8879-entities....* gnu/packages/docbook.scm (iso-8879-entities): New private variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-utils....* gnu/packages/docbook.scm (docbook-utils): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-sgml-3.1....* gnu/packages/docbook.scm (docbook-sgml-3.1): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-dsssl....* gnu/packages/docbook.scm (docbook-dsssl): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-sgml....* gnu/packages/docbook.scm (docbook-sgml): New variable. Maxim Cournoyer 2021-01-14gnu: Add iso-8879-entities....* gnu/packages/docbook.scm (iso-8879-entities): New private variable. Maxim Cournoyer 2020-11-29Merge remote-tracking branch 'origin/master' into core-updatesChristopher Baines 2020-11-09gnu: docbook: Update source URI....* gnu/packages/docbook.scm (docbook-xml-5)[source]: Update to new source URI. (docbook-xml, docbook-xml-4.4, docbook-xml-4.3, docbook-xml-4.2, docbook-xml-4.1.2)[source]: Same. Efraim Flashner 2020-06-22Merge branch 'master' into core-updatesJakub Kądziołka 2020-06-14gnu: docbook: Add 5.0.1....* gnu/packages/docbook.scm (docbook-xml-5): New public variable. (docbook-xml): Inherit from it. While at it, remove trailing whitespace. Marius Bakke 2020-06-14gnu: docbook-xsl: Update to 1.79.2....* gnu/packages/patches/docbook-xsl-support-old-url.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch: Adjust URL and context. * gnu/packages/docbook.scm (docbook-xsl): Update to 1.79.2. [source](uri): Adjust for new download location. Marius Bakke