aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pumpio)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages aspell)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages web))

(define-public pumpa
  (package
    (name "pumpa")
    (version "0.9.3")
    (source (origin
              (method git-fetch) ; no source tarballs
              (uri (git-reference
                    (url "https://source.pumpa.branchable.com/")
                    (commit (string-append "v" version))))
              (sha256
               (base32
                "14072vis539zjgryjr5a77j2cprxii5znyg3p01qbb11lijk9nj7"))
              (file-name (string-append name "-" version "-checkout"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (substitute* "src/util.cpp"
               (("buffio\\.h") "tidybuffio.h"))
             ;; Fix dependency tests.
             (substitute* "pumpa.pro"
               (("/usr/include/tidy\\.h")
                (search-input-file inputs "/include/tidy.h"))
               (("/usr/include/aspell.h")
                (search-input-file inputs "/include/aspell.h")))
             ;; Run qmake with proper installation prefix.
             (let ((prefix (string-append "PREFIX="
                                          (assoc-ref outputs "out"))))
               (invoke "qmake" prefix))
             #t)))))
    (inputs
     (list aspell qtbase-5 tidy-html))
    (synopsis "Qt-based pump.io client")
    (description "Pumpa is a simple pump.io client written in C++ and Qt.")
    (home-page "https://pumpa.branchable.com/")
    (license gpl3+)))
ref='/guix/commit/gnu/system/vm.scm?id=56f9d442e0b5624130042f69f33ea5bd7e970798'>vm: Use a deterministic file system UUID in shared-store VMs....Ludovic Courtès 2018-03-24system: Add "guix system docker-image" command....Chris Marusich 2018-03-24gnu: When building in a VM, share a temporary directory....Chris Marusich 2018-03-18vm: Display a backtrace upon error by default....Ludovic Courtès 2018-03-08vm: Use 9p mount tags below 32 chars....Ludovic Courtès 2018-03-03linux-initrd: Add virtio modules to '%base-initrd-modules'....Ludovic Courtès 2018-03-03vm: Add missing modules to the 'expression->derivation-in-linux-vm' initrd....Ludovic Courtès 2018-01-19gnu: Consistently Write ‘file system(s)’....Tobias Geerinckx-Rice 2018-01-07vm: 'vm-image' images refer to the root file system by UUID....Ludovic Courtès 2017-12-18vm: Pass the host's /dev/urandom to the guest at /dev/hwrng....Leo Famulari 2017-12-17gnu: system: vm: Use loose cache for 9p file system....Christopher Baines 2017-12-15bootloader: Factorize write-file-on-device....Mathieu Othacehe 2017-12-15vm: Adapt qemu command to ARM....Mathieu Othacehe 2017-12-04bootloader: extlinux: Stop using dd binary....Mathieu Othacehe 2017-12-02system: vm: Fix typo in comment....Mathieu Othacehe 2017-12-01system: vm: Do not add EFI partition on ARM system....Mathieu Othacehe 2017-11-30vm: Filter out file systems that refer to UUIDs or labels....Ludovic Courtès 2017-11-26vm: Use os-defined initrd intead of base-initrd....Mathieu Othacehe 2017-11-06system: vm: Use 2^32 - 1 as hash size....Mathieu Othacehe 2017-10-19vm: Always use GRUB/i386....Ludovic Courtès 2017-10-04vm: Add disk-image-size to <virtual-machine>....Christopher Baines 2017-10-04vm: Add a minimum root size....Christopher Baines