aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pth)
  #:use-module (gnu packages autotools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public pth
  (package
    (name "pth")
    (version "2.0.7")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/pth/pth-" version
                          ".tar.gz"))
      (sha256
       (base32
        "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'update-config-scripts
           (lambda* (#:key inputs native-inputs #:allow-other-keys)
             ;; Replace outdated config.guess and config.sub.
             (for-each (lambda (file)
                         (install-file
                          (search-input-file
                           (or native-inputs inputs)
                           (string-append "/bin/" file)) "."))
                       '("config.guess" "config.sub")))))))
    (native-inputs
     (list config))
    (home-page "https://www.gnu.org/software/pth/")
    (synopsis "Portable thread library")
    (description
     "GNU Pth is a portable library providing non-preemptive, priority-based
scheduling for multiple execution threads.  Each thread has its own
program-counter, run-time stack, signal mask and errno variable.  Threads are
scheduled in a cooperative way, rather than in the standard preemptive way,
such that they are managed according to priority and events.  However, Pth
also features emulation of POSIX.1c threads (\"pthreads\") for backwards
compatibility.")
    (license lgpl2.1+)))
b4402521c8'>gnu: autorandr: Fix typo in synopsis....Tobias Geerinckx-Rice 2019-03-18Correct name and email address for ng0....ng0 2019-03-15gnu: sxhkd: Update to 0.6.0....Tobias Geerinckx-Rice 2019-03-10Merge branch 'master' into stagingMarius Bakke 2019-03-07gnu: Add autorandr....Pierre Neidhardt 2019-03-01Merge branch 'master' into stagingMarius Bakke 2019-02-27gnu: libwacom: Update to 0.32....Tobias Geerinckx-Rice 2019-02-27gnu: libwacom: Don't use NAME in source URI....Tobias Geerinckx-Rice 2019-02-23gnu: libxkbcommon: Update to 0.8.4....Marius Bakke 2019-02-23gnu: libxkbcommon: Don't use NAME in source URI....Marius Bakke 2019-02-20Merge branch 'master' into stagingMarius Bakke 2019-02-18gnu: scrot: Update to 0.9....Tobias Geerinckx-Rice 2019-02-15gnu: libdrm: Update to 2.4.97....Marius Bakke 2019-02-14Merge branch 'master' into stagingMarius Bakke 2019-02-11gnu: pixman: Update source URI....Marius Bakke 2019-02-10gnu: libxkbcommon: Update to 0.8.3....Marius Bakke 2019-02-09gnu: Add xbanish....Marius Bakke 2019-01-20Merge branch 'master' into stagingLudovic Courtès 2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus 2019-01-13Merge branch 'master' into stagingMarius Bakke 2019-01-13gnu: rofi: Update to 1.5.2....Marius Bakke 2019-01-13gnu: xscreensaver: Update to 5.42....Marius Bakke 2019-01-10gnu: sct: Correct license....Nam Nguyen 2019-01-09Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner 2019-01-03gnu: xdisorg.scm: Add missing import....Efraim Flashner 2019-01-03gnu: Add wl-clipboard....Rutger Helling 2018-12-23gnu: libdrm: Enable etnaviv api for armhf and aarch64....Efraim Flashner 2018-12-22Merge branch 'master' into stagingMarius Bakke 2018-12-18gnu: Add sct....Nam Nguyen 2018-12-12gnu: pixman: Update to 0.36.0....Marius Bakke 2018-12-03Merge branch 'master' into stagingMarius Bakke 2018-12-03Merge branch 'core-updates'Ludovic Courtès