aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pth)
  #:use-module (gnu packages autotools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public pth
  (package
    (name "pth")
    (version "2.0.7")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/pth/pth-" version
                          ".tar.gz"))
      (sha256
       (base32
        "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'update-config-scripts
           (lambda* (#:key inputs native-inputs #:allow-other-keys)
             ;; Replace outdated config.guess and config.sub.
             (for-each (lambda (file)
                         (install-file
                          (search-input-file
                           (or native-inputs inputs)
                           (string-append "/bin/" file)) "."))
                       '("config.guess" "config.sub")))))))
    (native-inputs
     (list config))
    (home-page "https://www.gnu.org/software/pth/")
    (synopsis "Portable thread library")
    (description
     "GNU Pth is a portable library providing non-preemptive, priority-based
scheduling for multiple execution threads.  Each thread has its own
program-counter, run-time stack, signal mask and errno variable.  Threads are
scheduled in a cooperative way, rather than in the standard preemptive way,
such that they are managed according to priority and events.  However, Pth
also features emulation of POSIX.1c threads (\"pthreads\") for backwards
compatibility.")
    (license lgpl2.1+)))
/packages/make-bootstrap.scm: Likewise. * gnu/packages/messaging.scm: Likewise. * gnu/packages/music.scm: Likewise. * gnu/packages/networking.scm: Likewise. * gnu/packages/ocaml.scm: Likewise. * gnu/packages/perl.scm: Likewise. * gnu/packages/python.scm: Likewise. * gnu/packages/python-web.scm: Likewise. * gnu/packages/qt.scm: Likewise. * gnu/packages/ratpoison.scm: Likewise. * gnu/packages/sdl.scm: Likewise. * gnu/packages/sml.scm: Likewise. * gnu/packages/terminals.scm: Likewise. * gnu/packages/text-editors.scm: Likewise. * gnu/packages/video.scm: Likewise. * gnu/packages/virtualization.scm: Likewise. * gnu/packages/vulkan.scm: Likewise. * gnu/packages/wget.scm: Likewise. * gnu/packages/wine.scm: Likewise. * gnu/packages/wm.scm: Likewise. * gnu/packages/xdisorg.scm: Likewise. * gnu/packages/xml.scm: Likewise. * gnu/packages/xorg.scm: Likewise. Tobias Geerinckx-Rice 2018-03-17gnu: shaderc: Use more standard keys....* gnu/packages/vulkan.scm (shaderc)[arguments]: Move cmake options from the raw INVOKE call to #:build-type and #:configure-flags. Adjust the ‘configure’ phase accordingly. Tobias Geerinckx-Rice 2018-03-17gnu: shaderc: Use standard versioning scheme....* gnu/packages/vulkan.scm (shaderc)[version]: Use GIT-VERSION with a ‘0.0.0’ prefix. Tobias Geerinckx-Rice 2018-03-17gnu: shaderc: Fix formatting....* gnu/packages/vulkan.scm (shaderc): Use conventional indentation. [native-inputs]: Move unquotes to their operands. Tobias Geerinckx-Rice 2018-03-08gnu: vulkan-icd-loader: Update to 1.1.70.0....* gnu/packages/vulkan.scm (vulkan-icd-loader): Update to 1.1.70.0. Rutger Helling 2018-02-23gnu: vulkan-icd-loader: Update to 1.0.68.0....* gnu/packages/vulkan.scm (vulkan-icd-loader): Update to 1.0.68.0. [arguments]: Add 'remove-spirv-tools-commit-id phase. Add "-DBUILD_LAYERS=OFF" configure-flag. Rutger Helling 2018-02-14gnu: Add shaderc....* gnu/packages/vulkan.scm (shaderc): New variable. Rutger Helling 2018-01-31gnu: glslang: Update to commit b5b08462442239e6537315ea1405b6afcd53043e....* gnu/packages/vulkan.scm (glslang): Update to commit b5b08462442239e6537315ea1405b6afcd53043e. Rutger Helling 2018-01-31gnu: spirv-tools: Update to commit 90862fe4b1c6763b32ce683d2d32c2f281f577cf....* gnu/packages/vulkan.scm (spirv-tools): Update to commit 90862fe4b1c6763b32ce683d2d32c2f281f577cf. Rutger Helling 2018-01-31gnu: spirv-headers: Update to commit 061097878467b8e040fbf153a837d844ef9f9f96....* gnu/packages/vulkan.scm (spirv-headers): Update to commit 061097878467b8e040fbf153a837d844ef9f9f96. Rutger Helling 2018-01-30gnu: vulkan-icd-loader: Update to 1.0.65.2....* gnu/packages/vulkan.scm (vulkan-icd-loader): Update to 1.0.65.2. Rutger Helling 2017-12-18gnu: vulkan: Add vulkan-icd-loader....* gnu/packages/vulkan.scm (vulkan-icd-loader): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Rutger Helling 2017-12-18gnu: vulkan: Add glslang....* gnu/packages/vulkan.scm (glslang): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Rutger Helling 2017-12-18gnu: vulkan: Add spirv-tools....* gnu/packages/vulkan.scm (spirv-tools): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Rutger Helling 2017-12-18gnu: vulkan: Add spirv-headers....* gnu/packages/vulkan.scm: Create file. (spirv-headers): New variable. * gnu/local.mk: Add vulkan.scm. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Rutger Helling