aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages printers)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system go)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages avahi)
  #:use-module (gnu packages golang-xyz)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages man)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages qt))

;; This is a module for packages related to printer-like devices, but not
;; related to CUPS.

(define-public ipp-usb
  (package
    (name "ipp-usb")
    (version "0.9.25")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/OpenPrinting/ipp-usb")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "003njvcxi0w97wrs52nm9b0f1d96624hjnv9ywsr1m7p6q7r08mg"))))
    (build-system go-build-system)
    (arguments
     (list
      ;; TODO: The project provides manpages and udev rules, review them and
      ;; install in the next update cycle.
      #:install-source? #f
      #:import-path "github.com/OpenPrinting/ipp-usb"))
    (inputs
     (list avahi libusb))
    (native-inputs
     (list go-github-com-openprinting-goipp
           pkg-config
           ronn))
    (home-page "https://github.com/OpenPrinting/ipp-usb")
    (synopsis "HTTP reverse proxy, backed by the IPP-over-USB connection")
    (description
     "ipp-usb implements an HTTP reverse proxy, backed by the IPP-over-USB
connection to the device. This is because IPP-over-USB implementations which
simply relay a TCP connection to USB do not work.")
    (license license:bsd-2)))

(define-public robocut
  (package
    (name "robocut")
    (version "1.0.11")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/Timmmm/robocut")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0dp9cssyik63yvkk35s51v94a873x751iqg93qzd8dpqkmz5z8gn"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (replace 'configure
            (lambda _
              (substitute* "Robocut.pro"
                (("/usr/") (string-append #$output "/")))
              (invoke "qmake" (string-append "PREFIX=" #$output)))))))
    (inputs
     (list libusb qtbase-5 qtsvg-5))
    (native-inputs
     (list pkg-config qtbase-5))
    (synopsis "Graphical program to drive plotting cutters")
    (description
     "Robocut is a simple graphical program that allows you to cut graphics
with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
    (home-page "http://robocut.org")
    (license license:gpl3+)))
id=cc51f567884b5483fcf499214d8a6f98edb3e8e3'>news: Add entry for stumpwm:lib removal....* etc/news.scm: Add entry. Change-Id: Iff23c3f1d251cd23b0227b09eb1f05614b132dfb Guillaume Le Vaillant 2024-06-17news: Fix commit hash....* etc/news.scm: Use a commit hash that actually exist. Change-Id: I7e633b4cdd7c4c9a4669c26c2939bf1995260035 Nicolas Goaziou 2024-06-17news: Add entry for removing linux-libre 6.8 ("end of life")....* etc/news.scm: Add entry for linux-libre 6.8 removal. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: I9f91c810d5be7ab790c82bfa16a43e4893c06920 Wilko Meyer 2024-05-01news: Add entry for ‘guix git authenticate’ changes....* etc/news.scm: Add entry. Change-Id: I661a0c0bfc373b87a70508ad9a735315c96ba4a5 Co-authored-by: Florian Pelz <pelzflorian@pelzflorian.de> Change-Id: Ibafef9d432df163948c4884279d4ce2579ed0312 Ludovic Courtès 2024-04-30news: Add entry for removing linux-libre 6.7 (EoL)....* etc/news.scm: Add entry for linux-libre 6.7 removal. Change-Id: I8fe3eb3f68023e85fcac7549c06d2cc26cd8e810 Signed-off-by: Leo Famulari <leo@famulari.name> Wilko Meyer 2024-04-23news: Update news and commit for nss-certs change....As discussed in <https://lists.gnu.org/archive/html/guix-devel/2024-04/msg00211.html>. * etc/news.scm: Update. Change-Id: Id893abe6642de3939f7993267075764e4bb5d820 Florian Pelz 2024-04-20news: Add 'de' translation....* etc/news.scm: Add German translation for nss-certs entry. Change-Id: I82343fdc81c370a2a11e0c7bce55e5914187861f Florian Pelz 2024-04-18news: Add entry for nss-certs being added to %base-packages....* etc/news.scm: New entry. * NEWS: Update news. Change-Id: I40e0b859f2af0bb0e652925a53d6447ea6fbacfb Maxim Cournoyer 2024-04-08news: Add entry for the linux-libre-lts 6.6 update....* etc/news.scm: Add entry. Change-Id: Ic57c76c300712e4a6053052611e6483b4d72f0c5 Signed-off-by: Leo Famulari <leo@famulari.name> Ahmad Draidi via Guix-patches via 2024-03-16Merge remote-tracking branch 'savannah/master' into gnome-team...Change-Id: I775274c2693536e2efa36c9abca4c54c5c458e26 Christopher Baines 2024-03-12news: Update commit for fixed-output derivation vulnerability....* etc/news.scm: Update. Change-Id: Ia34408882f8928a0fd05acc12d4edc66b3dcb3b7 Ludovic Courtès 2024-03-12news: Add 'de' translation....* etc/news.scm: Add German translation. Change-Id: Ia2a11f71cdee5ccbf2a7fbe176e713418771599e Florian Pelz 2024-03-12news: Give upgrade instructions for foreign distros....* etc/news.scm: Update entry. Change-Id: Ia7c326bc97042d92a8d499ee27dd41d15f1f0d29 Ludovic Courtès 2024-03-11news: Add entry for the daemon fixed-output derivation vulnerability....* etc/news.scm: Add entry. Change-Id: Ib3f9c22eda1e8b9075620ec01b4edf2f24cfcf93 Ludovic Courtès 2024-02-28news: Add entry for changes in GNOME 44 and its desktop service....* etc/news.scm: Add entry. Liliana Marie Prikler 2024-02-28news: Add entry for GDM defaulting to Wayland....* etc/news.scm: Add entry. Change-Id: Icddcf269ff59a7ee2a14680ed95a167758ecddaf Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vivien Kraus 2024-02-28news: Add entry for hwdb support in udev-service-type....* etc/news.scm: Add entry. Change-Id: I3c27b10eab501cca6ed0e32a1b30d92f212266b4 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Vivien Kraus 2024-01-22news: Add entry for removing linux-libre 4.14 (EoL)....* etc/news.scm: Add entry for linux-libre 4.14 removal and add my copyright header. Change-Id: I5c2418bc22a4ae2bba63c1cf77e66d2574766e01 Wilko Meyer 2024-01-13news: Fix 'de' translation....* etc/news.scm: Fix typo. Change-Id: I943fed38a444d1403cc5f979a7d6b9f52bedf5dd Florian Pelz 2024-01-09news: Add entry for the new '--max-layers=N' option....* etc/news.scm: Add entry. Change-Id: I286c04fd2cef820007606d1092ab45be4466fb19 Oleg Pykhalov 2023-10-03news: Add 'de' translation....* etc/news.scm: Add German translation of offloading entry. Florian Pelz 2023-10-03news: Fix typo....* etc/news.scm: Fix typo in the English text on offloading. Florian Pelz 2023-10-01news: Add entry for declarative offloading....* etc/news.scm: Add entry. Ludovic Courtès 2023-07-23news: Add entry about the removal of linux-libre 6.3....* etc/news.scm: Add entry. Leo Famulari 2023-07-23news: Add entry for the linux-libre 6.4 update....* etc/news.scm: Add entry. Leo Famulari