aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages presentation)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix build-system python)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages figlet)
  #:use-module (gnu packages games)
  #:use-module (gnu packages image)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz))

(define-public presentty
  (package
    (name "presentty")
    (version "0.2.1")
    (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "presentty" version))
        (sha256
         (base32
          "1qpy992hyg1amjl0acic3agj20spcpv5m0ncg1283mmxs8cs3xy9"))
        (patches
          (list
            (origin
              (method url-fetch)
              (uri "https://sources.debian.org/data/main/p/presentty/0.2.1-1/debian/patches/presentty-python3.patch")
              (sha256
               (base32
                "03d3ylh1z99g4dqj7aka60spagnwss9mbacd7jbpk1gazflnssz1")))))))
    (build-system python-build-system)
    (arguments
     `(#:tests? #f ; Test suite hasn't withstood the test of time.
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'loosen-requirements
           (lambda _
             ;; Remove version pinning.
             (substitute* "requirements.txt"
               (("pbr>=.*") "pbr"))))
         (replace 'wrap
           (lambda* (#:key python inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin/"))
                    (python (assoc-ref inputs "python")))
               (for-each
                 (lambda (program)
                   (wrap-program (string-append bin program)
                     `("PATH" ":" prefix (,(dirname (which "cowsay"))
                                          ,(dirname (which "figlet"))
                                          ,(dirname (which "jp2a"))))
                     `("GUIX_PYTHONPATH" prefix
                       ,(cons (string-append out "/lib/python"
                                             (python-version python)
                                             "/site-packages")
                              (search-path-as-string->list
                                (or (getenv "GUIX_PYTHONPATH") ""))))))
                 '("presentty" "presentty-console")))))
         ;; XXX: console import test fails to find palette.py from the lib?
         (delete 'sanity-check))))
    (inputs
     (list bash-minimal
           cowsay
           figlet
           jp2a
           python-docutils
           python-pillow-2.9
           python-six
           python-urwid))
    (native-inputs
     (list python-pbr python-pygments))
    (home-page "http://git.inaugust.com/cgit/presentty/")
    (synopsis "Console-based presentation system")
    (description "Presentty is a console-based presentation program where slides
are authored in reStructuredText.  Its features include, but are not limited to:
Cross-fade animations, progressive list display, panning transitions, syntax
highlighting, Cowsay and figlet integration, ANSI art, JPEG display.")
    (license license:gpl3+)))
lf 2023-12-06gnu: deluge: Update to 2.1.1....Dependency on nss-certs was added. Most torrents do require SSL in some shape or form, so it seems appropriate to add it by default. * gnu/packages/bittorrent.scm (deluge)[version]: Update to 2.1.1. [propagated-inputs]: Add nss-certs. [native-search-paths]: Set to allow locating the certificates. Change-Id: Ic6c79f24851d6917dc4e5b22b3bcb2f6b99e187a Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-12-06gnu: libtorrent-rasterbar: Update to 1.2.19....With the update, the execution of the test suite was overhauled a lot. Parallel tests were disabled, since the do not work well. Since faketime does cause some tests to hang, test_ssl was moved into a separate run. * gnu/packages/bittorrent.scm (libtorrent-rasterbar)[version]: Update to 1.2.19. [arguments]<#:parallel-tests?>: Disable. [arguments]<#:phases>: Move test_ssl into separate run under faketime. Do not run under tests under faketime. Anchor the regex for test exclusion. Set timeout of 600 seconds for each test. Change-Id: I7392cb3ce1a8815b26b3257498082761255535ee Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-11-22gnu: aria2: Unbundle wslay....* gnu/packages/bittorrent.scm (aria2)[source]: Add snippet to delete configure script and remove bundled dependency. Add a patch. [native-inputs]: Add autoconf, automake, gettext-minimal, libtool. [inputs]: Add wslay. * gnu/packages/patches/aria2-unbundle-wslay.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I92390a872454726ff9587518bb535d2105c44ef3 Efraim Flashner 2023-11-22gnu: aria2: Update to 1.37.0....* gnu/packages/bittorrent.scm (aria2): Update to 1.37.0. Change-Id: Iddaeabb59b774b61610722f485c8c773aaf60434 Efraim Flashner 2023-10-30gnu: transmission: Update to 4.0.4....* gnu/packages/bittorrent.scm (transmission): Update to 4.0.4. [synopsis]: Remove "marketing phrases". Change-Id: Ibecdf14198ba926eea66ff5ba29ec05fbd27fde2 Signed-off-by: Christopher Baines <mail@cbaines.net> Leo Famulari 2023-09-24gnu: qbittorrent-enhanced: Update to 4.5.5.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.5.5.10. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Hilton Chain via Guix-patches via 2023-09-24gnu: qbittorrent-nox: Rename to qbittorrent-no-x....* gnu/packages/bittorrent.scm (qbittorrent-no-x): New variable, renamed from… (qbittorrent-nox): …this package, now redefined as a DEPRECATED-PACKAGE. Tobias Geerinckx-Rice 2023-09-24gnu: qbittorrent: Update to 4.5.5....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.5. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Hilton Chain 2023-09-27gnu: transmission: Fix loading icons in pure environments....* gnu/packages/bittorrent.scm (transmission)[arguments]: Add a 'wrap-program' phase that sets GDK_PIXBUF_MODULE_FILE. Clément Lassieur 2023-09-26gnu: transmission: Restore HTML files in the default output....This fixes transmission-daemon. * gnu/packages/bittorrent.scm (transmission)[arguments]: remove "transmission" directory from the 'move-gui' procedure. Clément Lassieur 2023-07-18gnu: qbittorrent-enhanced: Update to 4.5.4.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.5.4.10. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hilton Chain 2023-07-11gnu: qbittorrent{,-nox}: Use qt-build-system....CMake is now upstream’s preferred build system. * gnu/packages/bittorrent.scm (qbittorrent)[build-system]: Use qt-build-system. [arguments]: Drop custom wrap phase. (Re-)enable tests. [inputs]: Remove input labels. Drop qtbase-5. [native-inputs]: Drop pkg-config. (qbittorrent-nox)[arguments]: Adjust configure-flags. Keep the wrap-qt phase since the non-GUI version is also a QT program. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-07-11gnu: qbittorrent: Update to 4.5.4....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.4. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-07-01gnu: Add qbittorrent-enhanced-nox....* gnu/packages/bittorrent.scm (qbittorrent-enhanced-nox): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Hilton Chain 2023-07-01gnu: Add qbittorrent-enhanced....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): New variable. Hilton Chain via Guix-patches via 2023-05-22gnu: tremc: Fix compatibility with Transmission 4.0....This version is not released upstream, but it does fix compatibility with Transmission 4.0 and works for me. * gnu/packages/bittorrent.scm: Update to 0.9.3-0.6c15e3f. Leo Famulari 2023-05-17gnu: Add qbittorrent-nox....* gnu/packages/bittorrent.scm (qbittorrent-nox): New variable. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz> Hilton Chain 2023-05-01gnu: Transmission: Update to 4.0.3....* gnu/packages/bittorrent.scm: Update to 4.0.3. [build-system]: Use cmake-build-system. [source]: Remove obsolete patch. [inputs]: Add gtkmm, glib:bin, and python. [arguments]: Run the test suite. Import the glib-or-gtk-build-system and wrap the 'gui' build output. Remove #:configure-flags. Adjust the 'move-gui' phase to upstream changes. * gnu/packages/patches/transmission-honor-localedir.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Leo Famulari 2023-04-30gnu: deluge: Use librsvg-for-system....* gnu/packages/bittorent.scm (deluge)[native-inputs]: Replace librsvg input logic with librsvg-for-system. Efraim Flashner 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-05gnu: qbittorrent: Update to 4.5.2....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.2. Signed-off-by: Leo Famulari <leo@famulari.name> Hilton Chain 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-11gnu: libtorrent-rasterbar: Update to 1.2.18....* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.2.18. Signed-off-by: Christopher Baines <mail@cbaines.net> Hilton Chain