aboutsummaryrefslogtreecommitdiff
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages presentation)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix build-system python)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages figlet)
  #:use-module (gnu packages games)
  #:use-module (gnu packages image)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz))

(define-public presentty
  (package
    (name "presentty")
    (version "0.2.1")
    (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "presentty" version))
        (sha256
         (base32
          "1qpy992hyg1amjl0acic3agj20spcpv5m0ncg1283mmxs8cs3xy9"))
        (patches
          (list
            (origin
              (method url-fetch)
              (uri "https://sources.debian.org/data/main/p/presentty/0.2.1-1/debian/patches/presentty-python3.patch")
              (sha256
               (base32
                "03d3ylh1z99g4dqj7aka60spagnwss9mbacd7jbpk1gazflnssz1")))))))
    (build-system python-build-system)
    (arguments
     `(#:tests? #f ; Test suite hasn't withstood the test of time.
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'loosen-requirements
           (lambda _
             ;; Remove version pinning.
             (substitute* "requirements.txt"
               (("pbr>=.*") "pbr"))))
         (replace 'wrap
           (lambda* (#:key python inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin/"))
                    (python (assoc-ref inputs "python")))
               (for-each
                 (lambda (program)
                   (wrap-program (string-append bin program)
                     `("PATH" ":" prefix (,(dirname (which "cowsay"))
                                          ,(dirname (which "figlet"))
                                          ,(dirname (which "jp2a"))))
                     `("GUIX_PYTHONPATH" prefix
                       ,(cons (string-append out "/lib/python"
                                             (python-version python)
                                             "/site-packages")
                              (search-path-as-string->list
                                (or (getenv "GUIX_PYTHONPATH") ""))))))
                 '("presentty" "presentty-console")))))
         ;; XXX: console import test fails to find palette.py from the lib?
         (delete 'sanity-check))))
    (inputs
     (list bash-minimal
           cowsay
           figlet
           jp2a
           python-docutils
           python-pillow-2.9
           python-six
           python-urwid))
    (native-inputs
     (list python-pbr python-pygments))
    (home-page "http://git.inaugust.com/cgit/presentty/")
    (synopsis "Console-based presentation system")
    (description "Presentty is a console-based presentation program where slides
are authored in reStructuredText.  Its features include, but are not limited to:
Cross-fade animations, progressive list display, panning transitions, syntax
highlighting, Cowsay and figlet integration, ANSI art, JPEG display.")
    (license license:gpl3+)))
ix/commit/gnu/packages/bittorrent.scm?id=dc64e7a1ac53d56675cc28135f11ec38a1de4c23'>gnu: aria2: Rewrite with gexps....* gnu/packages/bittorrent.scm (aria2)[arguments]: Rewrite with gexps. Efraim Flashner 2022-01-14gnu: aria2: Update to 1.36.0....* gnu/packages/bittorrent.scm (aria2): Update to 1.36.0. Efraim Flashner 2022-01-14gnu: aria2: Add release-monitoring-property....* gnu/packages/bittorrent.scm (aria2)[properties]: New field. Efraim Flashner 2022-01-06gnu: tremc: Fix execution with recent Python....* gnu/packages/bittorrent.scm (tremc)[source]: Add patch. * gnu/packages/patches/tremc-fix-decodestring.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Reported by gnoo in #guix Tobias Geerinckx-Rice 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-08gnu: libtorrent-rasterbar: Build with default cmake....* gnu/packages/bittorrent.scm (libtorrent-rasterbar)[arguments]: Remove cmake flag. Efraim Flashner 2021-11-23Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-22gnu: uget: Add -fcommon to CFLAGS....* gnu/packages/bittorrent.scm (uget)[arguments]: Add -fcommon to CFLAGS. Ricardo Wurmus 2021-11-22gnu: transmission-remote-gtk: Update to 1.4.2....* gnu/packages/bittorrent.scm (transmission-remote-gtk): Update to 1.4.2. [source]: Remove patch. * gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Ricardo Wurmus 2021-11-17gnu: libtorrent-rasterbar: Update to 1.2.14....* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.2.14. [source](uri): Adjust tag name. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Adjust accordingly. Override the check phase to fake the time for one test, and disable another. [native-inputs]: Add LIBFAKETIME. Marius Bakke 2021-08-16gnu: bittorrent: Disable tests....* gnu/packages/bittorrent.scm (bittorrent)[arguments]: Disable tests that are failing when using libevent 2.12 without internet connection. Mathieu Othacehe 2021-07-16gnu: Add transmission-remote-gtk....* gnu/packages/bittorrent.scm (transmission-remote-gtk): New variable. * gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Leo Famulari <leo@famulari.name> Justin Veilleux 2021-07-02guix: qt-build-system, qt-utils: Unify wrapping of qt-programs....Unify (guix qt-build-system wrap-all-programs) and (guix qt-utils wrap-qt-program), so both behave the same. The functions now reside in qt-utils to make them easily available for packages not using the qt-build-system. * guix/build/qt-build-system.scm (variables-for-wrapping, wrap-all-programs): Move from here ... * guix/build/qt-utils.scm (variables-for-wrapping, wrap-all-qt-programs): ... to here. Base the later on (wrap-qt-program*): New function, carved out from old wrap-all-programs. (wrap-qt-program): Base on wrap-qt-program*, change arguments in an incompatible way. * gnu/packages/bittorrent.scm (qbittorrent)[arguments]<phases>{wrap-qt}: Adjust to new interface of wrap-qt-program. * gnu/packages/finance.scm (electron-cash): Likewise. * gnu/packages/geo.scm (qgis): Likewise. * gnu/packages/password-utils.scm (qtpass): Likewise. * gnu/packages/video.scm (openshot): Likewise. * gnu/packages/web-browsers.scm (kristall): Likewise. Hartmut Goebel 2021-06-14gnu: Rename qtbase to qtbase-5....This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit. Maxim Cournoyer