aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2016, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages popt)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system cmake)
  #:use-module (guix licenses)
  #:use-module (gnu packages texinfo))

(define-public argtable
  (package
    (name "argtable")
    (version "2.13")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "mirror://sourceforge/argtable/argtable/"
                    "argtable-" version "/argtable"
                    (string-join (string-split version #\.) "-")
                    ".tar.gz"))
             (sha256
              (base32
               "1gyxf4bh9jp5gb3l6g5qy90zzcf3vcpk0irgwbv1lc6mrskyhxwg"))))
    (build-system gnu-build-system)
    (home-page "https://argtable.sourceforge.net/")
    (synopsis "Command line option parsing library")
    (description
     "Argtable is an ANSI C library for parsing GNU style command line
options.  It enables a program's command line syntax to be defined in the
source code as an array of argtable structs.  The command line is then parsed
according to that specification and the resulting values are returned in those
same structs where they are accessible to the main program.  Both tagged (-v,
--verbose, --foo=bar) and untagged arguments are supported, as are multiple
instances of each argument.  Syntax error handling is automatic and the library
also provides the means for generating a textual description of the command
line syntax.")
    (license lgpl2.0+)))

(define-public popt
  (package
    (name "popt")
    (version "1.18")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://ftp.rpm.org/popt/releases"
                                 "/popt-1.x/popt-" version ".tar.gz"))
             (sha256
              (base32
               "1lf5zlj5rbg6s4bww7hbhpca97prgprnarx978vcwa0bl81vqnai"))))
    (build-system gnu-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-before 'configure 'patch-test
           (lambda _
             (substitute* "tests/test-poptrc.in"
               (("/bin/echo") (which "echo")))
             (substitute* "tests/testit.sh"   ;don't expect old libtool names
               (("lt-test1") "test1"))
             #t)))))
    (home-page "https://rpm5.org/files/popt/")
    (synopsis "Command line option parsing library")
    (description
     "This is the popt(3) command line option parsing library.  While it is
similar to getopt(3), it contains a number of enhancements, including:

  - popt is fully reentrant;

  - popt can parse arbitrary argv[] style arrays while getopt(3) makes this
    quite difficult;

  - popt allows users to alias command line arguments;

  - popt provides convenience functions for parsing strings into argv[] style
    arrays.")
    (license x11)))

(define-public gflags
  (package
    (name "gflags")
    (version "2.2.2")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/gflags/gflags")
             (commit (string-append "v" version))))
       (sha256
        (base32 "147i3md3nxkjlrccqg4mq1kyzc7yrhvqv5902iibc7znkvzdvlp0"))
       (file-name (git-file-name name version))))
    (build-system cmake-build-system)
    (arguments
     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON"
                           "-DBUILD_TESTING=ON")))
    (home-page "https://gflags.github.io/gflags/")
    (synopsis "C++ library for command-line argument parsing")
    (description
     "Gflags is a C++ library to parse command-line flags.  It differs from
other such libraries in that command-line flag definitions can be scattered
around the source code, and not just listed in one place such as @code{main}.
This means that a single source-code file will define and use flags that are
meaningful to that file.  Any application that links in that file will get the
flags, and the gflags library will automatically handle that flag
appropriately.")
    (license bsd-3)))

(define-public gengetopt
  (package
    (name "gengetopt")
    (version "2.23")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://gnu/gengetopt/gengetopt-"
                           version ".tar.xz"))
       (sha256
        (base32
         "1b44fn0apsgawyqa4alx2qj5hls334mhbszxsy6rfr0q074swhdr"))))
    (build-system gnu-build-system)
    (arguments
     `(#:parallel-build? #f             ; not supported
       #:parallel-tests? #f))           ; likewise
    (native-inputs
     (list texinfo))
    (synopsis "Create parsers for command line options")
    (description
     "GNU Gengetopt is a program to generate a C/C++ function for parsing
command-line options using the getopt_long function found in GNU
libc, removing some of the tedium of this task for large programs
that accept many options.  The options parsed by the generated
function may be in both short (e.g., \"-h\") and long (\"--help\")
formats, as specified by the GNU coding standards.  Additionally, the
output of the standard options \"--help\" and \"--version\" is generated
automatically.")
    (home-page "https://www.gnu.org/software/gengetopt/gengetopt.html")
    (license gpl3+)))
.com> Philip McGrath 2021-12-24gnu: node: Patch shebangs in node_modules....* gnu/packages/node.scm (node)[arguments]: Replace 'patch-npm-shebang and 'patch-node-shebang with a new 'patch-nested-shebangs that also handles node-gyp and other shebangs under "/lib/node_modules". [inputs]: Add Python for node-gyp as "python-for-target". (node-lts)[inputs]: Likewise. (libnode)[arguments]: Adjust to delete 'patch-nested-shebangs rather than 'patch-npm-shebang and 'patch-node-shebang. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Philip McGrath 2021-12-24gnu: node: Update to 10.24.1 for bootstrapping....* gnu/packages/node.scm (node): Update to 10.24.1. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Philip McGrath 2021-12-24gnu: node: Avoid duplicating build phases....* gnu/packages/node.scm (node)[arguments]: Split 'patch-files phase into 'patch-hardcoded-program-references and 'delete-problematic-tests. Adapt 'patch-hardcoded-program-references and 'configure to work unmodified on node-lts, but don't try to share 'delete-problematic-tests, because those details seem to change too much between node versions. (node, node-lts)[inputs]: Use bash-minimal rather than bash. (node-lts)[arguments]: Inherit 'patch-hardcoded-program-references, and 'configure phases from the bootstrap node. Remove the 'patch-files phase, keeping its remaining non-inherited work in a new 'replace-llhttp-sources phase. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Philip McGrath 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-15gnu: node-lts: Update to 14.18.1 [security fixes]....* gnu/packages/node.scm (node-lts): Update to 14.18.1. [native-inputs]: Replace c-ares with c-ares-for-node. [inputs]: Replace c-ares with c-ares-for-node. Includes fixes for CVE-2021-22918, CVE-2021-22930, CVE-2021-22931, CVE-2021-22939, and CVE-2021-22940. Jelle Licht 2021-11-15gnu: llhttp-bootstrap: Update to 2.1.4 [security-fixes]....* gnu/packages/node.scm (llhttp-bootstrap): Update to 2.1.4. Includes fixes for CVE-2021-22959 and CVE-2021-22960. Jelle Licht 2021-11-15gnu: node: Add cpe-name....* gnu/packages/node.scm (node)[properties]: Add cpe-name. Jelle Licht 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke 2021-10-13gnu: Rename google-brotli back to brotli....Sorry for the noise, but good riddance. Our nonstandard name for this package has caused confusion since it was added. For example, the duplicate python-brotli and python-google-brotli packages added later, with the latter name making even less sense. The Python packages will be fixed in the next commit. * gnu/packages/compression.scm (google-brotli): Redefine as a deprecated-package, with… (brotli): …restored to canonical status. (python-google-brotli)[inherit]: Adjust accordingly. * gnu/packages/databases.scm (apache-arrow)[inputs]: Adjust accordingly. * gnu/packages/fontutils.scm (woff2)[inputs]: Likewise. * gnu/packages/gnome.scm (libsoup)[propagated-inputs]: Likewise. * gnu/packages/networking (wireshark)[inputs]: Likewise. * gnu/packages/node.scm (node-lts)[arguments, native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-imagecodecs)[inputs]: Likewise. Tobias Geerinckx-Rice 2021-10-10gnu: llhttp: Fix build....* gnu/packages/node.scm (llhttp-bootstrap)[arguments]: Add missing keyword argument to 'configure' phase. Guillaume Le Vaillant 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-09-02gnu: node: Enable cross-compilation....Node runs parts of itself on the host for bootstraping therefore for cross-compiling support we need to fidle with the rpath in the build system, as well as duplicating some of the dependencies as native-inputs and inputs. * gnu/pakcages/node.scm (node)[arguments]: Refer to /bin/sh and /bin/env directly instead of using (which). Add new 'set-bootstrap-host-rpath phase to correctly set the rpath for binaries that are meant to run on the host. Pass --cross-compiling and --dest-cpu to configure script if needed. Set the CC_host, CXX_host, CC, CCX and PKG_CONFIG variable for cross-compilation. Refer to the host python. Do not return #t from any phases. [native-inputs]: Add c-ares, http-parser, icu4c, libuv, nghttp2, openssl and zlib. Remove which. [inputs]: Add bash and coreutils. (llhttp-bootstrap)[arguments]: Refer to esbuild via (or native-inputs inputs). (node-lts)[arguments]: Add new 'set-bootstrap-host-rpath phase to correctly set the rpath for host binaries. Pass --cross-compiling and --dest-cpu to configure script if needed. Set the CC_host, CXX_host, CCX and PKG_CONFIG variable for cross-compilation. Refer to the host python. Do not return #t from any phases. Refer to /bin/sh and /bin/env directly instead of using (which). Do not return #t from any phases. [native-inputs]: Hardcode native inputs instead of inheriting them from node. [inputs]: Add bash and coreutils. Pierre Langlois